Bug 300742 - Plenty of Knotify crash at logon
Summary: Plenty of Knotify crash at logon
Status: RESOLVED DUPLICATE of bug 293951
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: knotify (show other bugs)
Version: 4.0
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Olivier Goffart
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-28 06:46 UTC by Ákos Mattiassich
Modified: 2012-12-19 13:02 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.54 KB, text/plain)
2012-12-19 13:02 UTC, Kirill
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ákos Mattiassich 2012-05-28 06:46:35 UTC
Application: knotify4 (4.0)
KDE Platform Version: 4.8.3 (4.8.3)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-25-generic i686
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:
I simply login, then comes many Knotify crash report.  They comes always after i start an app.

The crash can be reproduced every time.

-- Backtrace:
Application: KNotify (knotify4), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb7717740 (LWP 31741))]

Thread 2 (Thread 0xb6610b40 (LWP 31748)):
#0  0x4311e8b7 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0x00000000 in ?? ()

Thread 1 (Thread 0xb7717740 (LWP 31741)):
[KCrash Handler]
#7  Phonon::Gstreamer::Pipeline::setState (this=0x0, state=GST_STATE_PLAYING) at ../../gstreamer/pipeline.cpp:220
#8  0x0064a08e in Phonon::Gstreamer::MediaObject::requestState (this=0x8c3e5f8, state=Phonon::PlayingState) at ../../gstreamer/mediaobject.cpp:785
#9  0x0064a127 in Phonon::Gstreamer::MediaObject::play (this=0x8c3e5f8) at ../../gstreamer/mediaobject.cpp:231
#10 0x46386900 in Phonon::MediaObject::play (this=0x8b020e0) at ../../phonon/mediaobject.cpp:113
#11 0x08054a2c in play (file=..., this=<optimized out>) at ../../knotify/notifybysound.cpp:63
#12 notify (config=0x8b05220, eventId=34, this=0x8abd348) at ../../knotify/notifybysound.cpp:245
#13 NotifyBySound::notify (this=0x8abd348, eventId=34, config=0x8b05220) at ../../knotify/notifybysound.cpp:197
#14 0x080514c1 in KNotify::emitEvent (this=0xbfe0c798, e=0x8b05218) at ../../knotify/knotify.cpp:230
#15 0x0805234c in KNotify::event (this=0xbfe0c798, event=..., appname=..., contexts=..., title=..., text=..., image=..., actions=..., timeout=-1, winId=0) at ../../knotify/knotify.cpp:149
#16 0x0805289a in KNotifyAdaptor::event (this=0x8ab9fd0, event=..., fromApp=..., contexts=..., title=..., text=..., image=..., actions=..., timeout=-1, winId=0) at ../../knotify/knotify.cpp:289
#17 0x08052d0a in qt_static_metacall (_a=0xbfe0be1c, _id=4, _o=0x8ab9fd0, _c=<optimized out>) at ./knotify.moc:218
#18 KNotifyAdaptor::qt_static_metacall (_o=0x8ab9fd0, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbfe0be1c) at ./knotify.moc:208
#19 0x08052e64 in KNotifyAdaptor::qt_metacall (this=0x8ab9fd0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe0be1c) at ./knotify.moc:260
#20 0x43c2df98 in QDBusConnectionPrivate::deliverCall (this=0x893f928, object=0x8ab9fd0, msg=..., metaTypes=..., slotIdx=0) at qdbusintegrator.cpp:947
#21 0x43c2f1e0 in QDBusConnectionPrivate::activateCall (this=0x893f928, object=0x8ab9fd0, flags=273, msg=...) at qdbusintegrator.cpp:857
#22 0x43c2f9ab in QDBusConnectionPrivate::activateObject (this=0x893f928, node=..., msg=..., pathStartPos=-1075789968) at qdbusintegrator.cpp:1443
#23 0x43c2fd48 in QDBusActivateObjectEvent::placeMetaCall (this=0x8b05820) at qdbusintegrator.cpp:1537
#24 0x4392b1bb in QObject::event (this=0xbfe0c798, e=0x8b05820) at kernel/qobject.cpp:1195
#25 0x44212654 in notify_helper (e=0x8b05820, receiver=0xbfe0c798, this=0x894f680) at kernel/qapplication.cpp:4559
#26 QApplicationPrivate::notify_helper (this=0x894f680, receiver=0xbfe0c798, e=0x8b05820) at kernel/qapplication.cpp:4531
#27 0x44217a8d in QApplication::notify (this=0x8b05820, receiver=0xbfe0c798, e=0x8b05820) at kernel/qapplication.cpp:4288
#28 0x44daa4e1 in KApplication::notify (this=0xbfe0c7ac, receiver=0xbfe0c798, event=0x8b05820) at ../../kdeui/kernel/kapplication.cpp:311
#29 0x4390febe in QCoreApplication::notifyInternal (this=0xbfe0c7ac, receiver=0xbfe0c798, event=0x8b05820) at kernel/qcoreapplication.cpp:876
#30 0x43914018 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#31 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x892aa40) at kernel/qcoreapplication.cpp:1500
#32 0x4391434c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#33 0x439429d4 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#34 postEventSourceDispatch (s=0x8950ba0) at kernel/qeventdispatcher_glib.cpp:279
#35 0x4314fcda in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#36 0x431500e5 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#37 0x431501c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x43942dc7 in QEventDispatcherGlib::processEvents (this=0x892b5c0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#39 0x442cb22a in QGuiEventDispatcherGlib::processEvents (this=0x892b5c0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#40 0x4390ea4d in QEventLoop::processEvents (this=0xbfe0c6f4, flags=...) at kernel/qeventloop.cpp:149
#41 0x4390ece9 in QEventLoop::exec (this=0xbfe0c6f4, flags=...) at kernel/qeventloop.cpp:204
#42 0x439143fa in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#43 0x442101f4 in QApplication::exec () at kernel/qapplication.cpp:3820
#44 0x0804f568 in main (argc=<error reading variable: Cannot access memory at address 0x0>, argv=<error reading variable: Cannot access memory at address 0x4>) at ../../knotify/main.cpp:73

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-05-28 09:14:57 UTC

*** This bug has been marked as a duplicate of bug 290706 ***
Comment 2 Myriam Schweingruber 2012-11-10 16:32:35 UTC
Wrong duplicate

*** This bug has been marked as a duplicate of bug 293951 ***
Comment 3 Kirill 2012-12-19 13:02:13 UTC
Created attachment 75926 [details]
New crash information added by DrKonqi

knotify4 (4.0) on KDE Platform 4.9.3 using Qt 4.8.3

- What I was doing when the application crashed:

i'm just logon, and i see a error message
and when i was writing about this bug, i some errors like this (when some notification window was shown)
and this errors i can see when i logout or shutdown

-- Backtrace (Reduced):
#6  Phonon::Gstreamer::Pipeline::setState (this=0x0, state=GST_STATE_PLAYING) at ../../gstreamer/pipeline.cpp:236
#7  0x00007f0b04c464e2 in Phonon::Gstreamer::MediaObject::requestState (this=this@entry=0x28a2380, state=state@entry=Phonon::PlayingState) at ../../gstreamer/mediaobject.cpp:839
#8  0x00007f0b04c467b4 in Phonon::Gstreamer::MediaObject::play (this=0x28a2380) at ../../gstreamer/mediaobject.cpp:239
#9  0x000000000040e5d9 in play (file=..., this=<optimized out>) at ../../knotify/notifybysound.cpp:63
#10 NotifyBySound::notify (this=0x25bfbe0, eventId=4, config=0x2612d58) at ../../knotify/notifybysound.cpp:245