Bug 300633 - smokekde fails to build with soprano 2.8
Summary: smokekde fails to build with soprano 2.8
Status: RESOLVED UPSTREAM
Alias: None
Product: bindings
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kde-bindings
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-25 22:29 UTC by Andrea Scarpino
Modified: 2012-06-10 11:08 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrea Scarpino 2012-05-25 22:29:10 UTC
[ 71%] Building CXX object soprano/CMakeFiles/smokesoprano.dir/smokedata.o
In file included from /build/src/build/soprano/smokedata.cpp:1:0:
/build/src/smokekde-4.8.80/soprano/soprano_includes.h:54:31: fatal error: soprano/tcpclient.h: No such file or directory
compilation terminated.
make[2]: *** [soprano/CMakeFiles/smokesoprano.dir/smokedata.o] Error 1
make[1]: *** [soprano/CMakeFiles/smokesoprano.dir/all] Error 2
make: *** [all] Error 2

Reproducible: Always

Steps to Reproduce:
1. Build and install soprano from git
2. Try to build smokekde
Actual Results:  
The build fails


soprano from git
smokekde from git
Comment 1 Arno Rehn 2012-06-10 11:00:22 UTC
This is because soprano from git has broken BC and SC. It should have been fixed with these commits:

http://gitweb.kde.org/index.php?p=soprano.git&a=commit&h=11936faea72ec13f9890c7f474ee21c9c3aa37cf
http://gitweb.kde.org/index.php?p=soprano.git&a=commit&h=ed17a950a9c6f83590fa62cb97e7278ba7f3e234

Works for me.