Bug 300445 - Integration with cloud storage (as Dropbox or GDrive) for quick sharing
Summary: Integration with cloud storage (as Dropbox or GDrive) for quick sharing
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Plugin-WebService-DropBox (show other bugs)
Version: 3.0.0
Platform: unspecified Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
: 275016 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-05-22 09:52 UTC by Patkos Csaba
Modified: 2018-02-04 07:42 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patkos Csaba 2012-05-22 09:52:15 UTC
This is a wish for a kipi plugin that would integrate with dropbox for quickly sharing pictures. More specifically, it would be really cool to have something like this: http://kde-look.org/content/show.php?content=124416

Reproducible: Always
Comment 1 Smit Mehta 2012-07-04 11:23:50 UTC
Hi Patkos, Gilles

It is a very good idea as well as necessary seeing the popularity of dropbox.
@Gilles, if you know any student who wants some work, he can start working towards this. Or I can take up this job after my GSoC?

Smit
Comment 2 caulier.gilles 2012-07-04 12:08:46 UTC
Smit,

Nobody is planed to work on DropBox Support yet.

So it's fine for me to start on it after GOSC 2012.

Gilles
Comment 3 caulier.gilles 2012-07-04 12:11:10 UTC
I would like to see more than Dropbox share support in kipi-plugins. For ex, i use GDrive which is another cloud media.

Both provide API to code opensource solution...

Gilles Caulier
Comment 4 Jekyll Wu 2012-08-16 03:27:08 UTC
*** Bug 275016 has been marked as a duplicate of this bug. ***
Comment 5 sreedhar palayil 2013-03-12 05:15:50 UTC
hi,
i'm a student (2nd year, Bsc computer science, university of calicut).
i don't have any previous experience in open source programming. I
know C and C++  and also started studying
QT recently, so i feel this idea will be better for me because
of the Knowledge Prerequisite, i like to this project with you in
GSoC2013. if you help me to do, i'm ready and do i need anymore
qualities?
from
 sreedharpalayil@gmail.com
Comment 6 sreedhar palayil 2013-03-12 05:15:50 UTC
hi,
i'm a student (2nd year, Bsc computer science, university of calicut).
i don't have any previous experience in open source programming. I
know C and C++  and also started studying
QT recently, so i feel this idea will be better for me because
of the Knowledge Prerequisite, i like to this project with you in
GSoC2013. if you help me to do, i'm ready and do i need anymore
qualities?
from
 sreedharpalayil@gmail.com
Comment 7 Juergen Karbach 2013-03-15 09:44:57 UTC
Hi,

please don't forget integrating ownCloud.
Because, it allows to host data everywehere.
Even in a home cloud.
Is it so different to DropBox?
Comment 8 NISHITA 2013-04-18 17:08:32 UTC
Hi

I am 2nd year B.Tech in Information Technology , Student of Delhi Technological University , New Delhi .Few days back  I  started working on Google API's . I know c and c++ and have worked on Qt also (though very less but have knowledge) . I would like to work on cloud integration export plugin project with you in GSoC 2013 . So , please guide me to what contribution I should do for the proposal of this project in GSOC 2013 .

Nishita Tanwar
nishitatanwar@yahoo.co.in
Comment 9 Smit Mehta 2013-04-18 17:19:45 UTC
Hi Nishita

This is Smit here. I am mentoring this project. Kindly mail me at smit.meh@gmail.com.

Smit
Comment 10 Govind kumar 2013-04-20 08:13:58 UTC
Hi,
 I know C and C++  and also 
QT , so i feel  that this idea will be best for me because
of the Knowledge Prerequisite, i like to this project with you in
G Soc 2013. 

Govind kumar
91govindkumar@gmail.com
Comment 11 Sisira 2013-08-20 05:27:49 UTC
(In reply to comment #10)
> Hi,
>  I know C and C++  and also 
> QT , so i feel  that this idea will be best for me because
> of the Knowledge Prerequisite, i like to this project with you in
> G Soc 2013. 
> 
> Govind kumar
> 91govindkumar@gmail.com
Comment 12 Alexander Potashev 2013-08-20 15:27:15 UTC
It looks like the GSOC2013 project for this feature has been accepted. I know it's too late, but in my opinion integration between KDE and could storages would be better if done via KIO Slaves, and then a KIPI Export Plugin can just use any KIO Slave. By having a KIO Slave for cloud storage services, we immediately gain support for those in Dolphin, Krusader and all other KDE applications, not just Digikam, Gwenview and KPhotoAlbum.
Comment 13 caulier.gilles 2013-11-20 08:52:35 UTC
Gdrive and DropBox tool are now integrated in next digiKam SC 4.0.0

Gilles Caulier
Comment 14 Patkos Csaba 2013-11-20 08:59:52 UTC
Cool. I was waiting for this. Great job.


On Wed, Nov 20, 2013 at 10:52 AM, Gilles Caulier
<caulier.gilles@gmail.com>wrote:

> https://bugs.kde.org/show_bug.cgi?id=300445
>
> Gilles Caulier <caulier.gilles@gmail.com> changed:
>
>            What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>              Status|UNCONFIRMED                 |RESOLVED
>    Version Fixed In|                            |4.0.0
>          Resolution|---                         |FIXED
>       Latest Commit|                            |
> http://commits.kde.org/kipi
>                    |
>  |-plugins/b3c4d4fb7d1dccfda5
>                    |                            |10a97830166006a424a950
>
> --- Comment #13 from Gilles Caulier <caulier.gilles@gmail.com> ---
> Gdrive and DropBox tool are now integrated in next digiKam SC 4.0.0
>
> Gilles Caulier
>
> --
> You are receiving this mail because:
> You reported the bug.
>