Bug 300191 - GREPME MySQLe query failed! (2000) on init
Summary: GREPME MySQLe query failed! (2000) on init
Status: RESOLVED DUPLICATE of bug 298425
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.5.0
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-17 11:36 UTC by stefan fischer
Modified: 2012-05-17 15:27 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description stefan fischer 2012-05-17 11:36:31 UTC
Application: amarok (2.5.0)
KDE Platform Version: 4.8.3 (4.8.3) "release 4"
Qt Version: 4.8.1
Operating System: Linux 3.3.4-22-default x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
simply started amarok 
os: opensuse 64 bit current + tumbleweed

The crash can be reproduced every time.

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f8cc2882760 (LWP 10456))]

Thread 2 (Thread 0x7f8c9d54e700 (LWP 10563)):
[KCrash Handler]
#6  0x00007f8ca192d89b in DirWatchJob::run (this=0x256b8c0) at /usr/src/debug/amarok-2.5.0/src/core-impl/collections/db/ScanManager.cpp:372
#7  0x00007f8cbc67e8db in ThreadWeaver::JobRunHelper::runTheJob (this=0x7f8c9d54ddc0, th=0x25c7140, job=0x256b8c0) at /usr/src/debug/kdelibs-4.8.3/threadweaver/Weaver/Job.cpp:106
#8  0x00007f8cbc67ea4c in ThreadWeaver::Job::execute (this=0x256b8c0, th=0x25c7140) at /usr/src/debug/kdelibs-4.8.3/threadweaver/Weaver/Job.cpp:135
#9  0x00007f8cbc67e09f in ThreadWeaver::ThreadRunHelper::run (this=0x7f8c9d54de40, parent=0x1f24f60, th=0x25c7140) at /usr/src/debug/kdelibs-4.8.3/threadweaver/Weaver/Thread.cpp:95
#10 0x00007f8cbc67e15b in ThreadWeaver::Thread::run (this=0x25c7140) at /usr/src/debug/kdelibs-4.8.3/threadweaver/Weaver/Thread.cpp:142
#11 0x00007f8cc068a56b in QThreadPrivate::start (arg=0x25c7140) at thread/qthread_unix.cpp:298
#12 0x00007f8cbd2a0f05 in start_thread () from /lib64/libpthread.so.0
#13 0x00007f8cbf15a10d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f8cc2882760 (LWP 10456)):
#0  0x00007f8cbf14c18d in read () from /lib64/libc.so.6
#1  0x00007f8cb7a8e17f in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f8cb7a4c232 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f8cb7a4cb02 in ?? () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f8cb7a4cfa9 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#5  0x00007f8cc07b727f in QEventDispatcherGlib::processEvents (this=0x1c01000, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#6  0x00007f8cbfbb076e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#7  0x00007f8cc0787012 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#8  0x00007f8cc0787267 in QEventLoop::exec (this=0x7fff5250ac70, flags=...) at kernel/qeventloop.cpp:204
#9  0x00007f8cbffd89d6 in QDialog::exec (this=0x24e1ec0) at dialogs/qdialog.cpp:554
#10 0x00007f8cc220464a in KMessageBox::createKMessageBox (dialog=<optimized out>, icon=<optimized out>, text=..., strlist=<optimized out>, ask=..., checkboxReturn=0x0, options=..., details=..., notifyType=QMessageBox::Critical) at /usr/src/debug/kdelibs-4.8.3/kdeui/dialogs/kmessagebox.cpp:344
#11 0x00007f8cc2204e24 in KMessageBox::createKMessageBox (dialog=0x24e1ec0, icon=QMessageBox::Critical, text=..., strlist=..., ask=..., checkboxReturn=0x0, options=..., details=...) at /usr/src/debug/kdelibs-4.8.3/kdeui/dialogs/kmessagebox.cpp:159
#12 0x00007f8cc2205b1b in KMessageBox::errorListWId (parent_id=0, text=..., strlist=..., caption=..., options=...) at /usr/src/debug/kdelibs-4.8.3/kdeui/dialogs/kmessagebox.cpp:854
#13 0x00007f8cc2205d3b in KMessageBox::error (parent=<optimized out>, text=..., caption=..., options=<optimized out>) at /usr/src/debug/kdelibs-4.8.3/kdeui/dialogs/kmessagebox.cpp:821
#14 0x00007f8ca19339aa in Collections::SqlCollection::SqlCollection (this=<optimized out>, id=..., prettyName=<optimized out>, storage=0x24b7250) at /usr/src/debug/amarok-2.5.0/src/core-impl/collections/db/sql/SqlCollection.cpp:176
#15 0x00007f8ca193568f in Collections::SqlCollectionFactory::createSqlCollection (this=<optimized out>, id=..., prettyName=..., storage=0x24b7250) at /usr/src/debug/amarok-2.5.0/src/core-impl/collections/db/sql/SqlCollectionFactory.cpp:31
#16 0x00007f8ca1b9436a in Collections::MySqlEmbeddedCollectionFactory::init (this=0x24cf8f0) at /usr/src/debug/amarok-2.5.0/src/core-impl/collections/db/sql/mysqlecollection/MySqlEmbeddedCollection.cpp:35
#17 0x00007f8cc172bed9 in CollectionManager::loadPlugins (this=0x2476180, factories=<optimized out>) at /usr/src/debug/amarok-2.5.0/src/core-impl/collections/support/CollectionManager.cpp:207
#18 0x00007f8cc172f484 in CollectionManager::init (this=0x2476180, factories=<optimized out>) at /usr/src/debug/amarok-2.5.0/src/core-impl/collections/support/CollectionManager.cpp:175
#19 0x00007f8cc18a548a in Plugins::PluginManager::init (this=0x246d0e0) at /usr/src/debug/amarok-2.5.0/src/PluginManager.cpp:82
#20 0x00007f8cc18a66a9 in Plugins::PluginManager::PluginManager (this=0x246d0e0, parent=<optimized out>) at /usr/src/debug/amarok-2.5.0/src/PluginManager.cpp:64
#21 0x00007f8cc18a6877 in Plugins::PluginManager::instance () at /usr/src/debug/amarok-2.5.0/src/PluginManager.cpp:43
#22 0x00007f8cc18884bd in pluginManager () at /usr/src/debug/amarok-2.5.0/src/PluginManager.h:76
#23 MainWindow::MainWindow (this=0x246d1b0) at /usr/src/debug/amarok-2.5.0/src/MainWindow.cpp:139
#24 0x00007f8cc186096f in App::continueInit (this=0x7fff5250c0f0) at /usr/src/debug/amarok-2.5.0/src/App.cpp:545
#25 0x00007f8cc186205c in App::App (this=0x7fff5250c0f0) at /usr/src/debug/amarok-2.5.0/src/App.cpp:185
#26 0x0000000000409085 in main (argc=1, argv=0x7fff5250e578) at /usr/src/debug/amarok-2.5.0/src/main.cpp:301

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2012-05-17 15:27:28 UTC
Please talk to your distribution, apparently the MySQL version provided doesn't have mysqle needed by Amarok. 

A workaround would be to downgrade your MySQL version to before 5.5.23

*** This bug has been marked as a duplicate of bug 298425 ***