Bug 300051 - Movie doesn't autostart in pdf created with LaTeX multimedia and pdflatex
Summary: Movie doesn't autostart in pdf created with LaTeX multimedia and pdflatex
Status: RESOLVED FIXED
Alias: None
Product: okular
Classification: Unclassified
Component: PDF backend (show other bugs)
Version: 0.12.5
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-15 10:26 UTC by Oliver Sander
Modified: 2013-04-11 09:59 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.10


Attachments
Test file that reproduces the error (14.17 KB, application/octet-stream)
2012-05-15 10:28 UTC, Oliver Sander
Details
tex sources (1.44 KB, text/x-tex)
2012-05-15 10:28 UTC, Oliver Sander
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Sander 2012-05-15 10:26:27 UTC
Movies embedded into pdf files using latex and the 'multimedia' package do not autostart even though being told to do so if the tex sources are compiled using pdflatex.

Note: it does work when you compile the tex sources with latex -> dvips -> ps2pdf.  That's a different code path.

You need latex-beamer (which multimedia.sty is a part of) in at least version 3.18.  See the discussion here: https://bitbucket.org/rivanvx/beamer/issue/188/autostart-of-video-files-not-working

This may actually be a poppler issue.  Please apologize if I posted in the wrong spot.

Reproducible: Always
Comment 1 Oliver Sander 2012-05-15 10:28:06 UTC
Created attachment 71098 [details]
Test file that reproduces the error
Comment 2 Oliver Sander 2012-05-15 10:28:36 UTC
Created attachment 71099 [details]
tex sources
Comment 3 Oliver Sander 2012-05-15 10:31:47 UTC
The actual movie I used in the pdf is too large to upload it here.  I put it on http://page.mi.fu-berlin.de/sander/data/test_movie.mpg
Comment 4 Tobias Koenig 2012-09-21 08:51:16 UTC
Git commit 770e2818bb149211330ddbc35877c20624a71862 by Tobias Koenig.
Committed on 16/08/2012 at 11:53.
Pushed by tokoe into branch 'master'.

Evaluate additional actions of screen and widget annotations

This fixes the auto-start feature of PDFs generated with the LaTeX movie
package, which uses the additional action of a widget annotation to start
the movie when entering the page.
REVIEW: 106430
FIXED-IN: 4.10

M  +4    -0    cmake/modules/FindPoppler.cmake
M  +147  -0    core/annotations.cpp
M  +127  -0    core/annotations.h
M  +7    -0    generators/poppler/annots.cpp
M  +47   -0    generators/poppler/generator_pdf.cpp
M  +6    -0    ui/guiutils.cpp
M  +28   -0    ui/presentationwidget.cpp

http://commits.kde.org/okular/770e2818bb149211330ddbc35877c20624a71862
Comment 5 Mrinal Kalakrishnan 2013-04-11 08:07:36 UTC
I'm using poppler 0.20.5 and okular 0.16.2, and I still have this problem. Could someone confirm that the test file still works on the latest versions?
Comment 6 Oliver Sander 2013-04-11 09:44:03 UTC
It still works for me, using the latest dev versions of poppler and okular.

Are you using the correct version of multimedia.sty?  (see above)

Also: you need to be in presentation mode for autostart to work.  Somewhere (don't recall where exactly) we decided that autostarting movies in non-presentation mode are too aggressive.
Comment 7 Mrinal Kalakrishnan 2013-04-11 09:59:04 UTC
(In reply to comment #6)
> Are you using the correct version of multimedia.sty?  (see above)

Yes, I'm using Beamer 3.26, and I've verified that the multimedia.sty being used contains the code in the patch linked above.
 
> Also: you need to be in presentation mode for autostart to work.  Somewhere
> (don't recall where exactly) we decided that autostarting movies in
> non-presentation mode are too aggressive.

Auto-start works when I compile the tex file using latex -> dvips -> pstopdf, but not with pdflatex. 

Thanks for verifying that it still works for you. This could be due to my system being a weird mix of back-ported packages and libraries. For now, the tex->dvi->ps->pdf workaround is good enough for my needs.