Bug 299915 - Leave a keynote
Summary: Leave a keynote
Status: RESOLVED DUPLICATE of bug 297415
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-13 03:34 UTC by rubenalamilla
Modified: 2012-05-14 17:54 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rubenalamilla 2012-05-13 03:34:29 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.8.2 (4.8.2) (Compiled from sources)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic-pae i686
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
-i leave a keynote when the plasma desktop crashed; clic 2 times

-- Backtrace:
Application: Shell de escritorio Plasma (plasma-desktop), signal: Aborted
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb1a21740 (LWP 1600))]

Thread 5 (Thread 0xae713b40 (LWP 1601)):
#0  0xb2bcfdcd in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0xb62d3315 in do_gettime (frac=0xae712fb0, sec=0xae712fa8) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb63bd226 in QTimerInfoList::updateCurrentTime (this=0xade02074) at kernel/qeventdispatcher_unix.cpp:343
#4  0xb63bd57a in QTimerInfoList::timerWait (this=0xade02074, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#5  0xb63bbe23 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xae7130bc) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb63bbebd in timerSourcePrepare (source=0xade02040, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb2b18762 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb2b18f6f in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb2b191c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb63bc8e7 in QEventDispatcherGlib::processEvents (this=0xade00468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#11 0xb638850d in QEventLoop::processEvents (this=0xae713240, flags=...) at kernel/qeventloop.cpp:149
#12 0xb63887a9 in QEventLoop::exec (this=0xae713240, flags=...) at kernel/qeventloop.cpp:204
#13 0xb627194c in QThread::exec (this=0x9a33af8) at thread/qthread.cpp:501
#14 0xb6365b5d in QInotifyFileSystemWatcherEngine::run (this=0x9a33af8) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb6274de0 in QThreadPrivate::start (arg=0x9a33af8) at thread/qthread_unix.cpp:298
#16 0xb2c29d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0xb7598ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 4 (Thread 0xa8bddb40 (LWP 1602)):
#0  socketNotifierSourcePrepare (timeout=0xa8bdd0bc) at kernel/qeventdispatcher_glib.cpp:73
#1  0xb2b18762 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb2b18f6f in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb2b191c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb63bc8e7 in QEventDispatcherGlib::processEvents (this=0xa8200468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0xb638850d in QEventLoop::processEvents (this=0xa8bdd240, flags=...) at kernel/qeventloop.cpp:149
#6  0xb63887a9 in QEventLoop::exec (this=0xa8bdd240, flags=...) at kernel/qeventloop.cpp:204
#7  0xb627194c in QThread::exec (this=0x9a79fe8) at thread/qthread.cpp:501
#8  0xb6365b5d in QInotifyFileSystemWatcherEngine::run (this=0x9a79fe8) at io/qfilesystemwatcher_inotify.cpp:248
#9  0xb6274de0 in QThreadPrivate::start (arg=0x9a79fe8) at thread/qthread_unix.cpp:298
#10 0xb2c29d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#11 0xb7598ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xa7144b40 (LWP 1608)):
#0  0xb76e7424 in __kernel_vsyscall ()
#1  0xb2c2d96b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb75a63dc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb3bea029 in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#4  0xb3bea06f in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#5  0xb2c29d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0xb7598ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xa5b66b40 (LWP 1610)):
#0  0xb76e7414 in __kernel_vsyscall ()
#1  0xb758817b in read () from /lib/i386-linux-gnu/libc.so.6
#2  0xb2b5766e in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb2b18af0 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb2b19002 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb2b1952b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xa64370ea in ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
#7  0xb2b3c673 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb2c29d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#9  0xb7598ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb1a21740 (LWP 1600)):
[KCrash Handler]
#7  0xb76e7424 in __kernel_vsyscall ()
#8  0xb74dc1ef in raise () from /lib/i386-linux-gnu/libc.so.6
#9  0xb74df835 in abort () from /lib/i386-linux-gnu/libc.so.6
#10 0xb75172fa in ?? () from /lib/i386-linux-gnu/libc.so.6
#11 0xb75addd5 in __fortify_fail () from /lib/i386-linux-gnu/libc.so.6
#12 0xb75acbaa in __chk_fail () from /lib/i386-linux-gnu/libc.so.6
#13 0xb75add6a in __fdelt_warn () from /lib/i386-linux-gnu/libc.so.6
#14 0xb6361443 in QProcessPrivate::waitForStarted (this=0xb206558, msecs=30000) at io/qprocess_unix.cpp:1038
#15 0xb6315e94 in QProcess::waitForStarted (this=0xbfa8cab8, msecs=30000) at io/qprocess.cpp:1687
#16 0xaed677d5 in LeaveNote::slotSend (this=0x979f410) at ../../../applets/leavenote/leavenote.cpp:218
#17 0xb63a06b1 in QMetaObject::activate (sender=0x9fbc988, m=0xb74a7064, local_signal_index=2, argv=0x0) at kernel/qobject.cpp:3547
#18 0xb737ff05 in Plasma::PushButton::clicked (this=0x9fbc988) at ./pushbutton.moc:195
#19 0xb7380140 in qt_static_metacall (_a=0xbfa8cdf8, _id=2, _o=0x9fbc988, _c=<optimized out>) at ./pushbutton.moc:84
#20 Plasma::PushButton::qt_static_metacall (_o=0x9fbc988, _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbfa8cdf8) at ./pushbutton.moc:76
#21 0xb63a06b1 in QMetaObject::activate (sender=0x9fbdd88, m=0xb62007c8, local_signal_index=2, argv=0xbfa8cdf8) at kernel/qobject.cpp:3547
#22 0xb5fac96d in QAbstractButton::clicked (this=0x9fbdd88, _t1=false) at .moc/release-shared/moc_qabstractbutton.cpp:220
#23 0xb5ca061d in QAbstractButtonPrivate::emitClicked (this=0x9fc6e78) at widgets/qabstractbutton.cpp:548
#24 0xb5ca1c8b in QAbstractButtonPrivate::click (this=0x9fc6e78) at widgets/qabstractbutton.cpp:541
#25 0xb5ca1f46 in QAbstractButton::mouseReleaseEvent (this=0x9fbdd88, e=0xb082070) at widgets/qabstractbutton.cpp:1123
#26 0xb58cf1ac in QWidget::event (this=0x9fbdd88, event=0xb082070) at kernel/qwidget.cpp:8362
#27 0xb5ca11e9 in QAbstractButton::event (this=0x9fbdd88, e=0xb082070) at widgets/qabstractbutton.cpp:1082
#28 0xb5d44758 in QPushButton::event (this=0x9fbdd88, e=0xb082070) at widgets/qpushbutton.cpp:683
#29 0xb5874ed4 in notify_helper (e=0xb082070, receiver=0x9fbdd88, this=0x9247c48) at kernel/qapplication.cpp:4559
#30 QApplicationPrivate::notify_helper (this=0x9247c48, receiver=0x9fbdd88, e=0xb082070) at kernel/qapplication.cpp:4531
#31 0xb587b024 in QApplication::notify (this=0x9247c48, receiver=0x9fbdd88, e=0xb082070) at kernel/qapplication.cpp:4102
#32 0xb6a23b21 in KApplication::notify (this=0x9235290, receiver=0x9fbdd88, event=0xb082070) at ../../kdeui/kernel/kapplication.cpp:311
#33 0xb638997e in QCoreApplication::notifyInternal (this=0x9235290, receiver=0x9fbdd88, event=0xb082070) at kernel/qcoreapplication.cpp:876
#34 0xb5875e95 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#35 QApplicationPrivate::sendMouseEvent (receiver=0x9fbdd88, event=0xb082070, alienWidget=0x0, nativeWidget=0x9fbdd88, buttonDown=0xbfa8d528, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3170
#36 0xb5f162ec in QGraphicsProxyWidgetPrivate::sendWidgetMouseEvent (this=0x9fbea28, event=0xbfa8dc18) at graphicsview/qgraphicsproxywidget.cpp:283
#37 0xb5ef7aef in QGraphicsItem::sceneEvent (this=0x9fbc990, event=0xbfa8dc18) at graphicsview/qgraphicsitem.cpp:6741
#38 0xb5f55196 in QGraphicsWidget::sceneEvent (this=0x9fbc988, event=0xbfa8dc18) at graphicsview/qgraphicswidget.cpp:1229
#39 0xb5f2130e in sendEvent (event=0xbfa8dc18, item=0x9fbc990, this=<optimized out>) at graphicsview/qgraphicsscene.cpp:1221
#40 QGraphicsScenePrivate::sendEvent (this=0x93a4d60, item=0x9fbc990, event=0xbfa8dc18) at graphicsview/qgraphicsscene.cpp:1197
#41 0xb5f21f43 in QGraphicsScenePrivate::sendMouseEvent (this=0x93a4d60, mouseEvent=0xbfa8dc18) at graphicsview/qgraphicsscene.cpp:1295
#42 0xb5f229a7 in QGraphicsScene::mouseReleaseEvent (this=0x924bf08, mouseEvent=0xbfa8dc18) at graphicsview/qgraphicsscene.cpp:4128
#43 0xb5f3135c in QGraphicsScene::event (this=0x924bf08, event=0xbfa8dc18) at graphicsview/qgraphicsscene.cpp:3458
#44 0xb5874ed4 in notify_helper (e=0xbfa8dc18, receiver=0x924bf08, this=0x9247c48) at kernel/qapplication.cpp:4559
#45 QApplicationPrivate::notify_helper (this=0x9247c48, receiver=0x924bf08, e=0xbfa8dc18) at kernel/qapplication.cpp:4531
#46 0xb587a30d in QApplication::notify (this=0xbfa8dc18, receiver=0x924bf08, e=0xbfa8dc18) at kernel/qapplication.cpp:4288
#47 0xb6a23b21 in KApplication::notify (this=0x9235290, receiver=0x924bf08, event=0xbfa8dc18) at ../../kdeui/kernel/kapplication.cpp:311
#48 0xb638997e in QCoreApplication::notifyInternal (this=0x9235290, receiver=0x924bf08, event=0xbfa8dc18) at kernel/qcoreapplication.cpp:876
#49 0xb5872ced in sendSpontaneousEvent (event=0xbfa8dc18, receiver=0x924bf08) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:234
#50 qt_sendSpontaneousEvent (receiver=0x924bf08, event=0xbfa8dc18) at kernel/qapplication.cpp:5557
#51 0xb5f503d8 in QGraphicsView::mouseReleaseEvent (this=0x9f44318, event=0xbfa8e334) at graphicsview/qgraphicsview.cpp:3338
#52 0xb58cf1ac in QWidget::event (this=0x9f44318, event=0xbfa8e334) at kernel/qwidget.cpp:8362
#53 0xb5cece45 in QFrame::event (this=0x9f44318, e=0xbfa8e334) at widgets/qframe.cpp:557
#54 0xb5d7faa1 in QAbstractScrollArea::viewportEvent (this=0x9f44318, e=0xbfa8e334) at widgets/qabstractscrollarea.cpp:1043
#55 0xb5f5369c in QGraphicsView::viewportEvent (this=0x9f44318, event=0xbfa8e334) at graphicsview/qgraphicsview.cpp:2866
#56 0xb5d821c6 in viewportEvent (this=<optimized out>, event=0xbfa8e334) at widgets/qabstractscrollarea_p.h:100
#57 eventFilter (e=0xbfa8e334, this=<optimized out>, o=<optimized out>) at widgets/qabstractscrollarea_p.h:116
#58 QAbstractScrollAreaFilter::eventFilter (this=0x94ad2b0, o=0x9a1ff98, e=0xbfa8e334) at widgets/qabstractscrollarea_p.h:115
#59 0xb6389b16 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x9247c48, receiver=0x9a1ff98, event=0xbfa8e334) at kernel/qcoreapplication.cpp:986
#60 0xb5874ea2 in notify_helper (e=0xbfa8e334, receiver=0x9a1ff98, this=0x9247c48) at kernel/qapplication.cpp:4555
#61 QApplicationPrivate::notify_helper (this=0x9247c48, receiver=0x9a1ff98, e=0xbfa8e334) at kernel/qapplication.cpp:4531
#62 0xb587b024 in QApplication::notify (this=0x9247c48, receiver=0x9a1ff98, e=0xbfa8e334) at kernel/qapplication.cpp:4102
#63 0xb6a23b21 in KApplication::notify (this=0x9235290, receiver=0x9a1ff98, event=0xbfa8e334) at ../../kdeui/kernel/kapplication.cpp:311
#64 0xb638997e in QCoreApplication::notifyInternal (this=0x9235290, receiver=0x9a1ff98, event=0xbfa8e334) at kernel/qcoreapplication.cpp:876
#65 0xb5875e95 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#66 QApplicationPrivate::sendMouseEvent (receiver=0x9a1ff98, event=0xbfa8e334, alienWidget=0x9a1ff98, nativeWidget=0x9f44318, buttonDown=0xb6209cf4, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3170
#67 0xb5902074 in QETWidget::translateMouseEvent (this=0x9f44318, event=0xbfa8e7ec) at kernel/qapplication_x11.cpp:4617
#68 0xb5900c0d in QApplication::x11ProcessEvent (this=0x9235290, event=0xbfa8e7ec) at kernel/qapplication_x11.cpp:3732
#69 0xb592deac in x11EventSourceDispatch (s=0x924df40, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#70 0xb2b18cda in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#71 0xb2b190e5 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#72 0xb2b191c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#73 0xb63bc887 in QEventDispatcherGlib::processEvents (this=0x91efeb8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#74 0xb592daaa in QGuiEventDispatcherGlib::processEvents (this=0x91efeb8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#75 0xb638850d in QEventLoop::processEvents (this=0xbfa8eae4, flags=...) at kernel/qeventloop.cpp:149
#76 0xb63887a9 in QEventLoop::exec (this=0xbfa8eae4, flags=...) at kernel/qeventloop.cpp:204
#77 0xb638deba in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#78 0xb5872a74 in QApplication::exec () at kernel/qapplication.cpp:3820
#79 0xb769ba7b in kdemain (argc=1, argv=0xbfa8ece4) at ../../../../plasma/desktop/shell/main.cpp:120
#80 0x0804850b in main (argc=1, argv=0xbfa8ece4) at plasma-desktop_dummy.cpp:3

Possible duplicates by query: bug 297415.

Reported using DrKonqi
Comment 1 Anne-Marie Mahfouf 2012-05-14 17:54:56 UTC
Fixed in KDE 4.8.3, thanks for your report.

*** This bug has been marked as a duplicate of bug 297415 ***