Bug 299863 - Network connections crashed when added wireless profile with wpa enterprise
Summary: Network connections crashed when added wireless profile with wpa enterprise
Status: RESOLVED FIXED
Alias: None
Product: Network Management
Classification: Unclassified
Component: Control Module (show other bugs)
Version: 0.9
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Lamarque V. Souza
URL:
Keywords:
: 300512 307496 315857 322203 322861 323106 325553 326129 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-05-12 09:03 UTC by artur.cuvasov
Modified: 2014-05-12 12:16 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In: 0.9.0.10


Attachments
crash dump as root with qdbus working (4.63 KB, application/octet-stream)
2012-07-11 11:21 UTC, artur.cuvasov
Details
networkmanagement-0.9.0.6 crash dump (4.53 KB, text/plain)
2013-02-04 14:10 UTC, artur.cuvasov
Details
Backtrace for crash on OpenSUSE 12.3 (4.43 KB, text/plain)
2013-10-14 13:14 UTC, Robert Munteanu
Details
New crash information added by DrKonqi (11.51 KB, text/plain)
2014-05-12 12:16 UTC, Massimiliano
Details

Note You need to log in before you can comment on or make changes to this bug.
Description artur.cuvasov 2012-05-12 09:03:39 UTC
Application: kcmshell4 ()
KDE Platform Version: 4.8.3 (4.8.3)
Qt Version: 4.8.1
Operating System: Linux 3.3.4-3.fc16.i686.PAE i686
Distribution: "Fedora release 16 (Verne)"

-- Information about the crash:
- What I was doing when the application crashed:

Open network connections window, create a new wireless profile with WPA/WPA2 Enterprise and save it. Crashes every time.

The crash can be reproduced every time.

-- Backtrace:
Application: KDE Control Module (kcmshell4), signal: Aborted
Using host libthread_db library "/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0xb776c780 (LWP 12683))]

Thread 2 (Thread 0xb621cb40 (LWP 12684)):
#0  0xb779c424 in __kernel_vsyscall ()
#1  0x488bd1a0 in poll () from /lib/libc.so.6
#2  0x46f3dd3c in g_poll () from /lib/libglib-2.0.so.0
#3  0x46f2f146 in ?? () from /lib/libglib-2.0.so.0
#4  0x46f2f4ef in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x477adf47 in QEventDispatcherGlib::processEvents (this=0xb5900468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x4777a11e in QEventLoop::processEvents (this=0xb621c200, flags=...) at kernel/qeventloop.cpp:149
#7  0x4777a3c9 in QEventLoop::exec (this=0xb621c200, flags=...) at kernel/qeventloop.cpp:204
#8  0x4766204c in QThread::exec (this=0x9417720) at thread/qthread.cpp:501
#9  0x4775706e in QInotifyFileSystemWatcherEngine::run (this=0x9417720) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x476655d1 in QThreadPrivate::start (arg=0x9417720) at thread/qthread_unix.cpp:298
#11 0x48991cd3 in start_thread () from /lib/libpthread.so.0
#12 0x488c7a2e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb776c780 (LWP 12683)):
[KCrash Handler]
#7  0xb779c424 in __kernel_vsyscall ()
#8  0x4880398f in raise () from /lib/libc.so.6
#9  0x488052d5 in abort () from /lib/libc.so.6
#10 0x48ea2485 in ?? () from /lib/libdbus-1.so.3
#11 0x48e97e1d in ?? () from /lib/libdbus-1.so.3
#12 0x48e8897d in dbus_message_iter_append_basic () from /lib/libdbus-1.so.3
#13 0x46c79d34 in q_dbus_message_iter_append_basic (value=0xbfdfb020, type=98, iter=<optimized out>) at qdbus_symbols_p.h:221
#14 qIterAppend (it=<optimized out>, ba=<optimized out>, type=98, arg=0xbfdfb020) at qdbusmarshaller.cpp:56
#15 0x46c7e194 in append (arg=<optimized out>, this=<optimized out>) at qdbusmarshaller.cpp:79
#16 QDBusMarshaller::appendVariantInternal (this=0xbfdfb0c4, arg=...) at qdbusmarshaller.cpp:415
#17 0x46c7f63b in append (arg=<optimized out>, this=<optimized out>) at qdbusmarshaller.cpp:204
#18 QDBusArgument::operator<< (this=0xbfdfb23c, arg=...) at qdbusargument.cpp:512
#19 0xb65b77da in operator<< (map=..., arg=...) at /usr/include/QtDBus/qdbusargument.h:341
#20 operator<< <QString, QMap<QString, QVariant> > (map=..., arg=...) at /usr/include/QtDBus/qdbusargument.h:310
#21 qDBusMarshallHelper<QMap<QString, QMap<QString, QVariant> > > (arg=..., t=0x94d8048) at /usr/include/QtDBus/qdbusmetatype.h:72
#22 0x46c82baf in QDBusMetaType::marshall (arg=..., id=292, data=0x94d8048) at qdbusmetatype.cpp:265
#23 0x46c7bfb0 in QDBusMarshaller::appendRegisteredType (this=0xbfdfb464, arg=...) at qdbusmarshaller.cpp:508
#24 0x46c7dd9c in QDBusMarshaller::appendVariantInternal (this=0xbfdfb464, arg=...) at qdbusmarshaller.cpp:481
#25 0x46c55086 in QDBusMessagePrivate::toDBusMessage (message=..., capabilities=) at qdbusmessage.cpp:189
#26 0x46c4db8b in QDBusConnectionPrivate::sendWithReplyAsync (this=0x9430f08, message=..., timeout=0) at qdbusintegrator.cpp:1989
#27 0x46c3b114 in QDBusConnection::asyncCall (this=0x943b93c, message=..., timeout=-1) at qdbusconnection.cpp:628
#28 0x46c5b031 in QDBusAbstractInterface::asyncCallWithArgumentList (this=0x943b310, method=..., args=...) at qdbusabstractinterface.cpp:501
#29 0xb65ecb54 in Update (properties=..., this=0x943b310) at /usr/src/debug/networkmanagement-0.9.0.1/backends/NetworkManager/nm-settings-connectioninterface.h:63
#30 NMDBusSettingsConnectionProvider::updateConnection (this=0x9430d08, uuid=..., newConnection=0x95a0b68) at /usr/src/debug/networkmanagement-0.9.0.1/backends/NetworkManager/nmdbussettingsconnectionprovider.cpp:373
#31 0xb6634ca2 in ManageConnectionWidget::editGotSecrets (this=0x93c1840, valid=true, errorMessage=..., uuid=...) at /usr/src/debug/networkmanagement-0.9.0.1/settings/config/manageconnectionwidget.cpp:566
#32 0xb6636050 in ManageConnectionWidget::editClicked (this=0x93c1840) at /usr/src/debug/networkmanagement-0.9.0.1/settings/config/manageconnectionwidget.cpp:544
#33 0xb6632f90 in qt_static_metacall (_a=0xbfdfbb38, _id=4, _o=0x93c1840, _c=<optimized out>) at /usr/src/debug/networkmanagement-0.9.0.1/i686-redhat-linux-gnu/settings/config/moc_manageconnectionwidget.cpp:76
#34 ManageConnectionWidget::qt_static_metacall (_o=0x93c1840, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbfdfbb38) at /usr/src/debug/networkmanagement-0.9.0.1/i686-redhat-linux-gnu/settings/config/moc_manageconnectionwidget.cpp:66
#35 0x4778f601 in QMetaObject::activate (sender=0x940bce8, m=0x4a931808, local_signal_index=2, argv=0xbfdfbb38) at kernel/qobject.cpp:3547
#36 0x4a6e589e in QAbstractButton::clicked (this=0x940bce8, _t1=false) at .moc/release-shared/moc_qabstractbutton.cpp:219
#37 0x4a3d662e in QAbstractButtonPrivate::emitClicked (this=0x940bd08) at widgets/qabstractbutton.cpp:548
#38 0x4a3d7d00 in QAbstractButtonPrivate::click (this=0x940bd08) at widgets/qabstractbutton.cpp:541
#39 0x4a3d7fb6 in QAbstractButton::mouseReleaseEvent (this=0x940bce8, e=0xbfdfc204) at widgets/qabstractbutton.cpp:1123
#40 0x4a00817d in QWidget::event (this=0x940bce8, event=0xbfdfc204) at kernel/qwidget.cpp:8362
#41 0x4a3d7221 in QAbstractButton::event (this=0x940bce8, e=0xbfdfc204) at widgets/qabstractbutton.cpp:1082
#42 0x4a47b919 in QPushButton::event (this=0x940bce8, e=0xbfdfc204) at widgets/qpushbutton.cpp:683
#43 0x49fad354 in notify_helper (e=0xbfdfc204, receiver=0x940bce8, this=0x9206e30) at kernel/qapplication.cpp:4554
#44 QApplicationPrivate::notify_helper (this=0x9206e30, receiver=0x940bce8, e=0xbfdfc204) at kernel/qapplication.cpp:4526
#45 0x49fb34ea in QApplication::notify (this=0x9206e30, receiver=0x940bce8, e=0xbfdfc204) at kernel/qapplication.cpp:4097
#46 0x48394e42 in KApplication::notify (this=0xbfdfca58, receiver=0x940bce8, event=0xbfdfc204) at /usr/src/debug/kdelibs-4.8.3/kdeui/kernel/kapplication.cpp:311
#47 0x4777b22e in QCoreApplication::notifyInternal (this=0xbfdfca58, receiver=0x940bce8, event=0xbfdfc204) at kernel/qcoreapplication.cpp:876
#48 0x49fae326 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:231
#49 QApplicationPrivate::sendMouseEvent (receiver=0x940bce8, event=0xbfdfc204, alienWidget=0x940bce8, nativeWidget=0x92d7360, buttonDown=0x4a93ac14, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3165
#50 0x4a03808c in QETWidget::translateMouseEvent (this=0x92d7360, event=0xbfdfc6bc) at kernel/qapplication_x11.cpp:4523
#51 0x4a03706d in QApplication::x11ProcessEvent (this=0xbfdfca58, event=0xbfdfc6bc) at kernel/qapplication_x11.cpp:3646
#52 0x4a0621b5 in x11EventSourceDispatch (s=0x920ca40, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:148
#53 0x46f2eaff in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#54 0x46f2f240 in ?? () from /lib/libglib-2.0.so.0
#55 0x46f2f4ef in g_main_context_iteration () from /lib/libglib-2.0.so.0
#56 0x477adee8 in QEventDispatcherGlib::processEvents (this=0x91ec5c0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#57 0x4a061e4b in QGuiEventDispatcherGlib::processEvents (this=0x91ec5c0, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#58 0x4777a11e in QEventLoop::processEvents (this=0xbfdfc9c0, flags=...) at kernel/qeventloop.cpp:149
#59 0x4777a3c9 in QEventLoop::exec (this=0xbfdfc9c0, flags=...) at kernel/qeventloop.cpp:204
#60 0x4a4fdcfa in QDialog::exec (this=0x92d7360) at dialogs/qdialog.cpp:554
#61 0x465d1ad7 in kdemain (_argc=5, _argv=0xbfdfccf4) at /usr/src/debug/kde-runtime-4.8.3/kcmshell/main.cpp:292
#62 0x080485ac in main (argc=5, argv=0xbfdfccf4) at /usr/src/debug/kde-runtime-4.8.3/i686-redhat-linux-gnu/kcmshell/kcmshell4_dummy.cpp:3

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2012-05-12 20:36:19 UTC
According to the crashlog you were editing a connection, not creating a new one. Anyway, the crash happens in libdbus, not in Plasma NM.
Comment 2 artur.cuvasov 2012-05-12 20:37:53 UTC
It does not matter if you edit an existing connection, or create a new one.
Comment 3 Lamarque V. Souza 2012-05-12 20:46:16 UTC
Still this looks like an upstream bug.
Comment 4 artur.cuvasov 2012-05-12 20:54:42 UTC
Can be. So what are the further steps?
Comment 5 Lamarque V. Souza 2012-05-12 21:12:45 UTC
I cannot reproduce this problem here, so I cannot help you much. Which dbus version do you use? Is there any bug related to dbus in Fedora's bugzilla?
Comment 6 artur.cuvasov 2012-05-12 23:52:15 UTC
The dbus is: dbus-1.4.10-3.fc16.i686
I am not sure if there are any related tickets to this problem at the moment.
Comment 7 Jekyll Wu 2012-05-23 18:10:41 UTC
*** Bug 300512 has been marked as a duplicate of this bug. ***
Comment 8 Lamarque V. Souza 2012-06-22 00:16:00 UTC
Can you reproduce this problem with Plasma NM 0.9.0.3?
Comment 9 artur.cuvasov 2012-06-22 08:05:42 UTC
Version     : 0.9.0.3
Release     : 2.fc17
Architecture: i686

The problem persists. Do you want a crash dump?
Comment 10 Lamarque V. Souza 2012-06-22 13:13:13 UTC
Yes, send me the crashlog, the files ~/.kde/share/config/networkmanagementrc and ~/.xsession-errors and NetworkManager's log.
Comment 11 Lamarque V. Souza 2012-06-22 22:54:38 UTC
Can you try upgrading to libdbus-1.4.20? There are a lot of error messages regarding dbus in your .xsession-errors and no application is able to use dbus according to the log.
Comment 12 artur.cuvasov 2012-06-22 23:42:24 UTC
Updated to the latest dbus available, same problem. Sent crash dump and .xsession-errors by mail.


python-slip-dbus-0.2.20-2.fc17.noarch
dbus-python-0.83.0-9.fc17.i686
dbus-debuginfo-1.6.0-1.fc18.i686
dbus-1.6.0-1.fc18.i686
dbus-glib-0.92-3.fc17.i686
dbus-libs-1.6.0-1.fc18.i686
abrt-dbus-2.0.10-4.fc17.i686
dbusmenu-qt-0.9.2-1.fc18.i686
dbus-x11-1.6.0-1.fc18.i686
Comment 13 Lamarque V. Souza 2012-06-25 22:21:49 UTC
dbus is still not working properly in you installation. What does the commands below return?

qdbus
qdbus --system org.freedesktop.NetworkManager
qdbus org.kde.networkmanagement
Comment 14 artur.cuvasov 2012-06-25 22:53:25 UTC
The installation is default.

qdbus
Could not connect to D-Bus server: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, th                                       e message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

qdbus --system org.freedesktop.NetworkManager                                                                                                                                                
/                                                                                                                                                                                                              
/com                                                                                                                                                                                                           
/com/redhat                                                                                                                                                                                                    
/com/redhat/ifcfgrh1                                                                                                                                                                                           
/org                                                                                                                                                                                                           
/org/freedesktop                                                                                                                                                                                               
/org/freedesktop/NetworkManager                                                                                                                                                                                
/org/freedesktop/NetworkManager/AccessPoint                                                                                                                             
/org/freedesktop/NetworkManager/AccessPoint/5167                                                                                                                        
/org/freedesktop/NetworkManager/AccessPoint/5281                                                                                                                        
/org/freedesktop/NetworkManager/AccessPoint/5494
/org/freedesktop/NetworkManager/AccessPoint/5503
/org/freedesktop/NetworkManager/AccessPoint/5515
/org/freedesktop/NetworkManager/AccessPoint/5520
/org/freedesktop/NetworkManager/AccessPoint/5533
/org/freedesktop/NetworkManager/AccessPoint/5535
/org/freedesktop/NetworkManager/AccessPoint/5536
/org/freedesktop/NetworkManager/AccessPoint/5537
/org/freedesktop/NetworkManager/AccessPoint/5538
/org/freedesktop/NetworkManager/AccessPoint/5539
/org/freedesktop/NetworkManager/ActiveConnection
/org/freedesktop/NetworkManager/ActiveConnection/21
/org/freedesktop/NetworkManager/AgentManager
/org/freedesktop/NetworkManager/DHCP4Config
/org/freedesktop/NetworkManager/DHCP4Config/10
/org/freedesktop/NetworkManager/Devices
/org/freedesktop/NetworkManager/Devices/0
/org/freedesktop/NetworkManager/Devices/1
/org/freedesktop/NetworkManager/IP4Config
/org/freedesktop/NetworkManager/IP4Config/10
/org/freedesktop/NetworkManager/Settings
/org/freedesktop/NetworkManager/Settings/0
/org/freedesktop/NetworkManager/Settings/1
/org/freedesktop/NetworkManager/Settings/2
/org/freedesktop/NetworkManager/Settings/3
/org/freedesktop/NetworkManager/Settings/4
/org/freedesktop/NetworkManager/Settings/5
/org/freedesktop/NetworkManager/Settings/6
/org/freedesktop/NetworkManager/Settings/7

qdbus org.kde.networkmanagement
Could not connect to D-Bus server: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Comment 15 Lamarque V. Souza 2012-06-25 23:18:23 UTC
The session bus is not started. You should open a bug request in Fedora's bugzilla about this problem. It has nothing to do with KDE.
Comment 16 artur.cuvasov 2012-07-11 11:18:55 UTC
This does not seem to be a (just) dbus problem, since I tried logging in as root, where all those 3 dbus related commands gave a positive result. Nevertheless, I am still getting a crash (attached, created as root)

########## qdbus
:1.100
 org.kde.nepomuk.services.nepomukfileindexer
:1.106
 org.kde.kwalletmanager
:1.108
 org.kde.StatusNotifierItem-20768-1
:1.109
 org.kde.konsole
:1.116
 org.freedesktop.PackageKit
 org.kde.ApperSentinel
:1.118
:1.119
:1.120
 org.a11y.Bus
:1.121
:1.122
:1.123
:1.17                                                                                                                                                                                                          
 org.kde.klauncher                                                                                                                                                                                             
:1.18                                                                                                                                                                                                          
 org.freedesktop.PowerManagement                                                                                                                                                                               
 org.freedesktop.PowerManagement.Inhibit                                                                                                                                                                       
 org.kde.Solid.PowerManagement                                                                                                                                                                                 
 org.kde.Solid.PowerManagement.PolicyAgent                                                                                                                                                                     
 org.kde.StatusNotifierWatcher                                                                                                                                                                                 
 org.kde.kded                                                                                                                                                                                                  
 org.kde.keyboard                                                                                                                                                                                              
 org.kde.networkmanagement                                                                                                                                                                                     
:1.21                                                                                                                                                                                                          
 org.kde.BlueDevil.Service
 org.kde.bluedevilfilereceiverhelper-20440
:1.22
:1.23
 org.openobex
:1.24
 org.kde.bluedevilmonolithic
:1.26
 org.kde.StatusNotifierItem-20447-1
:1.27
 org.kde.kglobalaccel
:1.29
 org.kde.kwalletd
:1.3
 com.redhat.imsettings
:1.31
 org.kde.kactivitymanagerd
:1.34
 org.kde.knotify
:1.36
 org.kde.ksmserver
 org.kde.ksmserver-20462
:1.37
 org.kde.kwin
 org.kde.kwin-20465
 org.kde.kwin.Screenshot
:1.38
 org.freedesktop.Notifications
 org.kde.DeviceNotifications
 org.kde.StatusNotifierHost-20474
 org.kde.plasma-desktop
:1.4
:1.40
 org.kde.JobViewServer
 org.kde.kuiserver
:1.43
 org.kde.kaccess
:1.45
 org.freedesktop.ScreenSaver
 org.kde.krunner
 org.kde.screensaver
:1.47
 org.kde.NepomukServer
:1.49
 org.gnome.zeitgeist.datahub
:1.5
 org.gtk.vfs.Daemon
:1.50
 org.kde.NepomukStorage
 org.kde.nepomuk.DataManagement
 org.kde.nepomuk.services.nepomukontologyloader
 org.kde.nepomuk.services.nepomukstorage
:1.51
 org.gnome.zeitgeist.Engine
:1.52
 com.redhat.abrt.applet
:1.53
 org.kde.klipper
:1.55
 org.kde.kmix
:1.57
:1.58
:1.59
 org.freedesktop.Tracker1.Miner.Applications
 org.freedesktop.Tracker1.Miner.Files
 org.freedesktop.Tracker1.Miner.Files.Index
:1.6
:1.61
 org.kde.nepomukcontroller
:1.63
 ca.desrt.dconf
:1.64
:1.65
 org.kde.Polkit1AuthAgent
:1.67
 org.kde.StatusNotifierItem-20595-1
:1.68
 org.kde.StatusNotifierItem-20580-1
:1.69
 org.PulseAudio1
 org.pulseaudio.Server
:1.7
:1.70
:1.71
:1.72
 org.kde.printer-applet-20543
:1.73
:1.74
 org.gtk.Private.UDisks2VolumeMonitor
:1.75
:1.76
 org.gtk.Private.GPhoto2VolumeMonitor
:1.77
 org.gtk.Private.AfcVolumeMonitor
:1.78
:1.79
 org.gnome.GConf
:1.81
:1.82
 org.kde.StatusNotifierItem-20582-1
:1.83
 org.kde.StatusNotifierItem-20543-1
:1.84
 org.gnome.zeitgeist.SimpleIndexer
:1.86
:1.88
:1.89
 org.freedesktop.Tracker1
:1.90
:1.96
 org.kde.nepomuk.services.nepomukqueryservice
:1.97
 org.kde.nepomuk.services.nepomukbackupsync
:1.98
 org.kde.nepomuk.services.nepomukfilewatch
:1.99
 org.kde.nepomuk.services.digikamnepomukservice
org.freedesktop.DBus
################# qdbus org.kde.networkmanagement
/
/KBookmarkManager
/KBookmarkManager/kfilePlaces
/KIO
/KIO/Scheduler
/Layouts
/MainApplication
/Mixers
/Mixers/0
/Mixers/0/Bass_Speaker_0
/Mixers/0/Beep_0
/Mixers/0/Capture_0
/Mixers/0/Digital_0
/Mixers/0/Headphone_0
/Mixers/0/IEC958_0
/Mixers/0/IEC958_1
/Mixers/0/IEC958_2
/Mixers/0/Line_Jack_Mode_0_penum
/Mixers/0/Master_0
/Mixers/0/Mic_Jack_Mode_0_penum
/Mixers/0/Mute_LED_Mode_0_penum
/Mixers/0/Mux_0
/Mixers/0/PCM_0
/Mixers/0/Speaker_0
/StatusNotifierWatcher
/kbuildsycoca
/kded
/modules
/modules/StatusNotifierWatcher
/modules/apperd
/modules/bluedevil
/modules/desktopnotifier
/modules/device_automounter
/modules/dnssdwatcher
/modules/favicons
/modules/freespacenotifier
/modules/keyboard
/modules/khotkeys
/modules/kmixd
/modules/kremotecontroldaemon
/modules/ktimezoned
/modules/kwrited
/modules/nepomuksearchmodule
/modules/networkmanagement
/modules/networkstatus
/modules/obexftpdaemon
/modules/phononserver
/modules/powerdevil
/modules/randrmonitor
/modules/remotedirnotify
/modules/solidautoeject
/modules/statusnotifierwatcher
/org
/org/freedesktop
/org/freedesktop/PowerManagement
/org/freedesktop/PowerManagement/Inhibit
/org/kde
/org/kde/Solid
/org/kde/Solid/PowerManagement
/org/kde/Solid/PowerManagement/PolicyAgent
/org/kde/networkmanagement
/org/kde/networkmanagement/Activatable
/org/kde/networkmanagement/Activatable/1
/org/kde/networkmanagement/Activatable/2
/org/kde/networkmanagement/Activatable/3
/org/kde/networkmanagement/Activatable/4
/org/kde/networkmanagement/Activatable/5
/org/kde/networkmanagement/Activatable/6
/org/kde/networkmanagement/Activatable/7
/org/kde/networkmanagement/Activatable/8
Comment 17 artur.cuvasov 2012-07-11 11:21:03 UTC
Created attachment 72452 [details]
crash dump as root with qdbus working
Comment 18 Lamarque V. Souza 2012-07-11 12:12:52 UTC
Your new crash is still related to a problem in dbus library. You setup is probably messed up or NetworkManager is crashing at some point.
Comment 19 artur.cuvasov 2012-07-11 13:03:42 UTC
Opened a ticket in Fedora bugtrack: https://bugzilla.redhat.com/show_bug.cgi?id=839284
Comment 20 Lamarque V. Souza 2012-09-30 23:53:54 UTC
*** Bug 307496 has been marked as a duplicate of this bug. ***
Comment 21 Anton Samsonov 2012-10-01 10:17:44 UTC
(In reply to comment #0)
> Open network connections window, create a new wireless profile with WPA/WPA2 Enterprise and save it. Crashes every time.

Artur, did you try to fill-in the "Identity" field, setting it to certificate's Common Name (the body to which the certificate was issued to)? I have a similar problem with NetworkManager 0.9.0.2 and found such a workaround.


(In reply to comment #18)
> Your new crash is still related to a problem in dbus library. You setup is probably messed up or NetworkManager is crashing at some point.

Lamarque, in both our crash dumps (Artur's in comment 17 and mine from bug 307496) there are a couple of lines near the top of the call stack:
> 0x... in _dbus_abort () at dbus-sysdeps.c:94
> 0x... in _dbus_warn_check_failed (format=0x... "arguments to %s() were incorrect, assertion \"%s\" failed in file %s line %d.\nThis is normally a bug in some application using the D-Bus library.\n") at dbus-internals.c:290
I am not a skilled crash dump parser, but this message looks more like a deliberate argument checking and early halting on encountered error, rather than passing obviously incorrect parameters further to lower-level functions. Although the presence of "%s" and "%d" placeholders introduces some doubts about dbus' own sanity, I still suppose that dbus is not the one to blame, since it really receives bad arguments. Isn't it the caller's responsibility to provide a valid "Identity" parameter, whether explicitly defined by user or implicitly looked up in the certificate?
Comment 22 Lamarque V. Souza 2012-12-02 02:17:37 UTC
Git commit cca7c1e9d50afeba8fb5bc880b652056c9c5b9ae by Lamarque V. Souza.
Committed on 02/12/2012 at 03:12.
Pushed by lvsouza into branch 'master'.

Add mechanism to validate EAP methods' settings. The first one implemented is
for TLS, which requires the identify field to be filled or it will crash the
edit dialog. Now the Ok button in edit dialog will be disabled if the identify
field is empty.

M  +2    -0    libs/ui/security/eapmethod.h
M  +2    -1    libs/ui/security/securityeap.cpp
M  +10   -1    libs/ui/security/tlswidget.cpp
M  +1    -0    libs/ui/security/tlswidget.h
M  +1    -0    libs/ui/security/wirelesssecuritysettingwidget.cpp

http://commits.kde.org/networkmanagement/cca7c1e9d50afeba8fb5bc880b652056c9c5b9ae
Comment 23 Lamarque V. Souza 2012-12-02 02:24:24 UTC
Git commit 9adc021082dfe43afa3d5a68a40d3807e867b46c by Lamarque V. Souza.
Committed on 02/12/2012 at 03:12.
Pushed by lvsouza into branch 'nm09'.

Add mechanism to validate EAP methods' settings. The first one implemented is
for TLS, which requires the identify field to be filled or it will crash the
edit dialog. Now the Ok button in edit dialog will be disabled if the identify
field is empty.
(cherry picked from commit cca7c1e9d50afeba8fb5bc880b652056c9c5b9ae)

M  +2    -0    libs/ui/security/eapmethod.h
M  +2    -1    libs/ui/security/securityeap.cpp
M  +10   -1    libs/ui/security/tlswidget.cpp
M  +1    -0    libs/ui/security/tlswidget.h
M  +1    -0    libs/ui/security/wirelesssecuritysettingwidget.cpp

http://commits.kde.org/networkmanagement/9adc021082dfe43afa3d5a68a40d3807e867b46c
Comment 24 Lamarque V. Souza 2013-01-31 18:35:04 UTC
Is this problem still happening?
Comment 25 artur.cuvasov 2013-02-04 14:09:19 UTC
Yes, NM crashes when I add Enterprise WPA2.
networkmanagement-0.9.0.6
dump attached.
Comment 26 artur.cuvasov 2013-02-04 14:10:36 UTC
Created attachment 76903 [details]
networkmanagement-0.9.0.6 crash dump
Comment 27 Anton Samsonov 2013-02-04 21:06:37 UTC
(In reply to comment #24)
> Is this problem still happening?

As for openSUSE 12.2 (bug 307496), it still claims Network Manager's version to be 0.9.0.2 (nm09 20120507), although package versions have changed since that report of mine; anyway the binary is dated 2012-11-23, which definitely precedes your commit of 2012-12-02. Perhaps they won't update it till 12.3 comes out in March.


(In reply to comment #23)
> TLS requires the identify field to be filled. Now the Ok button in edit dialog will be disabled if the identify field is empty.

Isn't there any option to just use the Common Name field from certificate, unless the user overrides it with custom value?
Comment 28 Lamarque V. Souza 2013-02-27 17:26:49 UTC
*** Bug 315857 has been marked as a duplicate of this bug. ***
Comment 29 Lamarque V. Souza 2013-10-03 00:30:16 UTC
*** Bug 325553 has been marked as a duplicate of this bug. ***
Comment 30 Robert Munteanu 2013-10-14 13:14:33 UTC
Created attachment 82844 [details]
Backtrace for crash on OpenSUSE 12.3

I still have this issue on OpenSUSE 12.3 - NM 0.9.6.4 and OpenSUSE 13.1 RC1 - NM 0.9.8.6.

I've attached the backtrace with debug symbols. Please note I can't save without filling in the identity field, so the fixes referenced in this bug report are in my local installations.
Comment 31 Lamarque V. Souza 2013-11-28 11:07:56 UTC
*** Bug 323106 has been marked as a duplicate of this bug. ***
Comment 32 Lamarque V. Souza 2013-11-28 11:08:59 UTC
Git commit 1b12d01965d9d8e1e56218abfbbe7436f06442d2 by Lamarque V. Souza.
Committed on 28/11/2013 at 11:03.
Pushed by lvsouza into branch 'nm09'.

Those operator overloads are not necessary and cause crash when adding WPA2
Enterprise connections.
Thanks Jan Grulich for spotting this solution.
FIXED-IN: 0.9.0.10

M  +0    -33   libs/marshalarguments.h
M  +1    -1    plasma_nm_version.h

http://commits.kde.org/networkmanagement/1b12d01965d9d8e1e56218abfbbe7436f06442d2
Comment 33 Lamarque V. Souza 2013-11-28 11:12:24 UTC
*** Bug 326129 has been marked as a duplicate of this bug. ***
Comment 34 Lamarque V. Souza 2013-11-28 11:14:55 UTC
*** Bug 322861 has been marked as a duplicate of this bug. ***
Comment 35 Lamarque V. Souza 2013-11-28 11:16:25 UTC
*** Bug 322203 has been marked as a duplicate of this bug. ***
Comment 36 Massimiliano 2014-05-12 12:16:57 UTC
Created attachment 86593 [details]
New crash information added by DrKonqi

kcmshell4 (4.11.5) on KDE Platform 4.11.5 using Qt 4.8.5

- What I was doing when the application crashed:

I was trying to create a new wpa2 network profile in network manager, but it crashed when I tried to save the profile.

-- Backtrace (Reduced):
#8  0x00007f9020aa6735 in _dbus_abort () at dbus-sysdeps.c:92
#9  0x00007f9020a9d3c1 in _dbus_warn_check_failed (format=0x7f9020aacb60 "arguments to %s() were incorrect, assertion \"%s\" failed in file %s line %d.\nThis is normally a bug in some application using the D-Bus library.\n") at dbus-internals.c:290
#10 0x00007f9020a8ffe6 in dbus_message_iter_append_basic (iter=0x7fff0e90a888, type=98, value=0x7fff0e90a700) at dbus-message.c:2586
#11 0x00007f9023d900a1 in append (arg=<optimized out>, this=0x7f9023fb9d84 <QDBusMetaTypeId::argument>) at qdbusmarshaller.cpp:79
#12 QDBusMarshaller::appendVariantInternal (this=this@entry=0x7fff0e90a870, arg=...) at qdbusmarshaller.cpp:415