Bug 299820 - Using filters to move mail from IMAP to local folder repeatibly results in 'Unknown error. (Unable to fetch item from backend)'
Summary: Using filters to move mail from IMAP to local folder repeatibly results in 'U...
Status: RESOLVED DUPLICATE of bug 289097
Alias: None
Product: kmail2
Classification: Applications
Component: filtering (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR major (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-11 14:35 UTC by Shez
Modified: 2012-05-21 16:28 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shez 2012-05-11 14:35:33 UTC
Hi,

Using kmail2 from fedora core 16:
kmail -v
Qt: 4.8.1
KDE Development Platform: 4.8.3 (4.8.3)
KMail: 4.8.3

I've been using kmail for a decade or so now, and have a lot of mail and folders, but I believe this should be reproducible in a limited environment:

I have local folders and an IMAP account.  With filters setup that move mail from IMAP to local folders, kmail gets  confused about what messages exist in the IMAP folder, and attempts to request the BODY of moved messages from the IMAP server.  This only happens after quiting and restarting kmail ,leading to the Unable to retreive message folder messages when clicking on the imap account folder.  Enabling KIMAP_LOGFILE appears to confirm this.  Using 'akonadiconsole' to clear the agent's cache kind of fixes the problem, but then restarting the mail filter agent seems to be required to get filtering working again.


General comment - as a very long term, very happy user of kmail, this is the least satisfying version from a user perspective.  I've always liked it because it just worked, and didn't require me to hack about to carry out my day job...  Happy to provide as much information as required on this and other issues to get back to that situation!

Cheers
Shez

Reproducible: Always

Steps to Reproduce:
1. Setup local folders
2. Setup IMAP account
3. Setup filters that move message from IMAP to local folders
4. Receive mail to imap account (message should get moved to local folder)
5. Quit kmail
6. Start kmail
7. Select imap folder
8. See 'Unknown error (unable to...') message
Actual Results:  
As above

Expected Results:  
No error expected
Comment 1 jos poortvliet 2012-05-14 19:06:26 UTC
I'm thinkin' this is a duplicate of 289097 - however this bug gives a clear way to reproduce and a hint to this being related to filters. I'll make sure this gets mentioned on the earlier report. Thanks for reporting, Shez!

I hope a developer who might know what's going on will find time to address this problem...

*** This bug has been marked as a duplicate of bug 289097 ***