Bug 299724 - pedestrian route is correct, but bicycle is not and does not update route when changing dropdown
Summary: pedestrian route is correct, but bicycle is not and does not update route whe...
Status: RESOLVED UPSTREAM
Alias: None
Product: marble
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR minor (vote)
Target Milestone: 1.3 (KDE 4.8)
Assignee: marble-bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-10 07:51 UTC by peter.maloney
Modified: 2012-05-17 10:04 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: KDE 4.8.4 / Marble 1.3.4


Attachments
bicycle route with obviously crazy route chosen (1.85 KB, application/xml; charset=utf-8)
2012-05-10 07:52 UTC, peter.maloney
Details

Note You need to log in before you can comment on or make changes to this bug.
Description peter.maloney 2012-05-10 07:51:18 UTC
in OpenStreetMap map view:
1. when changing the dropdown from "bicycle" to "pedestrian", the route is different but does not update until a destination point is dragged. Hitting "Get Directions" zooms the map to a different spot, so it is not the same thing.

2. for a particular route, shows obviously wrong route (attached exported route). There is no barrier there, and the pedestrian map will tell you to walk through that spot.

Reproducible: Always
Comment 1 peter.maloney 2012-05-10 07:52:54 UTC
Created attachment 70992 [details]
bicycle route with obviously crazy route chosen

see bug report
Comment 2 Dennis Nienhüser 2012-05-10 08:18:43 UTC
The dashed red path is marked as a footpath in OpenStreetMap. OpenRouteService treats those as paths for pedestrians and ignores them completely for bicycles. Therefore the map matching (finding the closest path next to your starting point) is different for pedestrian and bicycle routing here: For pedestrian routing it maps you to the red dashed path, for bicycle routing it does not know that path and chooses the way in the south (Zöllnersweg) as the start and the way in the north (Sophie-Scholl-Ring) as the destination.
If you move both points (start and destination) towards the north, for the same reason you get a seemingly uneeded jump to Sophie-Scholl-Ring.

Now one could argue that this could be special-cased (since the distance between both points is smaller than the distance to the next street each) but it's easy to construct examples where that would be wrong as well (think of both points separated by a river).

In the long run we'll eliminate that confusion when we have vector maps that can be adjusted to show only elements relevant to a certain task. For bicycle routing we'd hide footpaths then.

I can't reproduce 1. though. When I change the routing type and hit 'Get Directions', a new route is calculated and zoomed on (unless it's the same).
Comment 3 peter.maloney 2012-05-10 12:37:34 UTC
My problem for 1. is that changing the dropdown doesn't update the map
alone, without hitting the button. Hitting the button also zooms, so it
isn't the same as what I expected. Non-ajax web sites do what marble
does, but I would expect AJAX sites and offline programs to update when
you change such a dropdown.


And for 2., in Germany, people bike everywhere... I don't think there
are many paths that aren't also for bicycles, but the map has very many
dotted red lines and very few blue ones. So the data seems to be way
off, or someone's interpretation of walkway includes bicycles, but
Marble considers them to exclude bicycles.

In Germany, they banned the Google street view ;) so I can't show you
examples. But the sign that says you need to get off your bike doesn't
appear on that road. The sign is the rightmost one here (which I think I
probably never saw on an actual path; maybe it is more common in a
bigger city):
http://image.shutterstock.com/display_pic_with_logo/140728/140728,1221238420,3/stock-photo-traffic-signs-in-germany-17301934.jpg

And even if that sign did appear, a person would rather bike to the
sign, and walk a bit, and get back on the bike, rather than go the long
way.

And I disagree with hiding footpaths when you have bicycle selected. If
you did that, then people wouldn't know what other options there are
when the given route is bad, like in my case. If this is what you change
it to, then I will never select "bicycle" and use "pedestrian" always.
Comment 4 Dennis Nienhüser 2012-05-17 09:44:11 UTC
Git commit b444a15c4c38fc5831f24c668fedd06a5f6a5d93 by Dennis Nienhüser.
Committed on 17/05/2012 at 11:41.
Pushed by nienhueser into branch 'master'.

Retrieve new directions after changing the transport type.

M  +2    -0    src/lib/routing/RoutingWidget.cpp

http://commits.kde.org/marble/b444a15c4c38fc5831f24c668fedd06a5f6a5d93
Comment 5 Dennis Nienhüser 2012-05-17 10:02:05 UTC
Git commit af4ba7ff7919e66cbf609bef7588dede17ab378d by Dennis Nienhüser.
Committed on 17/05/2012 at 11:41.
Pushed by nienhueser into branch 'KDE/4.8'.

Retrieve new directions after changing the transport type.
(cherry picked from commit b444a15c4c38fc5831f24c668fedd06a5f6a5d93)

M  +2    -0    src/lib/routing/RoutingWidget.cpp

http://commits.kde.org/marble/af4ba7ff7919e66cbf609bef7588dede17ab378d
Comment 6 Dennis Nienhüser 2012-05-17 10:04:18 UTC
1. is resolved by the last commit
For 2. feel free to contact the people from http://openrouteservice.org/ (Marble has no influence on the behavior here)