Bug 299628 - Logical UI problem hinders start up
Summary: Logical UI problem hinders start up
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified All
: NOR normal (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-08 15:13 UTC by Hohyeis
Modified: 2012-09-05 17:25 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 2.7


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hohyeis 2012-05-08 15:13:53 UTC
When starting amarok with a fresh configuration, such as a user's first start, the plug in for Amazon halts the start up until a country is specified by its GUI -- however its window is  covered up by the splash image of Amarok. Clicking on the splash image does not cause it to disappear and it is not (easily) moveable.

This represents a conflict between the splash window and plug ins.


Reproducible: Always
Comment 1 Myriam Schweingruber 2012-05-09 14:07:05 UTC
This is a bug in Kwin, not in Amarok.

*** This bug has been marked as a duplicate of bug 252047 ***
Comment 2 Thomas Lübking 2012-05-09 14:44:24 UTC
@Myriam
"unlikely"

Hiding splashs on clicks is NO STANDARD but just implemented in some very few WMs (actually kwin is more or less the only common one just tried and it does work for me with kwin) where compiz is NONE of them.
Both compiz and kwin handle stacking fine here, but however this is NOT DETERMINISTIC because the the splash and the dialog are transient for the very same window and the splash is marked keep above.

-> the entire setup really begs for this bug and it's actually the different degrees of WMs grace which prevents those issues (There's no specific splash layer defined, kwin ignores the keep above flag and points them to the normal layer - the code is very old and commented "no damn annoying splashscreens" ...)

The user is (probably) using openbox which will stick to the keep above flag of the splash screen and keep it above the non keep above dialog, does not hide the splash on click and (different from compiz but like kwin) allows at least for alt + lmb moving
Comment 3 Myriam Schweingruber 2012-05-10 15:59:41 UTC
Thomas, you seem to miss the point, as this is happening on KDE as well, see the bug I referred to.
Comment 4 Hohyeis 2012-05-16 09:38:02 UTC
Kwin is not running. I'm using XFCE.
Comment 5 Edward Hades 2012-08-14 19:57:23 UTC
Git commit 84c05d37ac5be1c836948ca5e41a0f824969544e by Edward Hades.
Committed on 14/08/2012 at 21:49.
Pushed by hades into branch 'master'.

Detect Amazon country automatically.

This uses KDE locale settings and avoids "choose your country" popup at
first startup.
Related: bug 301242, bug 303272

M  +19   -10   src/services/amazon/AmazonStore.cpp
M  +8    -0    src/services/amazon/AmazonStore.h

http://commits.kde.org/amarok/84c05d37ac5be1c836948ca5e41a0f824969544e
Comment 6 esprit.tordu 2012-09-05 17:25:27 UTC
This bug affected me today.  I am running xfce and amarok 2.5.  The store config popped up behind a splashscreen and it was not obvious that there was a prompt anywhere.  Just a sliver of the store config prompt was showing from behind the splashscreen.  This would probably stop a beginning linux user in their tracks and they would adopt another media player.   Alt+tabbing does not allow you to get the store service config to gain prominence over the splashscreen either.