Bug 299433 - choqok twitter no photo preview
Summary: choqok twitter no photo preview
Status: RESOLVED FIXED
Alias: None
Product: choqok
Classification: Unclassified
Component: Twitter (show other bugs)
Version: Git
Platform: Compiled Sources Linux
: NOR normal with 25 votes (vote)
Target Milestone: 1.5
Assignee: Daniel Kreuter
URL:
Keywords:
: 338409 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-05-05 10:51 UTC by Philippe ROUBACH
Modified: 2014-12-14 18:06 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 1.5


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe ROUBACH 2012-05-05 10:51:55 UTC
mandriva 2010.2 i586
kde 4.5.5
choqok 1.2


Reproducible: Always

Steps to Reproduce:
i connect to my twitter account with my internet browser
then
i edit a twitt :

i type a text
then
i click on the 'DC' button to join a photo
then
i send the twitt
then
i go to choqok
then
i see my tweet
there is a link to the photo
but no preview
in the contrary of twitter site

the external module "preview a photo" is well checked in the settings

Actual Results:  
no preview for an attached photo


Expected Results:  
preview for an attached photo
Comment 1 Mehrdad Momeny 2012-06-09 03:37:08 UTC
Twitter has no image preview API, or I can't find it :/
Comment 2 Philippe ROUBACH 2012-06-09 07:25:14 UTC
i don't understand your answer.

what is the utility of the external module "photo preview" in choqok settings ?
Comment 3 Mehrdad Momeny 2012-06-09 08:09:40 UTC
(In reply to comment #2)
> i don't understand your answer.
> 
> what is the utility of the external module "photo preview" in choqok
> settings ?

We need a API from twitter side, to fetch a thumbnail of images, just like twitpic and other image servers that "photo preview" plugin is doing them! Right now, As I know, images on twitter server are just a URL link in Choqok! And we have no tool (API) to convert them to a link to a thumbnail image to show.
Comment 4 Mehrdad Momeny 2012-06-09 08:21:17 UTC
I found the API, it was quite hidden :/
Comment 5 Mehrdad Momeny 2012-06-09 08:28:12 UTC
We need to get and store Tweet entities https://dev.twitter.com/docs/tweet-entities
And by adding ":thumb" text to "media_url" field, we can find the thumbnail of image
e.g.:
"media_url": "http://p.twimg.com/AQ9JtQsCEAA7dEN.jpg"
thumbnail image URL: http://p.twimg.com/AQ9JtQsCEAA7dEN.jpg:thumb
Comment 6 Philippe ROUBACH 2012-06-09 09:27:24 UTC
ok thanks

you did not answer to one of my question.

what is the function of the external modules "photo preview" and "video preview" in choqok setrtings ?

thanks
Comment 7 Mehrdad Momeny 2012-06-09 10:05:26 UTC
(In reply to comment #6)
> ok thanks
> 
> you did not answer to one of my question.
> 
> what is the function of the external modules "photo preview" and "video
> preview" in choqok setrtings ?
> 
> thanks
Their job is as you think, getting a preview from videos and photos to show in Choqok, but not everything! right now they support some special services, such as Youtube/Twitpic/...
Comment 8 Daniel Kreuter 2014-03-05 17:57:15 UTC
Hi,

I will have a look at this.

I also updated the version information above, since this is still valid in the current git version.

Cheers,

Daniel
Comment 9 Daniel Kreuter 2014-04-05 09:28:33 UTC
Git commit 3ac39f19dfda65da4c46cae1302edde51961f25c by Daniel Kreuter.
Committed on 19/03/2014 at 19:45.
Pushed by dkreuter into branch 'master'.

Value changed for when to start resizing.

M  +3    -2    libchoqok/ui/postwidget.cpp

http://commits.kde.org/choqok/3ac39f19dfda65da4c46cae1302edde51961f25c
Comment 10 Daniel Kreuter 2014-04-05 09:28:36 UTC
Git commit 3e76e36ea47f0cbf1600219e6a03999719799d1b by Daniel Kreuter.
Committed on 13/03/2014 at 20:08.
Pushed by dkreuter into branch 'master'.

Preview of images from Twitter

Added preview of images postet via Twitter.

M  +27   -0    helperlibs/twitterapihelper/twitterapimicroblog.cpp
M  +4    -0    libchoqok/choqoktypes.h
M  +3    -2    libchoqok/mediamanager.cpp
M  +5    -0    libchoqok/mediamanager.h
M  +56   -12   libchoqok/ui/postwidget.cpp
M  +8    -0    libchoqok/ui/postwidget.h

http://commits.kde.org/choqok/3e76e36ea47f0cbf1600219e6a03999719799d1b
Comment 11 Daniel Kreuter 2014-04-05 09:28:38 UTC
Git commit dca7a2846040a3ecb028126d55eae3f81ea6ccdc by Daniel Kreuter.
Committed on 15/03/2014 at 16:45.
Pushed by dkreuter into branch 'master'.

Fixed table of own posts and added resize to image to fit better into gui

The layout for the own tweets was broken with my last change. That's working now as expected again.
Additionally images will now be scaled down if they are to big to fit in the
postwidget when the user resizes the window.

M  +30   -7    libchoqok/ui/postwidget.cpp

http://commits.kde.org/choqok/dca7a2846040a3ecb028126d55eae3f81ea6ccdc
Comment 12 Daniel Kreuter 2014-04-05 09:28:39 UTC
Git commit f282e6c5e9cd2c3e05bbd67bde864de313230f58 by Daniel Kreuter.
Committed on 19/03/2014 at 19:37.
Pushed by dkreuter into branch 'master'.

Fixed broken layout of other's tweets

M  +1    -3    libchoqok/ui/postwidget.cpp

http://commits.kde.org/choqok/f282e6c5e9cd2c3e05bbd67bde864de313230f58
Comment 13 Philippe ROUBACH 2014-04-05 09:36:02 UTC
thanks for all
Comment 14 Daniel Kreuter 2014-04-05 09:56:55 UTC
Git commit 97d7cf75efc93d9ae353685fa71e779de875a4f1 by Daniel Kreuter.
Committed on 05/04/2014 at 11:25.
Pushed by dkreuter into branch 'master'.

Added support for pictures in Twitter posts.

Choqok will now be able to display images of tweets if available.


http://commits.kde.org/choqok/97d7cf75efc93d9ae353685fa71e779de875a4f1
Comment 15 Philippe ROUBACH 2014-12-13 16:40:23 UTC
thanks
Comment 16 Andrea Scarpino 2014-12-14 18:06:24 UTC
*** Bug 338409 has been marked as a duplicate of this bug. ***