Bug 299387 - Amarok crashes when opening the main window [corrupt .xspf file]
Summary: Amarok crashes when opening the main window [corrupt .xspf file]
Status: RESOLVED DUPLICATE of bug 295199
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.5.0
Platform: Fedora RPMs Linux
: NOR critical (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-04 17:11 UTC by Orion Poplawski
Modified: 2012-05-06 22:31 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
current.xspf (5.34 KB, text/plain)
2012-05-04 17:37 UTC, Orion Poplawski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Orion Poplawski 2012-05-04 17:11:27 UTC
After clicking on the amarok icon in the system tray the outline of the main window appears for a bit before it crashes.

Reproducible: Always

Steps to Reproduce:
1. Click on sytem tray icon




It appears to have gotten into a recursive loop, back trace is essentially infinite.  Fedora bug is here: https://bugzilla.redhat.com/show_bug.cgi?id=814370

Program terminated with signal 11, Segmentation fault.
#0  0x42a0a67e in QVariant::create (this=0xbf5f23e8, type=300, copy=0xbf5f20e4)
    at kernel/qvariant.cpp:1383
1383        handler->construct(&d, copy);
(gdb) print *handler
$2 = {construct = 0x4523c390 <construct(QVariant::Private*, void const*)>, clear = 
    0x4523c1c0 <clear(QVariant::Private*)>, isNull = 
    0x4523b840 <isNull(QVariant::Private const*)>, load = 0, save = 0, compare = 
    0x4523b260 <compare(QVariant::Private const*, QVariant::Private const*)>, convert = 
    0x4523b9c0 <convert(QVariant::Private const*, QVariant::Type, void*, bool*)>, canConvert = 
    0, debugStream = 0x4523cc90 <streamDebug(QDebug, QVariant const&)>}

#0  0x42a0a67e in QVariant::create (this=0xbf5f23e8, type=300, copy=0xbf5f20e4)
    at kernel/qvariant.cpp:1383
#1  0x42a0a8d8 in QVariant::QVariant (this=0xbf5f23e8, typeOrUserType=300, copy=0xbf5f20e4, 
    flags=0) at kernel/qvariant.cpp:1674
#2  0x4ed36eb4 in qVariantFromValue<KSharedPtr<Meta::Track> > (t=<optimized out>)
    at /usr/include/QtCore/qvariant.h:453
#3  fromValue<KSharedPtr<Meta::Track> > (value=<optimized out>)
    at /usr/include/QtCore/qvariant.h:337
#4  Playlist::Model::data (this=0x90811c0, index=..., role=-1084283928)
    at /usr/src/debug/amarok-2.5.0/src/playlist/PlaylistModel.cpp:308
#5  0x45840968 in QSortFilterProxyModel::data (this=0x9082498, index=..., role=32)
    at itemviews/qsortfilterproxymodel.cpp:1718
#6  0x45840968 in QSortFilterProxyModel::data (this=0x9081dd8, index=..., role=32)
    at itemviews/qsortfilterproxymodel.cpp:1718
#7  0x45840968 in QSortFilterProxyModel::data (this=0x90908a8, index=..., role=32)
    at itemviews/qsortfilterproxymodel.cpp:1718
#8  0x4edce14a in Playlist::GroupingProxy::data (this=0x90908a8, index=..., role=-1084283928)
    at /usr/src/debug/amarok-2.5.0/src/playlist/proxymodels/GroupingProxy.cpp:194
#9  0x4ed66613 in data (arole=<optimized out>, this=<optimized out>)
    at /usr/include/QtCore/qabstractitemmodel.h:402
#10 Playlist::PlaylistLayout::partForItem (this=0xbf5f2460, index=...)
    at /usr/src/debug/amarok-2.5.0/src/playlist/layouts/LayoutItemConfig.cpp:173
#11 0x4edb004a in layoutForItem (index=<optimized out>, this=<optimized out>)
    at /usr/src/debug/amarok-2.5.0/src/playlist/layouts/LayoutItemConfig.h:261
#12 Playlist::PrettyItemDelegate::rowsForItem (index=...)
    at /usr/src/debug/amarok-2.5.0/src/playlist/view/listview/PrettyItemDelegate.cpp:75
#13 0x4edb01ca in Playlist::PrettyItemDelegate::sizeHint (this=0x45b666e0, option=..., index=
    ...) at /usr/src/debug/amarok-2.5.0/src/playlist/view/listview/PrettyItemDelegate.cpp:86
#14 0x457d04a4 in QListViewPrivate::itemSize (this=0x9a98438, option=..., index=...)
    at itemviews/qlistview.cpp:1783
#15 0x457d0c72 in QListView::updateGeometries (this=0x9a983e0) at itemviews/qlistview.cpp:1484
#16 0x457a83e6 in QAbstractItemView::resizeEvent (this=0x9a983e0, event=0xbf5f2f18)
    at itemviews/qabstractitemview.cpp:2415
#17 0x457cf1a2 in QListView::resizeEvent (this=0x9a983e0, e=0xbf5f2f18)
    at itemviews/qlistview.cpp:848
#18 0x4525815f in QWidget::event (this=0x9a983e0, event=0xbf5f2f18) at kernel/qwidget.cpp:8516
#19 0x45673886 in QFrame::event (this=0x9a983e0, e=0xbf5f2f18) at widgets/qframe.cpp:557
#20 0x45707412 in QAbstractScrollArea::viewportEvent (this=0x9a983e0, e=0xbf5f2f18)
    at widgets/qabstractscrollarea.cpp:1043
#21 0x457ac6ac in QAbstractItemView::viewportEvent (this=0x9a983e0, event=0xbf5f2f18)
    at itemviews/qabstractitemview.cpp:1644
#22 0x45709bd6 in viewportEvent (this=<optimized out>, event=0xbf5f2f18)
    at widgets/qabstractscrollarea_p.h:100
#23 eventFilter (e=0xbf5f2f18, this=<optimized out>, o=<optimized out>)
    at widgets/qabstractscrollarea_p.h:116
#24 QAbstractScrollAreaFilter::eventFilter (this=0x906b800, o=0x9a97a48, e=0xbf5f2f18)
    at widgets/qabstractscrollarea_p.h:115
#25 0x429e73d6 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x889ba38, 
    receiver=0x9a97a48, event=0xbf5f2f18) at kernel/qcoreapplication.cpp:986
#26 0x451fd323 in notify_helper (e=0xbf5f2f18, receiver=0x9a97a48, this=0x889ba38)
    at kernel/qapplication.cpp:4550
#27 QApplicationPrivate::notify_helper (this=0x889ba38, receiver=0x9a97a48, e=0xbf5f2f18)
    at kernel/qapplication.cpp:4526
#28 0x4520289b in QApplication::notify (this=0x889ba38, receiver=0x9a97a48, e=0xbf5f2f18)
    at kernel/qapplication.cpp:4519
#29 0x4e22fe42 in KApplication::notify (this=0xbfdee594, receiver=0x9a97a48, event=0xbf5f2f18)
    at /usr/src/debug/kdelibs-4.8.3/kdeui/kernel/kapplication.cpp:311
#30 0x429e722e in QCoreApplication::notifyInternal (this=0xbfdee594, receiver=0x9a97a48, event=
    0xbf5f2f18) at kernel/qcoreapplication.cpp:876
#31 0x452a374e in sendEvent (event=<optimized out>, receiver=<optimized out>)
    at ../../src/corelib/kernel/qcoreapplication.h:231
#32 QWidgetPrivate::setGeometry_sys (this=0x9a97470, x=0, y=0, w=-1084281064, h=291, isMove=
    true) at kernel/qwidget_x11.cpp:2656
#33 0x452529e5 in QWidget::setGeometry (this=0x9a97a48, r=...) at kernel/qwidget.cpp:6960
#34 0x45707f9b in QAbstractScrollAreaPrivate::layoutChildren (this=0x9a98438)
    at widgets/qabstractscrollarea.cpp:480
#35 0x4570917d in QAbstractScrollArea::event (this=0x9a983e0, e=0xbf5f36a8)
    at widgets/qabstractscrollarea.cpp:924
#36 0x457b83ac in QAbstractItemView::event (this=0x9a983e0, event=0xbf5f36a8)
    at itemviews/qabstractitemview.cpp:1580
#37 0x457cf774 in QListView::event (this=0x9a983e0, e=0xbf5f36a8)
    at itemviews/qlistview.cpp:1627
#38 0x451fd354 in notify_helper (e=0xbf5f36a8, receiver=0x9a983e0, this=0x889ba38)
    at kernel/qapplication.cpp:4554
#39 QApplicationPrivate::notify_helper (this=0x889ba38, receiver=0x9a983e0, e=0xbf5f36a8)
    at kernel/qapplication.cpp:4526
#40 0x4520289b in QApplication::notify (this=0x889ba38, receiver=0x9a983e0, e=0xbf5f36a8)
    at kernel/qapplication.cpp:4519
#41 0x4e22fe42 in KApplication::notify (this=0xbfdee594, receiver=0x9a983e0, event=0xbf5f36a8)
    at /usr/src/debug/kdelibs-4.8.3/kdeui/kernel/kapplication.cpp:311
#42 0x429e722e in QCoreApplication::notifyInternal (this=0xbfdee594, receiver=0x9a983e0, event=
    0xbf5f36a8) at kernel/qcoreapplication.cpp:876
#43 0x4525278a in sendEvent (event=0xbf5f36a8, receiver=0x9a983e0)
    at ../../src/corelib/kernel/qcoreapplication.h:231
#44 QWidget::setContentsMargins (this=0x9a983e0, left=0, top=0, right=0, bottom=17)
    at kernel/qwidget.cpp:7189
#45 0x456732a0 in QFrame::setFrameRect (this=0x9a983e0, r=...) at widgets/qframe.cpp:469
#46 0x457082ab in QAbstractScrollAreaPrivate::layoutChildren (this=0x9a98438)
    at widgets/qabstractscrollarea.cpp:403
#47 0x457d0b3a in QListView::updateGeometries (this=0x9a983e0) at itemviews/qlistview.cpp:1493
#48 0x457a83e6 in QAbstractItemView::resizeEvent (this=0x9a983e0, event=0xbf5f41f8)
    at itemviews/qabstractitemview.cpp:2415
#49 0x457cf1a2 in QListView::resizeEvent (this=0x9a983e0, e=0xbf5f41f8)
    at itemviews/qlistview.cpp:848
#50 0x4525815f in QWidget::event (this=0x9a983e0, event=0xbf5f41f8) at kernel/qwidget.cpp:8516
#51 0x45673886 in QFrame::event (this=0x9a983e0, e=0xbf5f41f8) at widgets/qframe.cpp:557
#52 0x45707412 in QAbstractScrollArea::viewportEvent (this=0x9a983e0, e=0xbf5f41f8)
    at widgets/qabstractscrollarea.cpp:1043
#53 0x457ac6ac in QAbstractItemView::viewportEvent (this=0x9a983e0, event=0xbf5f41f8)
    at itemviews/qabstractitemview.cpp:1644
#54 0x45709bd6 in viewportEvent (this=<optimized out>, event=0xbf5f41f8)
    at widgets/qabstractscrollarea_p.h:100
#55 eventFilter (e=0xbf5f41f8, this=<optimized out>, o=<optimized out>)
    at widgets/qabstractscrollarea_p.h:116
#56 QAbstractScrollAreaFilter::eventFilter (this=0x906b800, o=0x9a97a48, e=0xbf5f41f8)
    at widgets/qabstractscrollarea_p.h:115
#57 0x429e73d6 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x889ba38, 
    receiver=0x9a97a48, event=0xbf5f41f8) at kernel/qcoreapplication.cpp:986
#58 0x451fd323 in notify_helper (e=0xbf5f41f8, receiver=0x9a97a48, this=0x889ba38)
    at kernel/qapplication.cpp:4550
#59 QApplicationPrivate::notify_helper (this=0x889ba38, receiver=0x9a97a48, e=0xbf5f41f8)
    at kernel/qapplication.cpp:4526
#60 0x4520289b in QApplication::notify (this=0x889ba38, receiver=0x9a97a48, e=0xbf5f41f8)
    at kernel/qapplication.cpp:4519
#61 0x4e22fe42 in KApplication::notify (this=0xbfdee594, receiver=0x9a97a48, event=0xbf5f41f8)
    at /usr/src/debug/kdelibs-4.8.3/kdeui/kernel/kapplication.cpp:311
#62 0x429e722e in QCoreApplication::notifyInternal (this=0xbfdee594, receiver=0x9a97a48, event=
    0xbf5f41f8) at kernel/qcoreapplication.cpp:876
#63 0x452a374e in sendEvent (event=<optimized out>, receiver=<optimized out>)
    at ../../src/corelib/kernel/qcoreapplication.h:231
#64 QWidgetPrivate::setGeometry_sys (this=0x9a97470, x=0, y=0, w=-1084276232, h=308, isMove=
    true) at kernel/qwidget_x11.cpp:2656
#65 0x452529e5 in QWidget::setGeometry (this=0x9a97a48, r=...) at kernel/qwidget.cpp:6960
#66 0x45707f9b in QAbstractScrollAreaPrivate::layoutChildren (this=0x9a98438)
    at widgets/qabstractscrollarea.cpp:480
#67 0x4570917d in QAbstractScrollArea::event (this=0x9a983e0, e=0xbf5f4988)
    at widgets/qabstractscrollarea.cpp:924
#68 0x457b83ac in QAbstractItemView::event (this=0x9a983e0, event=0xbf5f4988)
    at itemviews/qabstractitemview.cpp:1580
#69 0x457cf774 in QListView::event (this=0x9a983e0, e=0xbf5f4988)
    at itemviews/qlistview.cpp:1627
#70 0x451fd354 in notify_helper (e=0xbf5f4988, receiver=0x9a983e0, this=0x889ba38)
    at kernel/qapplication.cpp:4554
#71 QApplicationPrivate::notify_helper (this=0x889ba38, receiver=0x9a983e0, e=0xbf5f4988)
    at kernel/qapplication.cpp:4526
#72 0x4520289b in QApplication::notify (this=0x889ba38, receiver=0x9a983e0, e=0xbf5f4988)
    at kernel/qapplication.cpp:4519
#73 0x4e22fe42 in KApplication::notify (this=0xbfdee594, receiver=0x9a983e0, event=0xbf5f4988)
    at /usr/src/debug/kdelibs-4.8.3/kdeui/kernel/kapplication.cpp:311
#74 0x429e722e in QCoreApplication::notifyInternal (this=0xbfdee594, receiver=0x9a983e0, event=
    0xbf5f4988) at kernel/qcoreapplication.cpp:876
#75 0x4525278a in sendEvent (event=0xbf5f4988, receiver=0x9a983e0)
    at ../../src/corelib/kernel/qcoreapplication.h:231
#76 QWidget::setContentsMargins (this=0x9a983e0, left=0, top=0, right=17, bottom=0)
    at kernel/qwidget.cpp:7189

this keeps going for thousands of frames.
Comment 1 Orion Poplawski 2012-05-04 17:18:07 UTC
(gdb) bt -25
#55445 0x45257e32 in QWidget::event (this=0x9a983e0, event=0xbfdee28c)
    at kernel/qwidget.cpp:8821
#55446 0x45673886 in QFrame::event (this=0x9a983e0, e=0xbfdee28c) at widgets/qframe.cpp:557
#55447 0x45708f94 in QAbstractScrollArea::event (this=0x9a983e0, e=0xbfdee28c)
    at widgets/qabstractscrollarea.cpp:996
#55448 0x457b83ac in QAbstractItemView::event (this=0x9a983e0, event=0xbfdee28c)
    at itemviews/qabstractitemview.cpp:1580
#55449 0x457cf774 in QListView::event (this=0x9a983e0, e=0xbfdee28c)
    at itemviews/qlistview.cpp:1627
#55450 0x451fd354 in notify_helper (e=0xbfdee28c, receiver=0x9a983e0, this=0x889ba38)
    at kernel/qapplication.cpp:4554
#55451 QApplicationPrivate::notify_helper (this=0x889ba38, receiver=0x9a983e0, e=0xbfdee28c)
    at kernel/qapplication.cpp:4526
#55452 0x4520289b in QApplication::notify (this=0x889ba38, receiver=0x9a983e0, e=0xbfdee28c)
    at kernel/qapplication.cpp:4519
#55453 0x4e22fe42 in KApplication::notify (this=0xbfdee594, receiver=0x9a983e0, event=
    0xbfdee28c) at /usr/src/debug/kdelibs-4.8.3/kdeui/kernel/kapplication.cpp:311
#55454 0x429e722e in QCoreApplication::notifyInternal (this=0xbfdee594, receiver=0x9a983e0, 
    event=0xbfdee28c) at kernel/qcoreapplication.cpp:876
#55455 0x42a1bfd0 in sendEvent (event=0xbfdee28c, receiver=<optimized out>)
    at kernel/qcoreapplication.h:231
#55456 QTimerInfoList::activateTimers (this=0x889a874) at kernel/qeventdispatcher_unix.cpp:611
#55457 0x42a196b9 in timerSourceDispatch (source=0x889a840)
    at kernel/qeventdispatcher_glib.cpp:186
#55458 timerSourceDispatch (source=0x889a840) at kernel/qeventdispatcher_glib.cpp:180
#55459 0x4a61caff in g_main_dispatch (context=0x889a780) at gmain.c:2441
#55460 g_main_context_dispatch (context=0x889a780) at gmain.c:3011
#55461 0x4a61d240 in g_main_context_iterate (context=0x889a780, block=1247984912, dispatch=1, 
    self=0x8899ef0) at gmain.c:3089
#55462 0x4a61d4ef in g_main_context_iteration (context=0x889a780, may_block=1) at gmain.c:3152
#55463 0x42a19ee8 in QEventDispatcherGlib::processEvents (this=0x879c9b8, flags=...)
    at kernel/qeventdispatcher_glib.cpp:424
#55464 0x452b1e4b in QGuiEventDispatcherGlib::processEvents (this=0x879c9b8, flags=...)
    at kernel/qguieventdispatcher_glib.cpp:207
#55465 0x429e611e in QEventLoop::processEvents (this=0xbfdee504, flags=...)
    at kernel/qeventloop.cpp:149
#55466 0x429e63c9 in QEventLoop::exec (this=0xbfdee504, flags=...) at kernel/qeventloop.cpp:204
#55467 0x429eb56b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#55468 0x451fb155 in QApplication::exec () at kernel/qapplication.cpp:3815
#55469 0x0804fd3a in main (argc=1, argv=0xbfdeef44)
    at /usr/src/debug/amarok-2.5.0/src/main.cpp:303
Comment 2 Orion Poplawski 2012-05-04 17:37:08 UTC
Created attachment 70859 [details]
current.xspf

Deleting this .kde/share/apps/amarok/current.xspf fixed the crash.
Comment 3 Myriam Schweingruber 2012-05-06 11:00:16 UTC
And which Amarok version is this about?
Comment 4 Rex Dieter 2012-05-06 14:40:43 UTC
2.5.0
Comment 5 Myriam Schweingruber 2012-05-06 22:31:24 UTC
Thank you for the feedback, this is solved in git already.

*** This bug has been marked as a duplicate of bug 295199 ***