Bug 299256 - IMAP not available offline
Summary: IMAP not available offline
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 4.8.4
Platform: OpenSUSE Linux
: NOR major with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-02 20:03 UTC by Axel Braun
Modified: 2016-12-13 16:58 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Axel Braun 2012-05-02 20:03:08 UTC
Running KMail in KDE 4.8.2 with several IMAP accounts configured.
I set KMail2 to offline and then switched off the network - so a typical offline usage.
Result:
No mails available offline
akonadiserver IMAP (or similar) crashed

To have all IMAP mail accounts unavailable in offline mode is a mess - that was working perfectly with KMail 1 . Please reenable resp. fix!

Reproducible: Always

Steps to Reproduce:
1. Switch off network
2. no mails available in IMAP folders
3.


Expected Results:  
KMail can be used offline - switch between IMAP accounts is possible, mails are displayed

Was working in KMail 1
Comment 1 Axel Braun 2012-05-21 09:54:00 UTC
In Mail accounts in the KMail preferences, there is a new setting "Enable disconnected mode" in "Advanced", which needs to be ticked. 

Can this maybe set by default?
Comment 2 Axel Braun 2012-05-23 07:04:27 UTC
...but it does not solve the problem: After I switched between 2 IMAP Accounts, no mails are displayed anymore. So the bug is still valid (unfortunately)
Comment 3 PhobosK 2012-06-27 07:02:49 UTC
This is not fixed even in 4.8.4. I confirm this bug on 4.8.4 too.
No matter if the IMAP is in disconnected mode (the option for the account 'Enable disconnected mode') or not, when no network KMail2 goes to offline mode and makes all IMAP accounts unavailable.

Another problem with this is that if KMail checks for new mails and right at this time the network disappears, Kmail2 keeps on checking and after a while it spews errors about inability to connect to the accounts... The expected behavior is to stop all online checks and to go offline....
Comment 4 Myriam Schweingruber 2012-08-18 21:36:02 UTC
Setting status to confirmed based on comment #3
Comment 5 Martin Bednar 2013-03-05 15:09:28 UTC
KDE 4.10.1:
I have 2 IMAP accounts configured in disconnected mode (GMail and my school server). The school server works fine, GMail doesn't. 
Differences : school server has in the hundreds of messages, Gmail  > 15K . I have manually selected which folders to subscribe to in gmail, not in the school IMAP.

What happens : when I start kmail disconnected, GMail inbox doesn't load (keeps spinning). All other folders I tried in this resource load. When connection is established, only new mails (not available on previous connection, read/unread isn't relevant) are shown in inbox, other folders still work fine. 

Happens on both Chakra and Gentoo. I'll gladly provide any other information you need.
Comment 6 Axel Braun 2013-05-07 12:11:38 UTC
Offline mode for disconnected IMAp is still not reliable in 4.10.2.
Is it maybe a caching problem in akonadi?
Comment 7 Till Schäfer 2013-10-15 18:13:36 UTC
the problem is gone for me in kde 4.11.2. after upgrading to that version a lot of emails were loaded to the cache and since now everything works fine in offline mode.
Comment 8 werner 2014-05-01 08:53:02 UTC
well, I see this (mails not readable in disconnected imap account when server is not available) here in kmail from kde 4.13 .
not in each case, however, as it seems that recently added emails are still visible/readable, while older ones are not.
Comment 9 werner 2014-05-02 10:57:40 UTC
(In reply to comment #8)
> well, I see this (mails not readable in disconnected imap account when
> server is not available) here in kmail from kde 4.13 .
> not in each case, however, as it seems that recently added emails are still
> visible/readable, while older ones are not.

additional note: after having exported all mails (server online, of course), I can now read all mails also when the server is offline.
with older kmail versions, this was not necessary - emails were always available offline.
Comment 10 Denis Kurz 2016-09-24 18:02:56 UTC
This bug has only been reported for versions before 4.14, which have been unsupported for at least two years now. Can anyone tell if this bug still present?

If noone confirms this bug for a Framework-based version of kmail2 (version 5.0 or later, as part of KDE Applications 15.12 or later), it gets closed in about three months.
Comment 11 Axel Braun 2016-12-13 08:10:55 UTC
Works in Kmail 5.3.2
Comment 12 Christoph Feck 2016-12-13 13:30:23 UTC
Axel, confirmed that it is fixed or that it does not work?
Comment 13 Axel Braun 2016-12-13 16:58:55 UTC
confirmed that it is fixed. Following your remark in the other bug I set it to resolved