Bug 299254 - Regression: QML lock/logout applet only lays out icons in panel direction
Summary: Regression: QML lock/logout applet only lays out icons in panel direction
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: desktop (show other bugs)
Version: 4.8.80 (beta1)
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: regression
: 164911 285073 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-05-02 19:32 UTC by Luca Beltrame
Modified: 2012-06-12 18:04 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.9


Attachments
Screenshot showing the issue (14.51 KB, image/png)
2012-05-02 19:33 UTC, Luca Beltrame
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luca Beltrame 2012-05-02 19:32:25 UTC
In the C++ version of the lock/logout applet, there was an alternative layout that made icons vertical, thus making them smaller and more fit for panels. With the QML version, this is no longer possible, and as result icons can take up quite a lot of space in a panel, especially if adding many buttons (see attached screenshot).

Reproducible: Always

Steps to Reproduce:
1. Add Lock/Logout applet to panel

Actual Results:  
There is no way to stack the buttons vertically like in the C++ applet.

Expected Results:  
The same layout options should be offered in the QML version.

From today's git master.
Comment 1 Luca Beltrame 2012-05-02 19:33:20 UTC
Created attachment 70812 [details]
Screenshot showing the issue
Comment 2 Myriam Schweingruber 2012-06-02 22:03:43 UTC
Which exact KDE version is this about?
Comment 3 Luca Beltrame 2012-06-02 22:06:25 UTC
In data sabato 02 giugno 2012 22:03:43, hai scritto:

> Which exact KDE version is this about?

Git master for everything + latest 4.8 branch for kdelibs.
Comment 4 Myriam Schweingruber 2012-06-02 22:26:42 UTC
Thank you for the fast feedback.
Comment 5 Thijs 2012-06-05 08:55:00 UTC
Confirmed here for 4.8b1. The funny thing is, the orientation changes as a desktop applet automatically, depending on the aspect ratio of the applet. In the panel, that does not happen. Marking as regression.
Comment 6 Rolf Eike Beer 2012-06-06 18:46:10 UTC
The icons are always laid out in the same direction as the panel. I have a vertical panel and would love to see them laid out horizontally...
Comment 7 perrantrevan 2012-06-06 19:21:08 UTC
I confirm for 4.9b1.

It's only a niggle and personal preference, but I'd rather not use the applet than have the applet taking up so much space in the panel.
Comment 8 Viranch Mehta 2012-06-08 19:01:07 UTC
*** Bug 164911 has been marked as a duplicate of this bug. ***
Comment 9 Viranch Mehta 2012-06-08 22:19:25 UTC
Git commit 8b0fd31b65327278e5c81c36a6d26d50292ff75f by Viranch Mehta.
Committed on 09/06/2012 at 00:16.
Pushed by viranch into branch 'master'.

Change orientation when inside an applet automatically

Change the orientation to occupy minimum visible area
on the panel
FIXED-IN: 4.9

M  +46   -46   plasma/generic/applets/lock_logout/contents/ui/lockout.qml

http://commits.kde.org/kde-workspace/8b0fd31b65327278e5c81c36a6d26d50292ff75f
Comment 10 David Edmundson 2012-06-12 18:04:21 UTC
*** Bug 285073 has been marked as a duplicate of this bug. ***