Bug 299174 - Remove "week number" from system tray calendar for improved readability
Summary: Remove "week number" from system tray calendar for improved readability
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-clock (show other bugs)
Version: 4.8.3
Platform: Fedora RPMs Linux
: NOR wishlist with 145 votes (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL: http://i.imgur.com/un2du.png
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-01 15:12 UTC by Michael
Modified: 2016-02-04 23:34 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In:
myriam: Usability?


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael 2012-05-01 15:12:28 UTC
1. Click the digital clock in the system tray to call up the calendar
2. Stare confused at the 8-day week presented with non-sequential days
3. Eventually realise that the extra column is "week number"
4. Look for option to disable it, fail to find such an option

The week number is essentially useless and need not be displayed. It serves only to confuse, as its a mysterious unlabeled column. I've never had to determine week number, only Julian day occasionally (cal -j). 

If removing it won't be considered, provide an option to disable it, preferably disabled by default.

Reproducible: Always

Steps to Reproduce:
Click the digital clock in the system tray to call up the calendar
Actual Results:  
A calendar with 8 columns is presented

Expected Results:  
A calendar with only 7 columns should be presented

The colours encircling some days (blue, red and green) are confusing as well. It's not immediately obvious which day today is; rather one needs to cross reference the list at the right with the marked days to eventually realise  red=public holiday, green=other holiday, and by process of elimination, blue must be today. Yeah yeah, it's not really rocket science. However reading a calendar should not require effort. Perhaps the extra space freed up by removing the week-number column can be replaced with a legend for the red,blue,green colours.
Comment 1 Myriam Schweingruber 2012-06-02 22:03:25 UTC
Which exact KDE version is this about?
Comment 2 Michael 2012-06-02 23:43:14 UTC
I believe it's 4.8.3 as most of the kde-* packages from "rpm -qa" are 4.8.3. Is there a specific package I should look for? 

$ rpm -qa|grep plasma
kde-plasma-networkmanagement-openvpn-0.9.0.1-1.fc16.x86_64
kde-plasma-networkmanagement-vpnc-0.9.0.1-1.fc16.x86_64
kde-settings-plasma-4.7-14.fc16.noarch
kde-plasma-networkmanagement-libs-0.9.0.1-1.fc16.x86_64
kdeplasma-addons-libs-4.8.3-1.fc16.x86_64
plasma-scriptengine-python-4.8.3-3.fc16.x86_64
kde-plasma-networkmanagement-0.9.0.1-1.fc16.x86_64
kde-plasma-networkmanagement-pptp-0.9.0.1-1.fc16.x86_64
kdeplasma-addons-4.8.3-1.fc16.x86_64
kde-plasma-networkmanagement-openconnect-0.9.0.1-1.fc16.x86_64
Comment 3 Jekyll Wu 2012-06-02 23:48:22 UTC
Thanks for your feedback
Comment 4 andrew_kde 2012-08-26 00:16:05 UTC
I'm with Micheal.  I have tried to decipher the calendar also.  I can not understand why you can configure the bejesus out of the clock, but the calendar is a immutable monolithic totem to somebody's preferred format.

Not only is the week number nearly useless, but it is presented in the column where some people expect the first day of the week (here, Sunday) to be.
Comment 5 Alexander Nestorov 2012-09-09 18:28:29 UTC
Fix that annoying bug already! -.-'
It's just a damn simple checkbox which should hide the week number.
Comment 6 Myriam Schweingruber 2012-09-10 12:56:36 UTC
(In reply to comment #5)
> Fix that annoying bug already! -.-'
> It's just a damn simple checkbox which should hide the week number.

You are welcome to give a hand...
Comment 7 Kai Uwe Broulik 2012-09-10 13:01:55 UTC
@alexandernst:
Add a checkbox here: [kde-workspace] libs/plasmaclock/calendarConfig.ui
add the logic here: [kde-workspace] libs/plasmaclock/calendartable.cpp
and then put your patch on http://git.reviewboard.kde.org
:-)
Comment 8 andrew_kde 2012-09-10 19:17:26 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > Fix that annoying bug already! -.-'
> > It's just a damn simple checkbox which should hide the week number.
> 
> You are welcome to give a hand...

Are you serious?  What an arrogant response.  Some people are not coders at all, and some write drivers or computational code.  This is UI code.  Written by UI coders.  Should I learn the inner workings of the KDE framework for this simple bug fix?

Thanks for helping make open source look like an unprofessional hobby toy.  "Fix it yourself" indeed.  Way to steer people away.  Why bother having bugs.kde.org if that is the response?
Comment 9 Christoph Feck 2012-09-10 20:29:59 UTC
This isn't arrogant, but the way it always was.

KDE is a community project, and those who volunteer to improve it, can do so. That does not imply that someone, who cannot contribute, should demand more than he can give. See also http://www.kde.org/code-of-conduct/
Comment 10 Alexander Nestorov 2012-09-10 22:50:03 UTC
I'm sorry if that sound arrogant. Instead, I wanted to express something more like "If it's not finished, don't release it. If that's your hobby, finish doing your hobby! Don't just release it saying that it's not finished and you accept patches."

Why should I fix *your* hobby? I help FOSS too, but why should I stop working on what I'm working just to make my DE usable?

You see, that's the unprofessional way. 
The professinal way -> If you're working on something and you're happy doing it, make sure that everybody else will be happy using it too.
Comment 11 andrew_kde 2012-09-10 23:11:35 UTC
Alexander, I don't think you are arrogant.  I think the attitude that you describe, which Christoph exemplifies, of "Well, if you are just a whiny user, you can suck it!  You'll get what you get and like it."

That's what turns people off to Open Source.  If I want to be mistreated, I'll give Microsoft a call.  The expectation that a user will fix a bug is unreasonable.  And completely unrecognized by this attitude is that the user is bug testing, and finding problems.  So the poor user has already done half the work.  But No!  That's not enough - now fix it too, or shut up.  Way to go.  "Do not ask for more than you can give" is it?  We've identified the problem, isolated it, and described it.  Would you like to be spoon fed and tucked into bed too?

I write device drivers for a living; I've been doing it for over 30 years.  I can write more low level code in a day than most in a week.  Should I need to fix my apps too?  I've dropped out of a couple of OSS projects because of this kind of attitude.  I don't care to be around people with an elitist mentality.  Especially when they think that I am just some idiot user who couldn't code his way out of a wet paper bag.  I think a better attitude is "each to his abilities" - I can write driver code, but not app code without shifting gears and wasting a lot of time coming up to speed on the KDE framework.  And I don't have the time for all that.  But there are people in the KDE project with those skills on tap: don't you think it would be a better use of resources for them to quickly resolve this issue?  For example, whoever wrote the calender applet in the first place?
Comment 12 Christoph Feck 2012-09-11 00:20:11 UTC
> Why should I fix *your* hobby?

You do not have to.

If you think that our work is unfinished, you have four choices:
1) use the finished work of a different community instead
2) report the deficiency, and wait until someone improves it
3) hire a commercial developer to solve the issue for you
4) join the community to learn how to solve it yourself

Please note that all options (except 1) are contributions to the KDE community.

I am interested to know if you have other options. Please discuss these on https://forum.kde.org/ because they do not belong in this bug tracker. Thanks.

> you are just a whiny user

I said that where?

> For example, whoever wrote the calender applet in the first place?

What do you suggest to do, if the original authors are no longer around? If I understand you correctly, we should immediately remove the code from the distribution, because it may be unfinished or even buggy, and no one left to look at it.

The KDE community choosed not to do this. In fact, if we would do this, we would have to remove 90% of current KDE code. I cannot possibly imagine the user reactions. Instead, we also keep unmaintained code in the distribution, in the hope that it gets love from new or existing contributors.

Again, you are invited to discuss this topic at https://forum.kde.org/ so that we can find other options.
Comment 13 Heiko Tietze 2012-09-11 12:44:30 UTC
Please stay on topic.

I would disagree with Michael's recommendation to remove the week number. If the configuration dialog has space for the discussed checkbox that option would be a good compromise (I'm on Windows right now and cannot check it). More important in my opinion is to change the appearence of week numbers if they are shown. Some ideas: smaller font, combined text (cw18,cw19...), or separation by a vertical line. My favorit is to make it an interactive element like a scroll bar.

For sake of easy coding I vote for smaller font in combination with the configuration to disable it.
Comment 14 Thomas Pfeiffer 2012-09-15 21:25:52 UTC
(From the usability team): Heiko's solution (smaller font for the week number) is a good idea. 
However a configuration option would definitely be helpful here, because the week number is useless for many people, but essential for many others: In many companies, week numbers are used regularly for time planning, but for people not working in such companies they're indeed pretty much meaningless.
Comment 15 Michael 2012-09-15 21:49:21 UTC
How about make the header "Wk" ?
Comment 16 Greg Lepore 2014-03-17 17:56:20 UTC
*** This bug has been confirmed by popular vote. ***
Comment 17 Kai Uwe Broulik 2016-02-04 23:34:04 UTC
Week numbers in Plasma 5 are off by default and can be turned on in the clock's/calendar's settings if needed. Also they're now visually separated, not part of the day grid.