Bug 299044 - kgpg displays key twice after refreshing it from server
Summary: kgpg displays key twice after refreshing it from server
Status: RESOLVED FIXED
Alias: None
Product: kgpg
Classification: Unclassified
Component: general (show other bugs)
Version: 2.7.2
Platform: Ubuntu Packages Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Rolf Eike Beer
URL:
Keywords:
: 306533 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-04-29 16:44 UTC by Stanislav Sidorenko
Modified: 2012-09-10 17:47 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.8.4


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stanislav Sidorenko 2012-04-29 16:44:18 UTC
If user right-clicks on a key and then clicks "Refresh key from server" then key will be displayed twice in the list after updating it from server. Refreshing the list removes the duplicate.
Comment 1 Rolf Eike Beer 2012-04-29 17:08:53 UTC
I see this, too. Weird.
Comment 2 Rolf Eike Beer 2012-04-29 21:52:34 UTC
Git commit 2fe1b683cec044f96cf973ea2feace70aeb7e6f5 by Rolf Eike Beer.
Committed on 29/04/2012 at 23:52.
Pushed by dakon into branch 'KDE/4.8'.

prevent that a key shows up twice after reloading it from keyserver
FIXED-IN:4.8.4

M  +14   -0    core/KGpgKeyNode.cpp
M  +8    -0    core/KGpgKeyNode.h
M  +1    -1    core/KGpgRootNode.cpp
M  +13   -4    model/kgpgitemmodel.cpp

http://commits.kde.org/kgpg/2fe1b683cec044f96cf973ea2feace70aeb7e6f5
Comment 3 Rolf Eike Beer 2012-09-10 17:47:53 UTC
*** Bug 306533 has been marked as a duplicate of this bug. ***