Bug 299031 - Add a table twice in Query editor
Summary: Add a table twice in Query editor
Status: CLOSED DUPLICATE of bug 277869
Alias: None
Product: KEXI
Classification: Unclassified
Component: Queries (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Jarosław Staniek
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-29 12:33 UTC by Werner Llacer
Modified: 2012-08-11 11:22 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Sample database (11.00 KB, application/octet-stream)
2012-04-29 12:34 UTC, Werner Llacer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Werner Llacer 2012-04-29 12:33:55 UTC
On the Graphical Query editor one should be able to define more than one relationship between two tables without resorting to SQL edition


(Haven't found any similar entry. Sorry if duplicate)

Reproducible: Always

Steps to Reproduce:
1. Design follow schema
      Table Comunication (Id,fromPersonId, toPersonId, .....)
      Person(Id,personName, ....)
  We plan to have a query which lists details of the communication event and the names of the persons involved
2. We create a query thru the graphic editor. It only allows the inclusion of persons once; and the definition of only a relationship btw. communication AND person (see query llamadas in the sample database)
3. The query with two relationships is doable and works in plain SQL edition (see query Insql in the sample database); so there is no engine limitation


Expected Results:  
The GUI query editor should be able to allow the design of such multiple relationship between tables; either inserting n-times a table into the editor area (as other products do) or painting multiple relationship links between two

Drawing multiple relationships is more "natural" but can lead to obscure graphics.
Inserting multiple instances of a table is conceptually "clumsy" but is an easy view
Comment 1 Werner Llacer 2012-04-29 12:34:55 UTC
Created attachment 70751 [details]
Sample database
Comment 2 Dimitrios T Tanis 2012-04-29 19:42:14 UTC
Hi Werner.

This is the same issue as mentioned in bug277869, so I closed this one as duplicate.

*** This bug has been marked as a duplicate of bug 277869 ***