Bug 298645 - Amarok does not play tracks, added to playlist from cd
Summary: Amarok does not play tracks, added to playlist from cd
Status: RESOLVED DUPLICATE of bug 285885
Alias: None
Product: amarok
Classification: Applications
Component: Collections/CD (show other bugs)
Version: 2.5.0
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-23 09:01 UTC by Ilya Potapov
Modified: 2012-04-26 14:44 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ilya Potapov 2012-04-23 09:01:17 UTC
When i add an Audio-CD from Amarok sources panel to play list, all tracks are marked grey (like disabled or smth), and pressing 'Play' button causes nothing.
If i add tracks from CD to existing play list, playback comes to the end of last 'not-from-CD' track and then stops.
 So i am not able to play Audio-CD in Amarok.
Please notice, that Amarok freezes for a couple of minutes after inserting CD or after starting Amarok having CD inserted already.

Reproducible: Always

Steps to Reproduce:
1. Insert Audio-CD
2. Start Amarok
3. Add Audio-CD to playlist
4. Click 'Play' button
Actual Results:  
Amarok freezes for a couple of minutes after start.
All tracks are grey. 'Play' not works

Expected Results:  
Playback starts.

I should say, that i am using CDEmu for now, because .cue sheets support in Amarok is poor and buggy. But, for example, VLC recognizes and plays emulated Audio-CD very well. I will test Amarok with a real CD in the evening and write back the results.
Comment 1 Myriam Schweingruber 2012-04-24 10:20:51 UTC
Which exact Amarok version do you use? There was bug 285885 in Amarok 2.5 which is already solved in the development branch though.
Comment 2 Ilya Potapov 2012-04-26 14:44:59 UTC
I'm sorry i have not specified version. Yes, it is 2.5.0 as in that bug, so i think my bug is duplicate of bug 285885. Could you tell me, what is approximate date of 2.6 release?

*** This bug has been marked as a duplicate of bug 285885 ***