Bug 298487 - Improve highlight windows effect to better dim out not-highlighted windows
Summary: Improve highlight windows effect to better dim out not-highlighted windows
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: effects-various (show other bugs)
Version: 4.8.2
Platform: Ubuntu Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: usability
: 384979 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-04-20 13:19 UTC by Mirza
Modified: 2021-03-22 12:02 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.22


Attachments
Difficulty to distinguish highlighted window (320.89 KB, image/png)
2012-04-20 13:21 UTC, Mirza
Details
2 maximized windows and 4 not maximized (161.39 KB, image/jpeg)
2012-04-20 13:58 UTC, Mirza
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mirza 2012-04-20 13:19:10 UTC
When using highlight it is sometimes difficult to distinguish between bright windows.
Non selected windows are still visible enough to interfere with overall picture.

I will try to attach the picture to indicate the problem.

Reproducible: Always

Steps to Reproduce:
1. Open few bright windows (firefox blank page, dolphin, settings)
2. Hover over the task bar with highlight effect turned on
3. Try to distinguish highlighted window
Actual Results:  
Not able to distinguish highlighted window

Expected Results:  
To be able to distinguish highlighted window
Comment 1 Mirza 2012-04-20 13:21:01 UTC
Created attachment 70531 [details]
Difficulty to distinguish highlighted window
Comment 2 Martin Flöser 2012-04-20 13:43:07 UTC
The screenshot is a bad example as it shows two maximized Dolphin windows both highlighted. That's of course a useless setup for highlight windows.

Do you have a better example which does not involve highlighting multiple maximized windows?
Comment 3 Mirza 2012-04-20 13:58:19 UTC
Created attachment 70538 [details]
2 maximized windows and 4 not maximized
Comment 4 Mirza 2012-04-20 14:01:55 UTC
Please look at new screenshot.
If there is more than one maximized window it becomes difficult to distinguish highlighted window.
And almost all of my windows are maximized all the time, especially on my laptop.

I think i read in one of your posts (or someone elses) not to propose the solution only describe the problem, but i think some blur would help, or desturation of other windows, or even something like they do in windows7 peek effect.
Comment 5 Martin Flöser 2012-04-20 14:50:54 UTC
while I can easily recognize the highlighted window I see what you mean. I change it to wishlist as it is not really a bug, but the currently intended behavior of just setting all other window to translucency.

Personal I have no idea on what and how this can be improved, I would say this needs designer input.
Comment 6 abulak 2012-04-20 21:59:13 UTC
How about solution ala Windows 7? The highlighted window is shown on top, whereas others are just outlines?

Maybe some application of Blur?
Highlighted is shown again on top of blurred others?

The important thing is to make the highlighted visually contrast from the others. Setting opacity to maximum and showing it ON TOP of others translucent and/or blurred should suffice.

is it possible with current Kwin effects chain?
Comment 7 Thomas Lübking 2012-04-20 22:32:28 UTC
core issue is that elevating the window elevates it above plasma popups as well - at least the effect states that (i've never tried myself. martin?)
elevating the window would however obviously be sufficient alone.
Comment 8 Martin Flöser 2012-04-21 06:23:05 UTC
> core issue is that elevating the window elevates it above plasma popups as
> well - at least the effect states that (i've never tried myself. martin?)
> elevating the window would however obviously be sufficient alone.
Yes that is the case, but should be fixable by elevating the popups, too.
Comment 9 Nate Graham 2021-03-22 02:37:06 UTC
*** Bug 384979 has been marked as a duplicate of this bug. ***
Comment 10 Nate Graham 2021-03-22 12:02:34 UTC
Git commit 8c352f685e77d4751010a395932ac1beb77a5a22 by Nate Graham, on behalf of Bharadwaj Raju.
Committed on 22/03/2021 at 12:00.
Pushed by ngraham into branch 'master'.

Make ghost windows in highlight effect be fully transparent
FIXED-IN: 5.22

M  +1    -1    src/effects/highlightwindow/highlightwindow.h

https://invent.kde.org/plasma/kwin/commit/8c352f685e77d4751010a395932ac1beb77a5a22