Bug 298392 - Quick Chat applet doesn't scroll to the bottom when new messages come in
Summary: Quick Chat applet doesn't scroll to the bottom when new messages come in
Status: RESOLVED FIXED
Alias: None
Product: telepathy
Classification: Unclassified
Component: chat-plasmoid (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal
Target Milestone: 0.5-next
Assignee: Telepathy Bugs
URL:
Keywords:
: 305829 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-04-19 07:25 UTC by Weng Xuetian
Modified: 2013-02-20 03:01 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 0.5.2


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Weng Xuetian 2012-04-19 07:25:24 UTC
ktp-text-ui is today's master snapshot.

Reproducible: Always

Steps to Reproduce:
1. receive some message length over the list
Actual Results:  
the scroll might not reach the bottom. and new message cannot be complete shown in this case.

Expected Results:  
the scroll to the bottom.
Comment 1 David Edmundson 2012-04-19 21:28:21 UTC
The main text application, not the plasmoid? 

Is this reproducible every time? 
What theme are you using?
Can you upload a screenshot.
Comment 2 Weng Xuetian 2012-04-20 03:43:04 UTC
It's plasmoid problem.

It's in Chinese, but you can see the last message is not shown completely.
http://wstaw.org/m/2012/04/20/kmix1.png

Seems usually happen when I post something.

Theme is slim glow, but air also have the problem.
Comment 3 Alex Tsi 2012-08-25 14:28:46 UTC
I think that this bug is fixed. See https://bugs.kde.org/show_bug.cgi?id=293522.
Should status change to "closed"?
Comment 4 Martin Klapetek 2012-08-25 17:08:37 UTC
No, this is not fixed. Fwiw, the scrolling is still completely crazy here on 4.9.
Comment 5 Martin Klapetek 2012-08-26 19:09:28 UTC
*** Bug 305829 has been marked as a duplicate of this bug. ***
Comment 6 Martin Klapetek 2012-08-26 19:10:37 UTC
Marking as new.
Comment 7 Aleix Pol 2012-10-11 03:04:07 UTC
This is related to: https://bugreports.qt-project.org/browse/QTBUG-27529

I'm trying to find a workaround...
Comment 8 Aleix Pol 2012-10-11 23:33:44 UTC
Git commit 14cbd86be2d406c4d58b2f97e5f648c8deef4236 by Aleix Pol.
Committed on 12/10/2012 at 01:27.
Pushed by apol into branch 'kde-telepathy-0.5'.

Fix scrolling

Workaround a bug in Qt #27592 where the ListView won't scroll to the end when
sections are being used. Dirty hack but seems to work correct.

REVIEW: 106791

M  +1    -1    plasmoid/org.kde.ktp-chatplasmoid/contents/ui/ChatWidget.qml

http://commits.kde.org/telepathy-text-ui/14cbd86be2d406c4d58b2f97e5f648c8deef4236
Comment 9 Aleix Pol 2012-10-11 23:33:49 UTC
Git commit b731bbe0a9efd52d9641ab9df2d66e60ed7114d0 by Aleix Pol.
Committed on 12/10/2012 at 01:27.
Pushed by apol into branch 'master'.

Fix scrolling

Workaround a bug in Qt #27592 where the ListView won't scroll to the end when
sections are being used. Dirty hack but seems to work correct.

REVIEW: 106791

M  +1    -1    plasmoid/org.kde.ktp-chatplasmoid/contents/ui/ChatWidget.qml

http://commits.kde.org/telepathy-text-ui/b731bbe0a9efd52d9641ab9df2d66e60ed7114d0
Comment 10 Aleix Pol 2013-02-20 03:01:22 UTC
Git commit dc5dfc8e32e6b4a285ded327d4b78c40cd24adf8 by Aleix Pol.
Committed on 20/02/2013 at 03:57.
Pushed by apol into branch 'master'.

Cache all the conversation in the ListView

Keep all the delegates in memory while showing. It could be a problem
if the conversation grows _a lot_ but it has to grow a lot.

Possible ways to solve it:
- limit the log lines that we'll be displaying. We're talking about a
plasmoid anyway. If the user wants to read the log, he'll use ktp-log-viewer.
- set interactive to false. Then we can scroll as much we want, but not with
the scrollbar
- buy a better aleix

REVIEW: 109051

M  +5    -1    chat/org.kde.ktp-chat/contents/ui/ChatWidget.qml

http://commits.kde.org/telepathy-contact-applet/dc5dfc8e32e6b4a285ded327d4b78c40cd24adf8