Bug 298376 - Window decorations and window borders (title bars and surrounding shadows) rendered incorrectly
Summary: Window decorations and window borders (title bars and surrounding shadows) re...
Status: RESOLVED DUPLICATE of bug 282882
Alias: None
Product: kwin
Classification: Unclassified
Component: kdecorations (show other bugs)
Version: 4.7.4
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL: http://wstaw.org/m/2012/04/18/plasma-...
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-18 19:39 UTC by searchfgold67899
Modified: 2012-04-18 19:52 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description searchfgold67899 2012-04-18 19:39:56 UTC
Anything surrounding a window (that is, the title bar and the buttons on it, the window borders, and the window shadows) is rendered incorrectly. This includes shadows that surround menus. The best way to describe this is with a screen shot. Reproducible with all decoration styles. Not reproducible with desktop effects off. Windows still function normally and close, minimize, maximize, and open the window menu when the appropriate place is clicked. 

Reproducible: Always

Steps to Reproduce:
1. Turn on Desktop Effects.
2. Open a window.
Actual Results:  
Window decorations, borders, and shadows are rendered incorrectly.

Expected Results:  
Expected window decorations, borders, and shadows to appear normal.

Nvidia GeForce FX 5200, driver version 173-updates. Occurs with other driver versions as well. Started occurring after upgrade to Kubuntu 11.10.
Screenshot, with window decoration, window shadow, and menu shadow behavior:
http://wstaw.org/m/2012/04/18/plasma-desktoppd3241.jpg
Comment 1 Thomas Lübking 2012-04-18 19:52:46 UTC
is bug #282882  & bug #293325 - picking random dupe
can partially be worked around by "kwin --replace --graphicssystem native &" but you want 4.8.1 or up.

*** This bug has been marked as a duplicate of bug 282882 ***