Bug 298319 - Chat window does not provide a method to clear the chat window content
Summary: Chat window does not provide a method to clear the chat window content
Status: RESOLVED FIXED
Alias: None
Product: telepathy
Classification: Unclassified
Component: text-ui (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist
Target Milestone: 0.6-next
Assignee: Telepathy Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-17 19:07 UTC by Filipe Azevedo
Modified: 2012-12-28 13:00 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 0.6.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Filipe Azevedo 2012-04-17 19:07:28 UTC
Chat window does not handle /clear command and/or does not provide a button to clear the chat window content ( privacy!!!).

Please add these features.

Reproducible: Always

Steps to Reproduce:
1. Oopen chat window
2. Speak with someone
3. type /clear
4. Chat window is not cleared
Actual Results:  
See chat windows after typing command.

Expected Results:  
Chat window to be cleared!
Comment 1 David Edmundson 2012-04-19 21:27:01 UTC
Please don't put exclamation marks in a title in future.

I don't like the concept of having "/clear" it's not intuitive, we don't follow any other commands common to IRC "/join" "/quit" etc. "/me" is a special case as it's actually referenced by XMPP.

I am happy for it to be an entry in the edit menu with an assigned keyboard shortcut. That's more in line with most KDE app behaviour.
Comment 2 Filipe Azevedo 2012-04-20 07:11:13 UTC
Sorry for the exclamation marks.
I will live with a menu entry for clearing the chat window.

Thanks,

Le 19 avril 2012 23:27, David Edmundson <kde@davidedmundson.co.uk> a écrit :
> https://bugs.kde.org/show_bug.cgi?id=298319
>
> David Edmundson <kde@davidedmundson.co.uk> changed:
>
>           What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                 CC|                            |kde@davidedmundson.co.uk
>            Summary|Chat window does not handle |Chat window does not
>                   |/clear command and/or does  |provide a method to clear
>                   |not provide a button to     |the chat window content
>                   |clear the chat window       |
>                   |content ( privacy!!!)       |
>
> --- Comment #1 from David Edmundson <kde@davidedmundson.co.uk> ---
> Please don't put exclamation marks in a title in future.
>
> I don't like the concept of having "/clear" it's not intuitive, we don't follow
> any other commands common to IRC "/join" "/quit" etc. "/me" is a special case
> as it's actually referenced by XMPP.
>
> I am happy for it to be an entry in the edit menu with an assigned keyboard
> shortcut. That's more in line with most KDE app behaviour.
>
> --
> You are receiving this mail because:
> You reported the bug.
Comment 3 David Edmundson 2012-08-09 09:07:29 UTC
Confirming, aiming for the next release after this one (0.6)
Comment 4 Rohan Garg 2012-10-22 11:04:14 UTC
When clearing the window, should we also clear logs? If so, should we clear all logs? or just the recent messages?
Comment 5 Filipe Azevedo 2012-10-22 11:55:32 UTC
My primary goal was simply to clear the widget content - not to touch the internal log.
We can already delete log using the discussion history tool.
Comment 6 Rohan Garg 2012-10-22 12:01:26 UTC
Ah, so something to just clear the chat view, and nothing else. Got it.
Comment 7 Filipe Azevedo 2012-10-22 12:04:42 UTC
Clear the content of the active discussion, exactly ;)
Comment 8 Daniel Vrátil 2012-12-28 13:00:34 UTC
Git commit c7509e10727532376b0c87f162d1f9794db07aa4 by Dan Vrátil.
Committed on 28/12/2012 at 13:58.
Pushed by dvratil into branch 'master'.

Add action to clear current chat tab

REVIEW: 107967
FIXED-IN: 0.6.0

M  +15   -0    app/chat-window.cpp
M  +1    -0    app/chat-window.h
M  +2    -0    app/chatwindow.rc
M  +55   -37   lib/chat-widget.cpp
M  +5    -0    lib/chat-widget.h

http://commits.kde.org/telepathy-text-ui/c7509e10727532376b0c87f162d1f9794db07aa4