Bug 298267 - crash when attempting to restart gmail imap connect
Summary: crash when attempting to restart gmail imap connect
Status: RESOLVED DUPLICATE of bug 325443
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: 4.8
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Christian Mollekopf
URL:
Keywords:
: 298853 299136 302537 302750 309728 309993 320128 320229 320947 321465 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-04-16 21:59 UTC by abenson
Modified: 2013-12-03 16:48 UTC (History)
17 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.05 KB, text/plain)
2012-05-22 21:00 UTC, Diego
Details
New crash information added by DrKonqi (6.05 KB, text/plain)
2012-05-22 21:00 UTC, Diego
Details
New crash information added by DrKonqi (6.44 KB, text/plain)
2012-06-18 15:09 UTC, Klaus Layer
Details
New crash information added by DrKonqi (6.62 KB, text/plain)
2013-10-07 09:16 UTC, Dennis Schridde
Details
New crash information added by DrKonqi (5.23 KB, text/plain)
2013-10-29 20:04 UTC, casey.duquette
Details

Note You need to log in before you can comment on or make changes to this bug.
Description abenson 2012-04-16 21:59:15 UTC
Application: akonadi_imap_resource (4.8)
KDE Platform Version: 4.8.1 (4.8.1)
Qt Version: 4.8.0
Operating System: Linux 3.3.1-3.fc16.x86_64 x86_64
Distribution: "Fedora release 16 (Verne)"

-- Information about the crash:
- What I was doing when the application crashed: I was unable to retrieve e-mail via GMail IMAP connection. So, in configure->accounts->receiving I select my gmail account and clicked the "restart" button. it then crashed.

-- Backtrace:
Application: GMail of type IMAP E-Mail Server (akonadi_imap_resource), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x2ba8735445c0 (LWP 4776))]

Thread 2 (Thread 0x2ba889bf5700 (LWP 4943)):
#0  0x0000003731ae85c3 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x0000003734644fd8 in g_main_context_poll (n_fds=1, fds=0x2ba890004b30, priority=<optimized out>, timeout=-1, context=0x2ba8900009a0) at gmain.c:3402
#2  g_main_context_iterate (context=0x2ba8900009a0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3084
#3  0x000000373464549c in g_main_context_iteration (context=0x2ba8900009a0, may_block=1) at gmain.c:3152
#4  0x0000003d79da7dc6 in QEventDispatcherGlib::processEvents (this=0x2ba8900008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x0000003d79d78182 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x0000003d79d783d7 in QEventLoop::exec (this=0x2ba889bf4d20, flags=...) at kernel/qeventloop.cpp:204
#7  0x0000003d79c78b27 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00000034c903c739 in KIMAP::SessionThread::run (this=0x13bfbc0) at /usr/src/debug/kdepimlibs-4.8.1/kimap/sessionthread.cpp:181
#9  0x0000003d79c7bb6b in QThreadPrivate::start (arg=0x13bfbc0) at thread/qthread_unix.cpp:298
#10 0x0000003732607d90 in start_thread (arg=0x2ba889bf5700) at pthread_create.c:309
#11 0x0000003731af0f5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x2ba8735445c0 (LWP 4776)):
[KCrash Handler]
#6  0x0000000000000081 in ?? ()
#7  0x00000034c1161e22 in ~Task (this=0x7fff988ef250, __in_chrg=<optimized out>) at /usr/src/debug/kdepimlibs-4.8.1/akonadi/resourcescheduler_p.h:64
#8  Akonadi::ResourceBase::cancelTask (this=0xf886e0) at /usr/src/debug/kdepimlibs-4.8.1/akonadi/resourcebase.cpp:792
#9  0x00000034c1161f99 in Akonadi::ResourceBase::cancelTask (this=0xf886e0, msg=...) at /usr/src/debug/kdepimlibs-4.8.1/akonadi/resourcebase.cpp:820
#10 0x000000000041d3db in ResourceState::cancelTask (this=0x12c1d80, errorString=<optimized out>) at /usr/src/debug/kdepim-runtime-4.8.1/resources/imap/resourcestate.cpp:389
#11 0x0000000000444421 in ResourceTask::cancelTask (this=0xfc5360, errorString=<optimized out>) at /usr/src/debug/kdepim-runtime-4.8.1/resources/imap/resourcetask.cpp:284
#12 0x0000000000444471 in ResourceTask::onPoolDisconnect (this=0xfc5360) at /usr/src/debug/kdepim-runtime-4.8.1/resources/imap/resourcetask.cpp:136
#13 0x0000003d79d8cce1 in QMetaObject::activate (sender=0x10562f0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#14 0x0000000000453b66 in SessionPool::disconnect (this=0x10562f0, termination=SessionPool::LogoutSession) at /usr/src/debug/kdepim-runtime-4.8.1/resources/imap/sessionpool.cpp:129
#15 0x0000000000453c37 in SessionPool::~SessionPool (this=0x10562f0, __in_chrg=<optimized out>) at /usr/src/debug/kdepim-runtime-4.8.1/resources/imap/sessionpool.cpp:54
#16 0x0000000000453d49 in SessionPool::~SessionPool (this=0x10562f0, __in_chrg=<optimized out>) at /usr/src/debug/kdepim-runtime-4.8.1/resources/imap/sessionpool.cpp:55
#17 0x0000003d79d8b395 in QObjectPrivate::deleteChildren (this=0xf854d0) at kernel/qobject.cpp:1908
#18 0x0000003d79d9166c in QObject::~QObject (this=0xf886e0, __in_chrg=<optimized out>) at kernel/qobject.cpp:927
#19 0x00000000004170c9 in ImapResource::~ImapResource (this=0xf886e0, __in_chrg=<optimized out>) at /usr/src/debug/kdepim-runtime-4.8.1/resources/imap/imapresource.cpp:156
#20 0x00000034c115e157 in Akonadi::ResourceBase::init (r=0xf886e0) at /usr/src/debug/kdepimlibs-4.8.1/akonadi/resourcebase.cpp:413
#21 0x000000000041a7f6 in Akonadi::ResourceBase::init<ImapResource> (argc=<optimized out>, argv=<optimized out>) at /usr/include/kde4/akonadi/resourcebase.h:188
#22 0x0000003731a2169d in __libc_start_main (main=0x415230 <main(int, char**)>, argc=3, ubp_av=0x7fff988ef7d8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff988ef7c8) at libc-start.c:226
#23 0x00000000004153e5 in _start ()

Reported using DrKonqi
Comment 1 Diego 2012-05-22 21:00:14 UTC
Created attachment 71299 [details]
New crash information added by DrKonqi

akonadi_imap_resource (4.8) on KDE Platform 4.8.3 (4.8.3) using Qt 4.8.1

- What I was doing when the application crashed:

Akonadi crashed on logout. Kontact was already closed.

-- Backtrace (Reduced):
#7  0x0000003e9a162492 in ~Task (this=0x7fff173456b0, __in_chrg=<optimized out>) at /usr/src/debug/kdepimlibs-4.8.3/akonadi/resourcescheduler_p.h:64
#8  Akonadi::ResourceBase::cancelTask (this=0x1f309e0) at /usr/src/debug/kdepimlibs-4.8.3/akonadi/resourcebase.cpp:792
#9  0x0000003e9a162609 in Akonadi::ResourceBase::cancelTask (this=0x1f309e0, msg=...) at /usr/src/debug/kdepimlibs-4.8.3/akonadi/resourcebase.cpp:820
#10 0x000000000041d3db in ResourceState::cancelTask (this=0x228af60, errorString=<optimized out>) at /usr/src/debug/kdepim-runtime-4.8.3/resources/imap/resourcestate.cpp:389
#11 0x0000000000444411 in ResourceTask::cancelTask (this=0x1fa6720, errorString=<optimized out>) at /usr/src/debug/kdepim-runtime-4.8.3/resources/imap/resourcetask.cpp:284
Comment 2 Diego 2012-05-22 21:00:15 UTC
Created attachment 71300 [details]
New crash information added by DrKonqi

akonadi_imap_resource (4.8) on KDE Platform 4.8.3 (4.8.3) using Qt 4.8.1

- What I was doing when the application crashed:

Akonadi crashed on logout. Kontact was already closed.

-- Backtrace (Reduced):
#7  0x0000003e9a162492 in ~Task (this=0x7fff173456b0, __in_chrg=<optimized out>) at /usr/src/debug/kdepimlibs-4.8.3/akonadi/resourcescheduler_p.h:64
#8  Akonadi::ResourceBase::cancelTask (this=0x1f309e0) at /usr/src/debug/kdepimlibs-4.8.3/akonadi/resourcebase.cpp:792
#9  0x0000003e9a162609 in Akonadi::ResourceBase::cancelTask (this=0x1f309e0, msg=...) at /usr/src/debug/kdepimlibs-4.8.3/akonadi/resourcebase.cpp:820
#10 0x000000000041d3db in ResourceState::cancelTask (this=0x228af60, errorString=<optimized out>) at /usr/src/debug/kdepim-runtime-4.8.3/resources/imap/resourcestate.cpp:389
#11 0x0000000000444411 in ResourceTask::cancelTask (this=0x1fa6720, errorString=<optimized out>) at /usr/src/debug/kdepim-runtime-4.8.3/resources/imap/resourcetask.cpp:284
Comment 3 Klaus Layer 2012-06-18 15:09:47 UTC
Created attachment 71914 [details]
New crash information added by DrKonqi

akonadi_imap_resource (4.8) on KDE Platform 4.8.3 (4.8.3) using Qt 4.8.1

- What I was doing when the application crashed:

The application crashed on shutting down the system.

-- Backtrace (Reduced):
#7  0x00007f9173e5f052 in ~Task (this=0x7fff9c9793a0, __in_chrg=<optimized out>) at ../../akonadi/resourcescheduler_p.h:64
#8  Akonadi::ResourceBase::cancelTask (this=0x26ce9e0) at ../../akonadi/resourcebase.cpp:792
#9  0x00007f9173e5f1c9 in Akonadi::ResourceBase::cancelTask (this=0x26ce9e0, msg=...) at ../../akonadi/resourcebase.cpp:820
#10 0x000000000041d69b in ResourceState::cancelTask (this=0x2a65440, errorString=...) at ../../../resources/imap/resourcestate.cpp:389
#11 0x0000000000444a71 in ResourceTask::cancelTask (this=0x2842810, errorString=...) at ../../../resources/imap/resourcetask.cpp:284
Comment 4 Daniel Vrátil 2013-06-09 14:35:02 UTC
*** Bug 299136 has been marked as a duplicate of this bug. ***
Comment 5 Daniel Vrátil 2013-06-09 14:35:32 UTC
*** Bug 302750 has been marked as a duplicate of this bug. ***
Comment 6 Daniel Vrátil 2013-06-09 14:35:42 UTC
*** Bug 320229 has been marked as a duplicate of this bug. ***
Comment 7 Daniel Vrátil 2013-06-09 14:35:49 UTC
*** Bug 320128 has been marked as a duplicate of this bug. ***
Comment 8 Daniel Vrátil 2013-06-09 14:36:05 UTC
*** Bug 309993 has been marked as a duplicate of this bug. ***
Comment 9 Daniel Vrátil 2013-06-09 14:36:42 UTC
*** Bug 309728 has been marked as a duplicate of this bug. ***
Comment 10 Daniel Vrátil 2013-06-09 14:37:24 UTC
*** Bug 298853 has been marked as a duplicate of this bug. ***
Comment 11 Daniel Vrátil 2013-06-09 14:38:39 UTC
*** Bug 302537 has been marked as a duplicate of this bug. ***
Comment 12 Daniel Vrátil 2013-06-09 14:47:22 UTC
*** Bug 320947 has been marked as a duplicate of this bug. ***
Comment 13 Daniel Vrátil 2013-06-24 08:15:09 UTC
*** Bug 321465 has been marked as a duplicate of this bug. ***
Comment 14 Dennis Schridde 2013-10-07 09:16:50 UTC
Created attachment 82699 [details]
New crash information added by DrKonqi

akonadi_imap_resource (4.11) on KDE Platform 4.11.2 using Qt 4.8.5

- What I was doing when the application crashed:

Akonadi/IMAP crashed on KDE logout. I was not actively using it at the time, but Kontact might still have been invisbly dangling around, due to another bug where it does not close properly.

-- Backtrace (Reduced):
#11 0x00007f361f8f30f9 in ~Task (this=0x7fff0c3e67f0, __in_chrg=<optimized out>) at /var/tmp/portage/kde-base/kdepimlibs-4.11.2-r1/work/kdepimlibs-4.11.2/akonadi/resourcescheduler_p.h:67
#12 Akonadi::ResourceBase::cancelTask (this=this@entry=0x1717a60) at /var/tmp/portage/kde-base/kdepimlibs-4.11.2-r1/work/kdepimlibs-4.11.2/akonadi/resourcebase.cpp:964
#13 0x00007f361f8f3252 in Akonadi::ResourceBase::cancelTask (this=0x1717a60, msg=...) at /var/tmp/portage/kde-base/kdepimlibs-4.11.2-r1/work/kdepimlibs-4.11.2/akonadi/resourcebase.cpp:992
#14 0x000000000041fd5d in ResourceState::cancelTask (this=0x1937990, errorString=...) at /var/tmp/portage/kde-base/kdepim-runtime-4.11.2/work/kdepim-runtime-4.11.2/resources/imap/resourcestate.cpp:405
#15 0x0000000000448dc1 in ResourceTask::cancelTask (this=this@entry=0x1906a40, errorString=...) at /var/tmp/portage/kde-base/kdepim-runtime-4.11.2/work/kdepim-runtime-4.11.2/resources/imap/resourcetask.cpp:309
Comment 15 casey.duquette 2013-10-29 20:04:59 UTC
Created attachment 83210 [details]
New crash information added by DrKonqi

akonadi_imap_resource (4.11) on KDE Platform 4.11.2 using Qt 4.8.2

- What I was doing when the application crashed: I logged out using the kde menu option. Upon clicking the confirmation, the crash happened.

-- Backtrace (Reduced):
#7  0x00007fb42813e0e2 in ~Task (this=0x7fff469720f0, __in_chrg=<optimized out>) at ../../akonadi/resourcescheduler_p.h:67
#8  Akonadi::ResourceBase::cancelTask (this=0x263f480) at ../../akonadi/resourcebase.cpp:964
#9  0x00007fb42813e259 in Akonadi::ResourceBase::cancelTask (this=0x263f480, msg=...) at ../../akonadi/resourcebase.cpp:992
#10 0x000000000042030b in ResourceState::cancelTask (this=0x264d820, errorString=...) at ../../../resources/imap/resourcestate.cpp:405
#11 0x000000000044ad11 in ResourceTask::cancelTask (this=0x26a8a60, errorString=...) at ../../../resources/imap/resourcetask.cpp:309
Comment 16 Kevin Ottens 2013-11-16 07:26:37 UTC
The IMAP resource has a new maintainer, reassigning to him.
Comment 17 Christian Mollekopf 2013-12-03 16:48:15 UTC
I suppose this crash was caused by calling ResourceBase method's after ResourceBase has already been destroyed (since the whole thing get's called from the QObject destructor). So I assume that this is probably fixed and a duplicate.
Let me know if it isn't.

The fix is in 4.11.3.

*** This bug has been marked as a duplicate of bug 325443 ***