Bug 298023 - Telepathy/KDE XMPP component sometimes stops sending messages after being away
Summary: Telepathy/KDE XMPP component sometimes stops sending messages after being away
Status: RESOLVED FIXED
Alias: None
Product: telepathy
Classification: Unclassified
Component: general (show other bugs)
Version: 0.3.0
Platform: unspecified Linux
: NOR normal
Target Milestone: Future
Assignee: Telepathy Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-13 08:14 UTC by Dennis Schridde
Modified: 2014-04-11 16:44 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Telepathy-gabble log (266.96 KB, application/octet-stream)
2012-04-18 11:52 UTC, Michele Gastaldo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Schridde 2012-04-13 08:14:00 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/536.5 (KHTML, like Gecko) Chrome/19.0.1084.15 Safari/536.5
Build Identifier: 

The Telepathy/KDE XMPP component sometimes stops sending messages after I was away and returned from that status. The messages simply do not reach the conversation partner. At first it seemed as if it'd happen with Facebook users only, but recently it also happened with a GMail user (IM: Pidgin).

Reproducible: Always




net-im/kde-telepathy-meta (0.3.1(4)@05/04/12)
net-im/telepathy-connection-managers (1@14/03/12)
net-im/telepathy-logger (0.2.12-r1@12/02/12)
net-im/telepathy-mission-control (5.10.1@13/11/11)
net-irc/telepathy-idle (0.1.11@03/12/11)
net-libs/telepathy-farsight (0.0.19@09/11/11)
net-libs/telepathy-glib (0.17.7@26/03/12)
net-libs/telepathy-qt (0.9.0@27/01/12)
net-voip/telepathy-gabble (0.14.1@06/12/11)
net-voip/telepathy-salut (0.6.0@06/12/11)
net-voip/telepathy-sofiasip (0.6.8@03/12/11)
Comment 1 Martin Klapetek 2012-04-13 09:37:09 UTC
We'll need some debug from you, if this is reproducible, please follow the steps here: http://martys.typepad.com/blog/2011/12/kde-telepathy-now-depends-on-telepathy-qt4-09-also-how-to-report-bugs.html

And post the log, thanks.
Comment 2 Dennis Schridde 2012-04-13 12:57:05 UTC
I will try that, but it will be hard, because it does not happen always and with every user. Is it possible to make the debugging permanent, i.e. to extend it over a long period of time? Would it be enough to insert these lines into ~/.kde4/env/...?

This information is also in the wiki, btw, with some extensions about debugging on the XMPP transport level: http://community.kde.org/Real-Time_Communication_and_Collaboration/FAQ#Providing_debug
Comment 3 Michele Gastaldo 2012-04-18 11:52:08 UTC
Created attachment 70476 [details]
Telepathy-gabble log

I have the same (or similar) problem: sometimes my messages are not correctly delivered. I noticed the problem chatting from XMPP to Gtalk user(s), haven't tried with other XMPP "pure" users. But the problem doesn't seem to happen when using Empathy instead.
I couldn't anyway notice any correlation to the Away status, it seems quite random instead.

I've logged my telepathy session as described in the documentation. Hopefully all personal details have been successfully removed!

I'm on Kubuntu 11.10 using kde-telepathy from PPA and KDE 4.8.2 from kubuntu-backports PPA, in any case
Comment 4 David Edmundson 2012-04-19 13:20:43 UTC
Git commit 9dbdd3858227f6d1004faa7370284775c306d640 by David Edmundson.
Committed on 19/04/2012 at 15:16.
Pushed by davidedmundson into branch 'master'.

Mark the channel as disconnected when the channel disconnects, instead of watching the connection status
Related: bug 293637

Reviewed-By: Dominik Cermak

M  +1    -1    lib/chat-widget.cpp

http://commits.kde.org/telepathy-text-ui/9dbdd3858227f6d1004faa7370284775c306d640
Comment 5 David Edmundson 2012-04-22 18:44:47 UTC
I assume you've edited that gabble log to hide people's IDs.
Who were you talking to? and who did you have the issues sending with?
Comment 6 Matija Šuklje 2012-04-23 14:56:37 UTC
As I've been suffering from this bug ever since I started using KTP (around 0.1), I've tried to figure out the pattern.

From what I've tested, this regularly happens when chatting with anyone on GTalk, regardless of the client they use. I couldn't reproduce it with any other XMPP server, so I assume it's again just Google being funny.

Also, as already mentioned in Comment 3, this seems to be a KTP issue and not a global Telepathy problem. I can't reproduce it in Empathy either.
Comment 7 Andreas Sturmlechner 2012-07-08 21:19:09 UTC
Here it seems that messages never reach my facebook contacts. However, I can see theirs.
Comment 8 Dennis Schridde 2012-07-08 22:00:23 UTC
(In reply to comment #7)
> Here it seems that messages never reach my facebook contacts. However, I can
> see theirs.
For all of them? There is another issue with Facebook (not Telepathy specific), where the messages you send to some contacts never reach them, butt you can still see theirs. This is always the case for some specific contacts, while it works for all others.
Comment 9 Andreas Sturmlechner 2012-07-08 22:05:01 UTC
So far I tried 4 or 5 fb contacts without any success.
Comment 10 Matija Šuklje 2012-07-29 14:29:15 UTC
This was tagged as a dependency for 0.4, but then removed.

Can we please add it to 0.5? It *is* a showstopper for anyone who has to talk to people that are on GTalk (regardless which client they are on).

If you still need to confirm the bug, from what I see, the reproduction is fairly simple: Try to chat with a contact @gmail.com and see when they stops seing your messages and/or see your status as constantly typing.
Comment 11 David Edmundson 2012-07-29 14:33:21 UTC
This may have been fixed with https://bugs.kde.org/show_bug.cgi?id=300655

please test with 0.4.1 or newer and report back.
Comment 12 Matija Šuklje 2012-08-03 23:13:19 UTC
(In reply to comment #11)
> This may have been fixed with https://bugs.kde.org/show_bug.cgi?id=300655
> 
> please test with 0.4.1 or newer and report back.

I’ve tested it with one GTalk contact and so far it seems it’s been fixed. I’ll report if I manage to reproduce it. If I don’t consider it unreproduced in 0.4.1. for my use case (conntacts that are on GTalk, various clients).