Bug 297710 - Kate crash on continue search
Summary: Kate crash on continue search
Status: RESOLVED DUPLICATE of bug 245663
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-08 10:04 UTC by Andreas Wenning Rangholm
Modified: 2012-04-10 20:56 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Wenning Rangholm 2012-04-08 10:04:54 UTC
Application: kate (3.8.2)
KDE Platform Version: 4.8.2 (4.8.2)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-22-generic x86_64
Distribution: Ubuntu precise (development branch)

-- Information about the crash:
- What I was doing when the application crashed:
A few files open in Kate, and searching through one of the files. Pressing the "next" in the search area a few times, and then it crashed after pressing it a 3rd or 4th time.

The crash does not seem to be reproducible.

-- Backtrace:
Application: Kate (kate), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fd17401f780 (LWP 9116))]

Thread 4 (Thread 0x7fd160350700 (LWP 9117)):
#0  0x00007fd17395ab03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fd170a82ff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fd170a83124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fd171845426 in QEventDispatcherGlib::processEvents (this=0x7fd1580008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fd171814c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fd171814ed7 in QEventLoop::exec (this=0x7fd16034fdd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fd171713fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fd1717f49ff in QInotifyFileSystemWatcherEngine::run (this=0x1010ec0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fd171716fcb in QThreadPrivate::start (arg=0x1010ec0) at thread/qthread_unix.cpp:298
#9  0x00007fd170f4fe9a in start_thread (arg=0x7fd160350700) at pthread_create.c:308
#10 0x00007fd1739664bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fd15fa9f700 (LWP 9118)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fd1613ea222 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007fd1613ea259 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007fd170f4fe9a in start_thread (arg=0x7fd15fa9f700) at pthread_create.c:308
#4  0x00007fd1739664bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fd15da38700 (LWP 9121)):
#0  0x00007fff837ff8de in ?? ()
#1  0x00007fd16cbad15d in __GI_clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:116
#2  0x00007fd17176dbb4 in do_gettime (frac=0x7fd15da37b98, sec=0x7fd15da37b90) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007fd171845b8d in QTimerInfoList::updateCurrentTime (this=0x7fd150002660) at kernel/qeventdispatcher_unix.cpp:343
#5  0x00007fd171845ec3 in QTimerInfoList::timerWait (this=0x7fd150002660, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#6  0x00007fd17184497c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7fd15da37c6c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007fd171844a25 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007fd170a8271e in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007fd170a82f1b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007fd170a83124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007fd171845426 in QEventDispatcherGlib::processEvents (this=0x7fd1500008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#12 0x00007fd171814c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#13 0x00007fd171814ed7 in QEventLoop::exec (this=0x7fd15da37dd0, flags=...) at kernel/qeventloop.cpp:204
#14 0x00007fd171713fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#15 0x00007fd1717f49ff in QInotifyFileSystemWatcherEngine::run (this=0x1534e90) at io/qfilesystemwatcher_inotify.cpp:248
#16 0x00007fd171716fcb in QThreadPrivate::start (arg=0x1534e90) at thread/qthread_unix.cpp:298
#17 0x00007fd170f4fe9a in start_thread (arg=0x7fd15da38700) at pthread_create.c:308
#18 0x00007fd1739664bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#19 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fd17401f780 (LWP 9116)):
[KCrash Handler]
#6  __memcpy_ssse3 () at ../sysdeps/x86_64/multiarch/memcpy-ssse3.S:1810
#7  0x00007fd161a94fe3 in QVector<KateHlContext*>::realloc (this=0xd53298, asize=757935148, aalloc=268435455) at /usr/include/x86_64-linux-gnu/bits/string3.h:52
#8  0x00007fd161a8be1e in resize (asize=757935148, this=0xd53298) at /usr/include/qt4/QtCore/qvector.h:343
#9  KateHighlighting::dropDynamicContexts (this=0xd53290) at ../../part/syntax/katehighlight.cpp:242
#10 0x00007fd161a812cf in KateHlManager::resetDynamicCtxs (this=0xc0e890) at ../../part/syntax/katesyntaxmanager.cpp:412
#11 0x00007fd161a408a3 in KateBuffer::doHighlight (this=0x1d7a1e0, startLine=22636, endLine=26976, invalidate=false) at ../../part/document/katebuffer.cpp:435
#12 0x00007fd161a20e0a in KateDocument::kateTextLine (this=0x1d7b260, i=26922) at ../../part/document/katedocument.cpp:4786
#13 0x00007fd161aabc2c in KateView::setCursorPositionInternal (this=0x1dfed40, position=..., tabwidth=1, calledExternally=false) at ../../part/view/kateview.cpp:1139
#14 0x00007fd161a752ce in KateSearchBar::selectRange (view=0x1dfed40, range=...) at ../../part/search/katesearchbar.cpp:355
#15 0x00007fd161a7534a in KateSearchBar::selectRange2 (this=0x2575a00, range=...) at ../../part/search/katesearchbar.cpp:366
#16 0x00007fd161a785ca in KateSearchBar::find (this=0x2575a00, searchDirection=KateSearchBar::SearchForward, replacement=0x0) at ../../part/search/katesearchbar.cpp:603
#17 0x00007fd161a78bfa in KateSearchBar::find (this=0x2575a00, searchDirection=KateSearchBar::SearchForward, replacement=0x0) at ../../part/search/katesearchbar.cpp:515
#18 0x00007fd161a78cfd in KateSearchBar::findNext (this=0x2575a00) at ../../part/search/katesearchbar.cpp:252
#19 0x00007fd17182a281 in QMetaObject::activate (sender=0x24c7310, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff83708c70) at kernel/qobject.cpp:3547
#20 0x00007fd172d6b132 in QAction::triggered (this=<optimized out>, _t1=false) at .moc/release-shared/moc_qaction.cpp:277
#21 0x00007fd172d6b31f in QAction::activate (this=0x24c7310, event=<optimized out>) at kernel/qaction.cpp:1257
#22 0x00007fd172d6b48f in QAction::event (this=<optimized out>, e=<optimized out>) at kernel/qaction.cpp:1183
#23 0x00007fd171f380ca in KAction::event (this=<optimized out>, event=0x7fff83709290) at ../../kdeui/actions/kaction.cpp:131
#24 0x00007fd172d71894 in notify_helper (e=0x7fff83709290, receiver=0x24c7310, this=0xa133f0) at kernel/qapplication.cpp:4559
#25 QApplicationPrivate::notify_helper (this=0xa133f0, receiver=0x24c7310, e=0x7fff83709290) at kernel/qapplication.cpp:4531
#26 0x00007fd172d76713 in QApplication::notify (this=0x7fff8370a780, receiver=0x24c7310, e=0x7fff83709290) at kernel/qapplication.cpp:4420
#27 0x00007fd172020b46 in KApplication::notify (this=0x7fff8370a780, receiver=0x24c7310, event=0x7fff83709290) at ../../kdeui/kernel/kapplication.cpp:311
#28 0x00007fd171815e9c in QCoreApplication::notifyInternal (this=0x7fff8370a780, receiver=0x24c7310, event=0x7fff83709290) at kernel/qcoreapplication.cpp:876
#29 0x00007fd172da38b9 in sendEvent (event=0x7fff83709290, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#30 QShortcutMap::dispatchEvent (this=<optimized out>, e=0x7fff83709830) at kernel/qshortcutmap.cpp:879
#31 0x00007fd172da4d8a in QShortcutMap::tryShortcutEvent (this=0xa13510, o=<optimized out>, e=0x7fff83709830) at kernel/qshortcutmap.cpp:364
#32 0x00007fd172d77f92 in QApplication::notify (this=0x7fff8370a780, receiver=0x1d868e0, e=0x7fff83709830) at kernel/qapplication.cpp:3983
#33 0x00007fd172020b46 in KApplication::notify (this=0x7fff8370a780, receiver=0x1d868e0, event=0x7fff83709830) at ../../kdeui/kernel/kapplication.cpp:311
#34 0x00007fd171815e9c in QCoreApplication::notifyInternal (this=0x7fff8370a780, receiver=0x1d868e0, event=0x7fff83709830) at kernel/qcoreapplication.cpp:876
#35 0x00007fd172e15c59 in QKeyMapper::sendKeyEvent (keyWidget=0x1d868e0, grab=<optimized out>, type=QEvent::KeyPress, code=16777266, modifiers=..., text=..., autorepeat=false, count=1, nativeScanCode=69, nativeVirtualKey=65472, nativeModifiers=0) at kernel/qkeymapper_x11.cpp:1866
#36 0x00007fd172e160cb in QKeyMapperPrivate::translateKeyEvent (this=0xa60f20, keyWidget=0x1d868e0, event=0x7fff8370a320, grab=false) at kernel/qkeymapper_x11.cpp:1836
#37 0x00007fd172df0637 in QApplication::x11ProcessEvent (this=0x7fff8370a780, event=0x7fff8370a320) at kernel/qapplication_x11.cpp:3625
#38 0x00007fd172e1a0e2 in x11EventSourceDispatch (s=0xa24e00, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#39 0x00007fd170a82c9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#40 0x00007fd170a83060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#41 0x00007fd170a83124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#42 0x00007fd1718453bf in QEventDispatcherGlib::processEvents (this=0x9e4b30, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#43 0x00007fd172e19d6e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#44 0x00007fd171814c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#45 0x00007fd171814ed7 in QEventLoop::exec (this=0x7fff8370a6c0, flags=...) at kernel/qeventloop.cpp:204
#46 0x00007fd171819f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#47 0x00007fd173c370d5 in kdemain (argc=<optimized out>, argv=<optimized out>) at ../../../kate/app/katemain.cpp:377
#48 0x00007fd17389576d in __libc_start_main (main=0x400630 <main(int, char**)>, argc=3, ubp_av=0x7fff8370bcb8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff8370bca8) at libc-start.c:226
#49 0x0000000000400661 in _start ()

Reported using DrKonqi
Comment 1 Dominik Haumann 2012-04-10 20:56:50 UTC

*** This bug has been marked as a duplicate of bug 245663 ***