Bug 297588 - Oxygen glitches while using raster and 16 bpp depth
Summary: Oxygen glitches while using raster and 16 bpp depth
Status: RESOLVED UPSTREAM
Alias: None
Product: Oxygen
Classification: Unclassified
Component: style (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Hugo Pereira Da Costa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-06 12:59 UTC by Jaroslav Reznik
Modified: 2012-04-11 07:25 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot (31.10 KB, image/png)
2012-04-06 12:59 UTC, Jaroslav Reznik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Reznik 2012-04-06 12:59:17 UTC
Created attachment 70189 [details]
Screenshot

For Fedora 17 Beta RC3 the X maintainers decided to switch Cirrus driver to 16 bpp depth by default for virt. evironments (as the Cirrus/VNC combo in KVM) due to the huge breakage of Gnome Shell. The reason is that 24 bpp (32 bpp is not supported on Cirrus) code path is not very well writen/tested/used.

It leads to several glitches in Oygen style, see screenshot. 

It works with native graphics system (and 16 bpp).

See https://bugzilla.redhat.com/show_bug.cgi?id=810161 and https://bugzilla.redhat.com/show_bug.cgi?id=809052

Fedora 17 Beta RC3 with KDE Plasma Workspaces 4.8.2, xorg-x11-drv-cirrus-1.3.2-9
Comment 1 Christoph Feck 2012-04-06 19:36:34 UTC
Looks like a Qt issue, no?
Comment 2 Jaroslav Reznik 2012-04-09 11:52:11 UTC
(In reply to comment #1)
> Looks like a Qt issue, no?

I've already filled Qt bug for another - related - 16 bpp raster breakage - https://bugreports.qt-project.org/browse/QTBUG-25198

While reporting this bug, I was hoping for Oxygen style workaround :)
Comment 3 Hugo Pereira Da Costa 2012-04-11 07:25:40 UTC
well, since there is no way for me (humbly the main oxygen developper) to reproduce the issue, there is no chance I'll come with a workaround (and also, I'm not even sure a workaround is desirable: hiding upstream bugs is in general not a good idea). 

So this should really be fixed upstream, sorry.