Bug 297242 - Crash of systemsettings when trying to see Gamma
Summary: Crash of systemsettings when trying to see Gamma
Status: RESOLVED DUPLICATE of bug 292335
Alias: None
Product: systemsettings
Classification: Unclassified
Component: general (show other bugs)
Version: 1.0
Platform: Debian unstable Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: System Settings Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-01 13:38 UTC by bou.gui
Modified: 2012-04-01 13:41 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bou.gui 2012-04-01 13:38:39 UTC
Application: systemsettings (1.0)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.3-0.slh.6-aptosid-amd64 x86_64
Distribution (Platform): Debian unstable

-- Information about the crash:
- What I was doing when the application crashed:
Just try to open "gamma" configuration in systemsettings then systemsettings crashes

The crash can be reproduced some of the time.

-- Backtrace:
Application: Configuration du système (systemsettings), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fd926ba8760 (LWP 4601))]

Thread 3 (Thread 0x7fd8fcc5c700 (LWP 4626)):
#0  0x00007fd924078cc3 in *__GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fd92194aaf6 in g_main_context_poll (n_fds=3, fds=0xd6ad60, timeout=-1, context=0xd6add0, priority=<optimized out>) at /tmp/buildd/glib2.0-2.32.0/./glib/gmain.c:3417
#2  g_main_context_iterate (dispatch=1, block=<optimized out>, context=0xd6add0, self=<optimized out>) at /tmp/buildd/glib2.0-2.32.0/./glib/gmain.c:3118
#3  g_main_context_iterate (context=0xd6add0, block=<optimized out>, dispatch=1, self=<optimized out>) at /tmp/buildd/glib2.0-2.32.0/./glib/gmain.c:3060
#4  0x00007fd92194af5a in g_main_loop_run (loop=0xd6ad80) at /tmp/buildd/glib2.0-2.32.0/./glib/gmain.c:3317
#5  0x00007fd8fcf49916 in gdbus_shared_thread_func (user_data=0xd6ada0) at /tmp/buildd/glib2.0-2.32.0/./gio/gdbusprivate.c:277
#6  0x00007fd92196c405 in g_thread_proxy (data=0xd67b20) at /tmp/buildd/glib2.0-2.32.0/./glib/gthread.c:801
#7  0x00007fd921e17b50 in start_thread (arg=<optimized out>) at pthread_create.c:304
#8  0x00007fd92408390d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fd8f2130700 (LWP 4718)):
#0  0x00007fff84bff8de in ?? ()
#1  0x00007fd91fb19e86 in *__GI_clock_gettime (clock_id=1, tp=0x7fd8f212fba0) at ../sysdeps/unix/clock_gettime.c:116
#2  0x00007fd924703fb4 in do_gettime (frac=0x7fd8f212fbb8, sec=0x7fd8f212fbb0) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007fd9247c5c4d in QTimerInfoList::updateCurrentTime (this=0x7fd910003360) at kernel/qeventdispatcher_unix.cpp:339
#5  0x00007fd9247c5f83 in QTimerInfoList::timerWait (this=0x7fd910003360, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#6  0x00007fd9247c49fc in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7fd8f212fc8c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007fd9247c4aa5 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007fd92194a21e in g_main_context_prepare (context=0x7fd910003da0, priority=0x7fd8f212fcd8) at /tmp/buildd/glib2.0-2.32.0/./glib/gmain.c:2813
#9  0x00007fd92194aa1b in g_main_context_iterate (dispatch=1, block=1, context=0x7fd910003da0, self=<optimized out>) at /tmp/buildd/glib2.0-2.32.0/./glib/gmain.c:3103
#10 g_main_context_iterate (context=0x7fd910003da0, block=1, dispatch=1, self=<optimized out>) at /tmp/buildd/glib2.0-2.32.0/./glib/gmain.c:3060
#11 0x00007fd92194ac24 in g_main_context_iteration (context=0x7fd910003da0, may_block=1) at /tmp/buildd/glib2.0-2.32.0/./glib/gmain.c:3184
#12 0x00007fd9247c54a6 in QEventDispatcherGlib::processEvents (this=0x186c4c0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#13 0x00007fd924799972 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#14 0x00007fd924799b6f in QEventLoop::exec (this=0x7fd8f212fdf0, flags=...) at kernel/qeventloop.cpp:201
#15 0x00007fd9246b14af in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#16 0x00007fd92477c9cf in QInotifyFileSystemWatcherEngine::run (this=0x193ea60) at io/qfilesystemwatcher_inotify.cpp:248
#17 0x00007fd9246b3ec5 in QThreadPrivate::start (arg=0x193ea60) at thread/qthread_unix.cpp:331
#18 0x00007fd921e17b50 in start_thread (arg=<optimized out>) at pthread_create.c:304
#19 0x00007fd92408390d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#20 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fd926ba8760 (LWP 4601)):
[KCrash Handler]
#6  0x00007fd9257b5a64 in QAbstractButton::isChecked (this=0x1ca41d0) at widgets/qabstractbutton.cpp:772
#7  0x00007fd8eaeb597d in ?? () from /usr/lib/kde4/kcm_kgamma.so
#8  0x00007fd9261ca511 in KCModule::qt_metacall (this=0x188e1d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xec0810) at ./kcmodule.moc:89
#9  0x00007fd8eaeb87b0 in ?? () from /usr/lib/kde4/kcm_kgamma.so
#10 0x00007fd9247b106a in QObject::event (this=0x188e1d0, e=<optimized out>) at kernel/qobject.cpp:1217
#11 0x00007fd925451f8b in QWidget::event (this=0x188e1d0, event=0x18c3f30) at kernel/qwidget.cpp:8754
#12 0x00007fd925401df4 in notify_helper (e=0x18c3f30, receiver=0x188e1d0, this=0x6f0430) at kernel/qapplication.cpp:4486
#13 QApplicationPrivate::notify_helper (this=0x6f0430, receiver=0x188e1d0, e=0x18c3f30) at kernel/qapplication.cpp:4458
#14 0x00007fd925406c81 in QApplication::notify (this=0x7fff84b92aa0, receiver=0x188e1d0, e=0x18c3f30) at kernel/qapplication.cpp:4365
#15 0x00007fd926133b26 in KApplication::notify (this=0x7fff84b92aa0, receiver=0x188e1d0, event=0x18c3f30) at ../../kdeui/kernel/kapplication.cpp:311
#16 0x00007fd92479a76c in QCoreApplication::notifyInternal (this=0x7fff84b92aa0, receiver=0x188e1d0, event=0x18c3f30) at kernel/qcoreapplication.cpp:787
#17 0x00007fd92479db48 in sendEvent (event=0x18c3f30, receiver=0x188e1d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#18 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x6c0320) at kernel/qcoreapplication.cpp:1428
#19 0x00007fd9247c4fe3 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#20 postEventSourceDispatch (s=0x6efc90) at kernel/qeventdispatcher_glib.cpp:277
#21 0x00007fd92194a79a in g_main_dispatch (context=0x6f1800) at /tmp/buildd/glib2.0-2.32.0/./glib/gmain.c:2515
#22 g_main_context_dispatch (context=0x6f1800) at /tmp/buildd/glib2.0-2.32.0/./glib/gmain.c:3052
#23 0x00007fd92194ab60 in g_main_context_iterate (dispatch=1, block=<optimized out>, context=0x6f1800, self=<optimized out>) at /tmp/buildd/glib2.0-2.32.0/./glib/gmain.c:3123
#24 g_main_context_iterate (context=0x6f1800, block=<optimized out>, dispatch=1, self=<optimized out>) at /tmp/buildd/glib2.0-2.32.0/./glib/gmain.c:3060
#25 0x00007fd92194ac24 in g_main_context_iteration (context=0x6f1800, may_block=1) at /tmp/buildd/glib2.0-2.32.0/./glib/gmain.c:3184
#26 0x00007fd9247c543f in QEventDispatcherGlib::processEvents (this=0x6c1a10, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#27 0x00007fd9254a62ee in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#28 0x00007fd924799972 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#29 0x00007fd924799b6f in QEventLoop::exec (this=0x7fff84b92a30, flags=...) at kernel/qeventloop.cpp:201
#30 0x00007fd92479dd37 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#31 0x000000000040b225 in ?? ()
#32 0x00007fd923fc9ead in __libc_start_main (main=<optimized out>, argc=<optimized out>, ubp_av=<optimized out>, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff84b92d58) at libc-start.c:228
#33 0x000000000040b279 in _start ()

Possible duplicates by query: bug 294227, bug 292335.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-04-01 13:41:17 UTC

*** This bug has been marked as a duplicate of bug 292335 ***