Bug 297192 - Amarok does not play audio CD in KDE unless opened from Nautilus using gvfsd-cdda
Summary: Amarok does not play audio CD in KDE unless opened from Nautilus using gvfsd-...
Status: RESOLVED DUPLICATE of bug 285885
Alias: None
Product: amarok
Classification: Applications
Component: Collections/CD (show other bugs)
Version: 2.5.0
Platform: Fedora RPMs Linux
: NOR major (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-31 16:15 UTC by SP
Modified: 2012-05-06 10:56 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description SP 2012-03-31 16:15:17 UTC
I have read many reports about this problem - or similar - but no resolution. I have Fedora 16 with KDE 4.8.1 on three PCs and two laptops. The problem exists on all of them. When an audio CD is inserted it shows in the device notifier. In both KsCD or Amarok the tracks are listed but they do not play. KsCD appears to play the tracks but there is no sound. Banshee will play the CD. If Nautilus file manager is opened in KDE it gives the option to open Amarok which will then play the CD without a hitch.  (Using gvfsd-cdda) (Nautilus presents no option to use KsCD.) If Dolphin is opened it will show the audio CD and its tracks - but if any are selected to play with an application (KsCD or Amarok) it takes about a minute or more to rip the track to a cache before making it available to Amarok. (It will not play in KsCD). Any advice or solution to this problem would be appreciated. From searches it would seem that this problem has plagued KDE for years.

Reproducible: Always 
Steps to Reproduce: 1.Insert audio cd 2. Open device manager 3. Choose either Amarok or KCSD to play.
Actual Results: Audio CD does not play.
Expected Results: Audio CD should play.
Comment 1 Myriam Schweingruber 2012-04-01 22:27:51 UTC
This is already solved in the development branch.

Since you use Fedora I assume you use the phonon-backend-gstreamer, but for completenes sake there was a bug with the phonon-backend-vlc which prevented CD playing until version 0.4.0, fixed since 0.4.1: https://bugs.kde.org/show_bug.cgi?id=276034

As for KsCD please report this separately for that application, it is not related to Amarok at all.

*** This bug has been marked as a duplicate of bug 285885 ***
Comment 2 SP 2012-04-02 02:27:09 UTC
Glad to hear that it is solved and look forward to the package update.  Yes, I use the phonon-backend-gstreamer.  Separatel, VLC has no problems playing CD audio  though it is not the ideal choice.  As Amarok plays CD audio when the CD is opened with Nautilus but not from the KDE menu or panel I have suspected that the problem lies with the kio audio slave.  Is that correct?
Comment 3 Myriam Schweingruber 2012-04-02 11:20:01 UTC
Yes and no. There was a problem with the KIO slave and also with Amarok itself. BTW if I talk about the vlc backend I mean the phonon-backend-vlc, not vlc itself.
Comment 4 SP 2012-04-02 18:03:47 UTC
Yes, I understood that - and I was pointing out, perhaps irrelevantly, that the VLC program was able to play  audio CDS within the KDE environment.
How soon will the fix move from development to package release?
Comment 5 Myriam Schweingruber 2012-04-03 11:12:10 UTC
That will still take some time, we currently don't have a specific release date for 2.6
Comment 6 Schoelje 2012-05-03 15:48:53 UTC
I had the same problem with Amarok 2.4.3 and phonon-backend-vlc 4.1.1
After changing the default DVD path in VLC (which was /dev/dvd and changed it to /dev/sr0), not only VLC could now play audio-CD's but Amarok as well.
Comment 7 SP 2012-05-03 18:58:26 UTC
@Schoelje  I tried the VLC phonon backend to no avail.  VLC is already set to the correct device and can play audio cds without a problem.  Amarok shows the audio CD - but the tracks are greyed out and will not play if added to the playlist.  The same applies to KSCD.  K3b will identify and rip a CD without a problem.  I suspect the root of the problem may be that both Amarok and KSCD do not have the correct permissions set to fully access the device.  Perhaps a matter of adding something to the right group?
Comment 8 Schoelje 2012-05-03 20:32:50 UTC
@SP For me, KsCD has always been working perfectly, so your problem is of another nature. I'm sorry I can't help you with that.
Comment 9 SP 2012-05-03 20:49:46 UTC
@Schoelje Which distro are you using?  I have the problem duplicated on all my machines with Fedora 16 installed.  Other users have the same or similar problem - it seems quite widespread and has persisted through versions.
Comment 10 Schoelje 2012-05-04 13:22:31 UTC
@SP I'm using Linux Mint 12 KDE 64bits.
Comment 11 Myriam Schweingruber 2012-05-06 10:56:41 UTC
Please do not comment on bugs marked as duplicate, please see bug 285885