Bug 296965 - Device notifier widget can't eject cd or dvd in kde-4.8.1
Summary: Device notifier widget can't eject cd or dvd in kde-4.8.1
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-devicenotifier (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-28 12:45 UTC by DrHouse
Modified: 2012-04-06 15:52 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.8.2


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description DrHouse 2012-03-28 12:45:03 UTC
Device notifier widget can't eject cd or dvd in kde-4.8.1. It's not clickable. I have stable Gentoo system with testing versions of kde and gcc (gcc is 4.7.0)

Reproducible: Always

Steps to Reproduce:
1.Put any CD into CD\DVD drive
2.Try click on eject button in Device notifier plasma applet. Button is not clickable.
Comment 1 Bojan Vitnik 2012-03-31 19:52:56 UTC
I can confirm this. Using Kubuntu 11.10 and KDE 4.8.1 from Kubuntu Backports PPA (ppa:kubuntu-ppa/backports).
Comment 2 DrHouse 2012-04-01 23:49:36 UTC
Thanks for fixing this bug.
Comment 3 Johannes Huber 2012-04-02 11:38:10 UTC
(In reply to comment #2)
> Thanks for fixing this bug.

Its not fixed...
Comment 4 Lamarque V. Souza 2012-04-02 11:49:36 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > Thanks for fixing this bug.
> 
> Its not fixed...

4.8.2 has not been released yet. Have you installed branch KDE/4.8 recently?
Comment 5 DrHouse 2012-04-02 14:19:32 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > (In reply to comment #2)
> > > Thanks for fixing this bug.
> > 
> > Its not fixed...
> 
> 4.8.2 has not been released yet. Have you installed branch KDE/4.8 recently?

No, I have still 4.8.1. I just hope that bug will be fixed in 4.8.2
Comment 6 Lukáš Tinkl 2012-04-04 20:44:19 UTC
*** Bug 294344 has been marked as a duplicate of this bug. ***
Comment 7 Lukáš Tinkl 2012-04-06 10:20:49 UTC
Still doesn't work reliably, here it just unmounts the CD and fails to eject it, saying it's still being used. Only if I remount it, it's subsequently possible to also eject it.
Comment 8 Lamarque V. Souza 2012-04-06 15:32:29 UTC
(In reply to comment #7)
> Still doesn't work reliably, here it just unmounts the CD and fails to eject
> it, saying it's still being used. Only if I remount it, it's subsequently
> possible to also eject it.

The problem you described is bug https://bugs.kde.org/show_bug.cgi?id=274982

this particular problem with eject never working with 4.8.x (and 4.8.x only) is fixed.
Comment 9 Lukáš Tinkl 2012-04-06 15:52:34 UTC
OK, I will investigate the other bug then