Bug 296903 - konsole freezes when remote machine is shutdown via ssh
Summary: konsole freezes when remote machine is shutdown via ssh
Status: RESOLVED DUPLICATE of bug 251351
Alias: None
Product: konsole
Classification: Applications
Component: general (show other bugs)
Version: 2.8.1
Platform: Gentoo Packages Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-27 18:01 UTC by Eggert Ehmke
Modified: 2012-03-27 20:30 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eggert Ehmke 2012-03-27 18:01:01 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:11.0) Gecko/20100101 Firefox/11.0
Build Identifier: 

When I run a SSH session in konsole and shut down the remote Linux box, the konsole session freezes

Reproducible: Always

Steps to Reproduce:
1. Open SSH session to other Linux system
2. Enter command "sudo halt"
3. The other system will issue the message "The system is going down for system halt NOW!
"
4. The local konsole session will not accept any commands anymore. 
5. Ctrl-C does help sometimes. In this case, the message is issued: "Write failed: Broken pipe"
Actual Results:  
See above

Expected Results:  
The session should be terminated to allow local commands again.
Comment 1 Jekyll Wu 2012-03-27 20:30:51 UTC
Thanks for reporting.

This is a knwon issue. The problem is Konsole currently does not put some (potentially) blocking operations into separate thread.

*** This bug has been marked as a duplicate of bug 251351 ***