Bug 296720 - KNode crashed afer / during marking a folder as all read
Summary: KNode crashed afer / during marking a folder as all read
Status: RESOLVED DUPLICATE of bug 286803
Alias: None
Product: knode
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-25 04:09 UTC by John Phillips
Modified: 2012-07-03 21:09 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Phillips 2012-03-25 04:09:06 UTC
Application: knode (4.7.3)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-17-generic-pae i686
Distribution: Ubuntu 11.10

-- Information about the crash:
Marking a folder with >1,000 unread messages as "all read".

-- Backtrace:
Application: KNode (knode), signal: Segmentation fault
[KCrash Handler]
#7  0xb72d3dfd in size (this=0x2c) at /usr/include/qt4/QtCore/qlist.h:94
#8  size (this=0x2c) at /usr/include/qt4/QtCore/qlist.h:124
#9  size (this=0x24) at ../../knode/knarticlecollection.h:38
#10 length (this=0x0) at ../../knode/knarticlecollection.h:95
#11 KNArticleFilter::doFilter (this=0x871f2d8, f=...) at ../../knode/knarticlefilter.cpp:297
#12 0xb728c9b0 in KNArticleManager::showHdrs (this=0x871e238, clear=false) at ../../knode/knarticlemanager.cpp:306
#13 0xb725c3d8 in KNGroupManager::processJob (this=0x871e378, j=0xb863f98) at ../../knode/kngroupmanager.cpp:654
#14 0xb7247c55 in KNJobConsumer::jobDone (this=0x871e380, j=0xb863f98) at ../../knode/knjobdata.cpp:54
#15 0xb7247caa in KNJobData::notifyConsumer (this=0xb863f98) at ../../knode/knjobdata.cpp:100
#16 0xb72452a3 in KNode::Scheduler::slotJobFinished (this=0x84cae50, job=0xb863f98) at ../../knode/scheduler.cpp:202
#17 0xb7246315 in KNode::Scheduler::qt_metacall (this=0x84cae50, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe19188) at ./scheduler.moc:81
#18 0xb5eddb7d in metacall (argv=0xbfe19188, idx=5, cl=QMetaObject::InvokeMetaMethod, object=0x84cae50) at kernel/qmetaobject.cpp:237
#19 QMetaObject::metacall (object=0x84cae50, cl=QMetaObject::InvokeMetaMethod, idx=5, argv=0xbfe19188) at kernel/qmetaobject.cpp:232
#20 0xb5eeca6a in QMetaObject::activate (sender=0xb863f98, m=0xb739f89c, local_signal_index=0, argv=0xbfe19188) at kernel/qobject.cpp:3278
#21 0xb72478a5 in KNJobData::finished (this=0xb863f98, _t1=0xb863f98) at ./knjobdata.moc:95
#22 0xb72478c3 in KNJobData::slotEmitFinished (this=0xb863f98) at ../../knode/knjobdata.cpp:182
#23 0xb7247943 in KNJobData::qt_metacall (this=0xb863f98, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x8e677c8) at ./knjobdata.moc:83
#24 0xb724be12 in KNode::ArticleListJob::qt_metacall (this=0xb863f98, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0x8e677c8) at ./nntpjobs.moc:133
#25 0xb5eddb7d in metacall (argv=0x8e677c8, idx=7, cl=QMetaObject::InvokeMetaMethod, object=0xb863f98) at kernel/qmetaobject.cpp:237
#26 QMetaObject::metacall (object=0xb863f98, cl=QMetaObject::InvokeMetaMethod, idx=7, argv=0x8e677c8) at kernel/qmetaobject.cpp:232
#27 0xb5ee8685 in QMetaCallEvent::placeMetaCall (this=0x8709870, object=0xb863f98) at kernel/qobject.cpp:535
#28 0xb5eefb52 in QObject::event (this=0xb863f98, e=0x8709870) at kernel/qobject.cpp:1217
#29 0xb616ad84 in notify_helper (e=0x8709870, receiver=0xb863f98, this=0x849c858) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x849c858, receiver=0xb863f98, e=0x8709870) at kernel/qapplication.cpp:4458
#31 0xb6170133 in QApplication::notify (this=0x8709870, receiver=0xb863f98, e=0x8709870) at kernel/qapplication.cpp:3886
#32 0xb6cc0971 in KApplication::notify (this=0xbfe198f4, receiver=0xb863f98, event=0x8709870) at ../../kdeui/kernel/kapplication.cpp:311
#33 0xb5ed719e in QCoreApplication::notifyInternal (this=0xbfe198f4, receiver=0xb863f98, event=0x8709870) at kernel/qcoreapplication.cpp:787
#34 0xb5edaf93 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8473540) at kernel/qcoreapplication.cpp:1428
#36 0xb5edb0ec in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1321
#37 0xb5f056a4 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#38 postEventSourceDispatch (s=0x849fdd8) at kernel/qeventdispatcher_glib.cpp:277
#39 0xb409225f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0xb4092990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#41 0xb4092c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#42 0xb5f05ada in QEventDispatcherGlib::processEvents (this=0x8474250, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#43 0xb6222e7a in QGuiEventDispatcherGlib::processEvents (this=0x8474250, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#44 0xb5ed61dd in QEventLoop::processEvents (this=0xbfe19884, flags=...) at kernel/qeventloop.cpp:149
#45 0xb5ed6421 in QEventLoop::exec (this=0xbfe19884, flags=...) at kernel/qeventloop.cpp:201
#46 0xb5edb19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#47 0xb6168924 in QApplication::exec () at kernel/qapplication.cpp:3760
#48 0x0804cc8d in main (argc=) at ../../knode/main.cpp:46

Possible duplicates by query: bug 286803.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-07-03 21:09:25 UTC

*** This bug has been marked as a duplicate of bug 286803 ***