Bug 296705 - Kontact crash after opening a mail
Summary: Kontact crash after opening a mail
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-24 20:07 UTC by Alexander Borghgraef
Modified: 2012-03-26 22:20 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Borghgraef 2012-03-24 20:07:39 UTC
Application: kontact (4.8.0)
KDE Platform Version: 4.8.1 (4.8.1)
Qt Version: 4.8.0
Operating System: Linux 3.0.0-16-generic-pae i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
Just opened a recent mail folder, clicked on a new mail, and then kontact crashed.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0xb26b6730 (LWP 4047))]

Thread 8 (Thread 0xb03cdb70 (LWP 4062)):
#0  0xb77d6424 in __kernel_vsyscall ()
#1  0xb3c90a5c in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:169
#2  0xb612609c in __pthread_cond_wait (cond=0xb5fed430, mutex=0xb5fed418) at forward.c:139
#3  0xb58cc883 in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#4  0xb58cc99f in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#5  0xb3c8cd31 in start_thread (arg=0xb03cdb70) at pthread_create.c:304
#6  0xb611846e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 7 (Thread 0xafaa4b70 (LWP 4063)):
#0  0xb77d6424 in __kernel_vsyscall ()
#1  0xb61097ae in __GI___poll (fds=0x8b0a7d8, nfds=1, timeout=3233) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0xb3bc434b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb3bb5896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb3bb5c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb645e1c7 in QEventDispatcherGlib::processEvents (this=0x8b022e8, flags=...) at kernel/qeventdispatcher_glib.cpp:430
#6  0xb6429d1d in ?? () at kernel/qeventloop.cpp:126 from /usr/lib/i386-linux-gnu/libQtCore.so.4
#7  0xafaa42b0 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 6 (Thread 0xad714b70 (LWP 4395)):
#0  0xb77d6424 in __kernel_vsyscall ()
#1  0xb61097ae in __GI___poll (fds=0xa7101108, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0xb3bc434b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb3bb5896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb3bb5c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb645e1c7 in QEventDispatcherGlib::processEvents (this=0x9b3f8b0, flags=...) at kernel/qeventdispatcher_glib.cpp:430
#6  0xb6429d1d in ?? () at kernel/qeventloop.cpp:126 from /usr/lib/i386-linux-gnu/libQtCore.so.4
#7  0xad714280 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 5 (Thread 0xa70ffb70 (LWP 15442)):
#0  0xb77d6424 in __kernel_vsyscall ()
#1  0xb3c90e04 in pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_timedwait.S:236
#2  0xb61260f4 in __pthread_cond_timedwait (cond=0x901c480, mutex=0x901c468, abstime=0xa70ff288) at forward.c:152
#3  0xb631736f in wait (time=30000, this=0x901c468) at thread/qwaitcondition_unix.cpp:84
#4  QWaitCondition::wait (this=0x901c410, mutex=0x901c40c, time=30000) at thread/qwaitcondition_unix.cpp:158
#5  0xb6309504 in QThreadPoolThread::run (this=0x9028c08) at concurrent/qthreadpool.cpp:141
#6  0xb6316e70 in QThreadPrivate::start (arg=0x9028c08) at thread/qthread_unix.cpp:298
#7  0xb3c8cd31 in start_thread (arg=0xa70ffb70) at pthread_create.c:304
#8  0xb611846e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 4 (Thread 0xa68feb70 (LWP 15444)):
#0  0xb77d6424 in __kernel_vsyscall ()
#1  0xb3c90e04 in pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_timedwait.S:236
#2  0xb61260f4 in __pthread_cond_timedwait (cond=0xa7103df0, mutex=0xa7103dd8, abstime=0xa68fe288) at forward.c:152
#3  0xb631736f in wait (time=30000, this=0xa7103dd8) at thread/qwaitcondition_unix.cpp:84
#4  QWaitCondition::wait (this=0xa7103da8, mutex=0xa7103da4, time=30000) at thread/qwaitcondition_unix.cpp:158
#5  0xb6309504 in QThreadPoolThread::run (this=0xa71046d0) at concurrent/qthreadpool.cpp:141
#6  0xb6316e70 in QThreadPrivate::start (arg=0xa71046d0) at thread/qthread_unix.cpp:298
#7  0xb3c8cd31 in start_thread (arg=0xa68feb70) at pthread_create.c:304
#8  0xb611846e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 3 (Thread 0xa5cb7b70 (LWP 15447)):
#0  0xb77d6424 in __kernel_vsyscall ()
#1  0xb3c90e04 in pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_timedwait.S:236
#2  0xb61260f4 in __pthread_cond_timedwait (cond=0x92b6bc8, mutex=0x92b6bb0, abstime=0xa5cb7288) at forward.c:152
#3  0xb631736f in wait (time=30000, this=0x92b6bb0) at thread/qwaitcondition_unix.cpp:84
#4  QWaitCondition::wait (this=0x92b6b80, mutex=0x92b6b7c, time=30000) at thread/qwaitcondition_unix.cpp:158
#5  0xb6309504 in QThreadPoolThread::run (this=0xa5e12ae8) at concurrent/qthreadpool.cpp:141
#6  0xb6316e70 in QThreadPrivate::start (arg=0xa5e12ae8) at thread/qthread_unix.cpp:298
#7  0xb3c8cd31 in start_thread (arg=0xa5cb7b70) at pthread_create.c:304
#8  0xb611846e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 2 (Thread 0xa54b6b70 (LWP 15448)):
#0  0xb77d6424 in __kernel_vsyscall ()
#1  0xb3c90e04 in pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_timedwait.S:236
#2  0xb61260f4 in __pthread_cond_timedwait (cond=0x92b6bc8, mutex=0x92b6bb0, abstime=0xa54b6288) at forward.c:152
#3  0xb631736f in wait (time=30000, this=0x92b6bb0) at thread/qwaitcondition_unix.cpp:84
#4  QWaitCondition::wait (this=0x92b6b80, mutex=0x92b6b7c, time=30000) at thread/qwaitcondition_unix.cpp:158
#5  0xb6309504 in QThreadPoolThread::run (this=0xa5e151e8) at concurrent/qthreadpool.cpp:141
#6  0xb6316e70 in QThreadPrivate::start (arg=0xa5e151e8) at thread/qthread_unix.cpp:298
#7  0xb3c8cd31 in start_thread (arg=0xa54b6b70) at pthread_create.c:304
#8  0xb611846e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb26b6730 (LWP 4047)):
[KCrash Handler]
#7  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0xb0b42f0, hm=) at access/qnetworkaccesshttpbackend.cpp:827
#8  0xb3e8fd0d in QNetworkAccessHttpBackend::qt_static_metacall (_o=0xb0b42f0, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xa3c07c0) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#9  0xb643d411 in guardHashLock () at kernel/qobject.cpp:387
#10 0xb69c0b08 in QLayout::activate (this=0x8) at kernel/qlayout.cpp:1266
#11 0x0ac69430 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2012-03-26 22:20:09 UTC

*** This bug has been marked as a duplicate of bug 286307 ***