Bug 296399 - Panel - Digital Clock Overlaping the System Tray
Summary: Panel - Digital Clock Overlaping the System Tray
Status: RESOLVED UNMAINTAINED
Alias: None
Product: plasma4
Classification: Plasma
Component: panel (show other bugs)
Version: 4.8.4
Platform: Debian testing Linux
: NOR normal
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-19 22:54 UTC by pbea
Modified: 2018-06-08 19:43 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments
png image of panel area in question (32.48 KB, image/png)
2012-03-19 22:54 UTC, pbea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pbea 2012-03-19 22:54:44 UTC
Created attachment 69744 [details]
png image of panel area in question

Hello

Bug Reports 162277 and 177968 both fixed or resolved from 08 may be similiar to this. This is 4.7.4 and four years later.

4.7.4 was downloaded yesterday and the problem started immediately.

The system tray is residing about 50% over the digital clock as per the attachment. I tried to remedy by substituting old copies of the plasma-desktop-appletsrc, plasma-desktoprc, and plasmarc but nothing helped. I tried moving the system tray to the left but just made the situation worse. Nothing that I do helps.

This is the first time in years that I have had this problem probably around 08.

Please tell me what you want in the way of files.

Hope this helps.
Comment 1 pbea 2012-03-24 20:05:45 UTC
Additional Comments

Previous bugs mention a relationship between locked icons and this issue. In this cause this may and may have any bearing.

I unlocked the icons and logged in and out and the problem failed to show. My monitor went into screensaver and the problem started again. The monitor awoke from suspension and the problem was agin present.

Hope this helps.

ps:   I replaced the plasma-desktop-appletsrc with an old copy from 4.6.5 and the problem is not present.
Comment 2 pbea 2012-03-24 20:06:27 UTC
Additional Comments

Previous bugs mention a relationship between locked icons and this issue. In this cause this may and may have any bearing.

I unlocked the icons and logged in and out and the problem failed to show. My monitor went into screensaver and the problem started again. The monitor awoke from suspension and the problem was agin present.

Hope this helps.

ps:   I replaced the plasma-desktop-appletsrc with an old copy from 4.6.5 and the problem is not present.
Comment 3 stimur 2012-06-28 15:03:13 UTC
It has same problems in vertical mode.
like here: http://flic.kr/p/cmMFxE
resizing panel resizes clock font as wel

There is no way how to configure fixed font size for this applet which could solve the issue.

Thanks
Comment 4 apache 2012-07-02 17:12:14 UTC
Please also see discussion
http://forum.kde.org/viewtopic.php?f=93&t=39121
Comment 5 Myriam Schweingruber 2012-08-06 09:27:37 UTC
Which is the most recent KDE version this is reproducible with?
Comment 6 apache 2012-08-06 10:00:55 UTC
Have a look at date on 4.8.4 
http://i.imgur.com/NxM6C.png
Even on completely empty panel there are some glitches
http://i.imgur.com/znDB3.png
Comment 7 Myriam Schweingruber 2012-09-07 10:09:38 UTC
Thank you for the feedback.

FWIW: please always attach images here instead of using an external storage space.
Comment 8 Greta Watson 2012-12-02 18:43:56 UTC
I have a similar problem with the system tray.  On two of my machines, the two that are HD and have a resolution of 1920x1080, the rightmost system tray icon sits atop the "show hidden icons" icon.  If I right click, open "System Tray Settings", and click "ok", the system tray moves over so all icons show properly.  Hitting "cancel" does not get the system tray to organize itself properly.

On my desktop, which does not have a battery or bluetooth, the two icons that I have "Always Visible" are the Network Manager and the Volume Control.  On my laptop, I have those two and also Battery Monitor and Bluetooth as "Always Visible".

On the same laptop, if I click on the battery monitor to bring up more information, there is again an overlap.  The first line, "Battery x% (discharging) overlaps the battery icon.  The overlap starts with the "ng" in discharging.

I have another laptop, much smaller, and not HD.  It does not have the system tray overlap; nor does it have the battery info overlap.
Comment 9 Greta Watson 2013-01-07 03:30:26 UTC
My panel is set up to auto-hide.  When I log in and the panel is hidden, the problem appears when I put my cursor in a position to show the panel.

If, however, the cursor is in the position to show the panel at the time I log into my Fedora KDE session, the rightmost item in the system tray does not overlap the "show hidden icons" icon.

Once in the proper position, the system tray stays properly oriented.  Going to the screensaver and back out does not affect the system tray.

I have not yet found a way to get the battery information to stop overlapping.
Comment 10 Nate Graham 2018-06-08 19:43:23 UTC
Hello!

This bug report was filed for KDE Plasma 4, which reached end-of-support status in August 2015. KDE Plasma 5's desktop shell has been almost completely rewritten for better performance and usability, so it is likely that this bug is already resolved in Plasma 5.

Accordingly, we hope you understand why we must close this bug report. If the issue described  here is still present in KDE Plasma 5.12 or later, please feel free to open a new ticket in the "plasmashell" product after reading https://community.kde.org/Get_Involved/Bug_Reporting

If you would like to get involved in KDE's bug triaging effort so that future mass bug closes like this are less likely, please read https://community.kde.org/Get_Involved#Bug_Triaging

Thanks for your understanding!

Nate Graham