Bug 295873 - Backtrace
Summary: Backtrace
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: muon
Classification: Unclassified
Component: muon (show other bugs)
Version: 1.3.0
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-12 21:59 UTC by ben11
Modified: 2012-03-13 13:05 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ben11 2012-03-12 21:59:11 UTC
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb774f930 (LWP 2376))]

Thread 2 (Thread 0xb56e2b70 (LWP 2380)):
#0  0x0090adbd in pthread_mutex_lock () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x07578f14 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#2  0x054de0c3 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x054de990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x054dec2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x00b5fb37 in QEventDispatcherGlib::processEvents (this=0x88e3878, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x00b301dd in QEventLoop::processEvents (this=0xb56e22b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00b30421 in QEventLoop::exec (this=0xb56e22b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x00a3390b in QThread::exec (this=0x88e3618) at thread/qthread.cpp:498
#9  0x00b10e2d in QInotifyFileSystemWatcherEngine::run (this=0x88e3618) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00a367b3 in QThreadPrivate::start (arg=0x88e3618) at thread/qthread_unix.cpp:331
#11 0x00908d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x0756b0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb774f930 (LWP 2376)):
[KCrash Handler]
#7  0x00a8ae11 in QtPrivate::QStringList_contains (that=0xbfc52cf4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfc52cf4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x88508f0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x88508f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc52f14) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00b37b7d in metacall (argv=0xbfc52f14, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x88508f0) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x88508f0, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfc52f14) at kernel/qmetaobject.cpp:232
#13 0x00b46a6a in QMetaObject::activate (sender=0x8832d98, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8832d98) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8832d98, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc53058) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00b37b7d in metacall (argv=0xbfc53058, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8832d98) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8832d98, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfc53058) at kernel/qmetaobject.cpp:232
#18 0x00b46a6a in QMetaObject::activate (sender=0x88508f0, m=0x80950c0, local_signal_index=0, argv=0xbfc53058) at kernel/qobject.cpp:3278
#19 0x0024f7c5 in MuonMainWindow::backendReady (this=0x88508f0, _t1=0x888ee70) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x0024f933 in MuonMainWindow::initObject (this=0x88508f0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x88508f0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x88508f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc53184) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00b37b7d in metacall (argv=0xbfc53184, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x88508f0) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x88508f0, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfc53184) at kernel/qmetaobject.cpp:232
#25 0x00b46a6a in QMetaObject::activate (sender=0x88bca60, m=0xc67238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00b4e375 in QSingleShotTimer::timeout (this=0x88bca60) at .moc/release-shared/qtimer.moc:82
#27 0x00b4e42c in QSingleShotTimer::timerEvent (this=0x88bca60) at kernel/qtimer.cpp:308
#28 0x00b49994 in QObject::event (this=0x88bca60, e=0xbfc5357c) at kernel/qobject.cpp:1181
#29 0x049f9d84 in notify_helper (e=0xbfc5357c, receiver=0x88bca60, this=0x87447f8) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x87447f8, receiver=0x88bca60, e=0xbfc5357c) at kernel/qapplication.cpp:4458
#31 0x049ff133 in QApplication::notify (this=0xbfc5357c, receiver=0x88bca60, e=0xbfc5357c) at kernel/qapplication.cpp:3886
#32 0x010c8971 in KApplication::notify (this=0xbfc53890, receiver=0x88bca60, event=0xbfc5357c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00b3119e in QCoreApplication::notifyInternal (this=0xbfc53890, receiver=0x88bca60, event=0xbfc5357c) at kernel/qcoreapplication.cpp:787
#34 0x00b61c10 in sendEvent (event=0xbfc5357c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x874608c) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00b5f122 in timerSourceDispatch (source=0x8746058) at kernel/qeventdispatcher_glib.cpp:184
#37 0x054de25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x054de990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x054dec2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00b5fada in QEventDispatcherGlib::processEvents (this=0x8728238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x04ab1e7a in QGuiEventDispatcherGlib::processEvents (this=0x8728238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00b301dd in QEventLoop::processEvents (this=0xbfc537f4, flags=...) at kernel/qeventloop.cpp:149
#43 0x00b30421 in QEventLoop::exec (this=0xbfc537f4, flags=...) at kernel/qeventloop.cpp:201
#44 0x00b3519d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x049f7924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61
Comment 1 Christoph Feck 2012-03-13 13:05:20 UTC

*** This bug has been marked as a duplicate of bug 291262 ***