Bug 295713 - Nepomuk crashes when calibre fetch news
Summary: Nepomuk crashes when calibre fetch news
Status: RESOLVED DUPLICATE of bug 241723
Alias: None
Product: nepomuk
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-10 20:09 UTC by fenuks
Modified: 2012-03-10 23:50 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fenuks 2012-03-10 20:09:09 UTC
Application: nepomukservicestub (0.2)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.8.0
Operating System: Linux 3.2.9-1.fc16.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed: I am using latest calibre (ebook manager, http://calibre-ebook.com/) which can fetch news from RSS and save it as ebook on hard drive. When calibre fetch news Nepomuk simply crash.

-- Backtrace:
Application: Tymczasowa usługa Nepomuka (nepomukservicestub), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7ff08644a840 (LWP 2387))]

Thread 3 (Thread 0x7ff07b9f0700 (LWP 2392)):
#0  0x00000030568e85c3 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x0000003058444fd8 in g_main_context_poll (n_fds=1, fds=0x7ff0740013e0, priority=<optimized out>, timeout=19398, context=0x7ff0740009a0) at gmain.c:3402
#2  g_main_context_iterate (context=0x7ff0740009a0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3084
#3  0x000000305844549c in g_main_context_iteration (context=0x7ff0740009a0, may_block=1) at gmain.c:3152
#4  0x000000305e5a7dc6 in QEventDispatcherGlib::processEvents (this=0x7ff0740008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x000000305e578182 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x000000305e5783d7 in QEventLoop::exec (this=0x7ff07b9efd40, flags=...) at kernel/qeventloop.cpp:204
#7  0x000000305e478b27 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x000000305e47bb6b in QThreadPrivate::start (arg=0x227b2a0) at thread/qthread_unix.cpp:298
#9  0x0000003057007d90 in start_thread (arg=0x7ff07b9f0700) at pthread_create.c:309
#10 0x00000030568f0f5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7ff07b1ef700 (LWP 2435)):
#0  0x00000030568e85c3 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x0000003058444fd8 in g_main_context_poll (n_fds=1, fds=0x7ff06c002250, priority=<optimized out>, timeout=-1, context=0x7ff06c0009a0) at gmain.c:3402
#2  g_main_context_iterate (context=0x7ff06c0009a0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3084
#3  0x000000305844549c in g_main_context_iteration (context=0x7ff06c0009a0, may_block=1) at gmain.c:3152
#4  0x000000305e5a7dc6 in QEventDispatcherGlib::processEvents (this=0x7ff06c0008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x000000305e578182 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x000000305e5783d7 in QEventLoop::exec (this=0x7ff07b1eed10, flags=...) at kernel/qeventloop.cpp:204
#7  0x000000305e478b27 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x000000305e557e7f in QInotifyFileSystemWatcherEngine::run (this=0x228c620) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x000000305e47bb6b in QThreadPrivate::start (arg=0x228c620) at thread/qthread_unix.cpp:298
#10 0x0000003057007d90 in start_thread (arg=0x7ff07b1ef700) at pthread_create.c:309
#11 0x00000030568f0f5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7ff08644a840 (LWP 2387)):
[KCrash Handler]
#6  isSignalConnected (signal_index=6, this=0x101c027a7) at kernel/qobject_p.h:229
#7  QMetaObject::activate (sender=0x2281b40, m=<optimized out>, local_signal_index=4, argv=0x7fffeac2c4a0) at kernel/qobject.cpp:3456
#8  0x00007ff07bc57fe6 in KInotify::created (this=<optimized out>, _t1=<optimized out>, _t2=true) at /usr/src/debug/kde-runtime-4.7.4/x86_64-redhat-linux-gnu/nepomuk/services/filewatch/kinotify.moc:173
#9  0x00007ff07bc5898d in KInotify::slotEvent (this=0x2281b40, socket=<optimized out>) at /usr/src/debug/kde-runtime-4.7.4/nepomuk/services/filewatch/kinotify.cpp:365
#10 0x00007ff07bc5a333 in qt_static_metacall (_a=0x7fffeac2caa0, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at /usr/src/debug/kde-runtime-4.7.4/x86_64-redhat-linux-gnu/nepomuk/services/filewatch/kinotify.moc:95
#11 KInotify::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=0x7fffeac2caa0) at /usr/src/debug/kde-runtime-4.7.4/x86_64-redhat-linux-gnu/nepomuk/services/filewatch/kinotify.moc:72
#12 0x000000305e58cce1 in QMetaObject::activate (sender=0x2285ee0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffeac2caa0) at kernel/qobject.cpp:3547
#13 0x000000305e5d982e in QSocketNotifier::activated (this=<optimized out>, _t1=14) at .moc/release-shared/moc_qsocketnotifier.cpp:103
#14 0x000000305e59608b in QSocketNotifier::event (this=0x2285ee0, e=0x7fffeac2d110) at kernel/qsocketnotifier.cpp:317
#15 0x0000003eaf1c9994 in notify_helper (e=0x7fffeac2d110, receiver=0x2285ee0, this=0x1faaed0) at kernel/qapplication.cpp:4550
#16 QApplicationPrivate::notify_helper (this=0x1faaed0, receiver=0x2285ee0, e=0x7fffeac2d110) at kernel/qapplication.cpp:4522
#17 0x0000003eaf1ce813 in QApplication::notify (this=0x7fffeac2d4e0, receiver=0x2285ee0, e=0x7fffeac2d110) at kernel/qapplication.cpp:4411
#18 0x0000003eb0c50766 in KApplication::notify (this=0x7fffeac2d4e0, receiver=0x2285ee0, event=0x7fffeac2d110) at /usr/src/debug/kdelibs-4.7.4/kdeui/kernel/kapplication.cpp:311
#19 0x000000305e57904c in QCoreApplication::notifyInternal (this=0x7fffeac2d4e0, receiver=0x2285ee0, event=0x7fffeac2d110) at kernel/qcoreapplication.cpp:876
#20 0x000000305e5a73b7 in sendEvent (event=0x7fffeac2d110, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#21 socketNotifierSourceDispatch (source=0x1fac000) at kernel/qeventdispatcher_glib.cpp:110
#22 0x0000003058444acd in g_main_dispatch (context=0x1fb08f0) at gmain.c:2441
#23 g_main_context_dispatch (context=0x1fb08f0) at gmain.c:3011
#24 0x00000030584452c8 in g_main_context_iterate (context=0x1fb08f0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3089
#25 0x000000305844549c in g_main_context_iteration (context=0x1fb08f0, may_block=1) at gmain.c:3152
#26 0x000000305e5a7d5f in QEventDispatcherGlib::processEvents (this=0x1f827a0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#27 0x0000003eaf26c66e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#28 0x000000305e578182 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#29 0x000000305e5783d7 in QEventLoop::exec (this=0x7fffeac2d350, flags=...) at kernel/qeventloop.cpp:204
#30 0x000000305e57cdd5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#31 0x0000000000403a10 in main (argc=2, argv=0x7fffeac2d988) at /usr/src/debug/kde-runtime-4.7.4/nepomuk/servicestub/main.cpp:170

Possible duplicates by query: bug 291195, bug 289635, bug 286240, bug 286238, bug 285959.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-10 23:50:47 UTC

*** This bug has been marked as a duplicate of bug 241723 ***