Bug 295711 - Amarok crashes on logout or restart select on leave widget.
Summary: Amarok crashes on logout or restart select on leave widget.
Status: RESOLVED DUPLICATE of bug 285951
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.5.0
Platform: openSUSE RPMs Linux
: NOR crash with 3 votes (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-10 19:31 UTC by Russ Fineman
Modified: 2012-03-10 21:41 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Russ Fineman 2012-03-10 19:31:15 UTC
Application: amarok (2.5.0)
KDE Platform Version: 4.8.1 (4.8.1) "release 481"
Qt Version: 4.8.0
Operating System: Linux 3.1.9-1.4-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
Had selected logout to pick up new permissions. Also always occurs or restart since upgrade to KDE 4.8.1

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
[Current thread is 1 (Thread 0x7ff65e0c97a0 (LWP 12572))]

Thread 11 (Thread 0x7ff6068e4700 (LWP 12613)):
#0  0x00007ff658aefe6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ff641d61314 in ?? () from /usr/lib64/libvlccore.so.4
#2  0x00007ff64bf30354 in ?? () from /usr/lib64/libGL.so.1
#3  0x00007ff658aebf05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007ff65a9a163d in clone () from /lib64/libc.so.6

Thread 10 (Thread 0x7ff5fffff700 (LWP 12617)):
#0  0x00007ff65bffdde3 in socketNotifierSourcePrepare (timeout=0x7ff5ffffeb5c) at kernel/qeventdispatcher_glib.cpp:73
#1  0x00007ff654639b22 in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#2  0x00007ff65463a92d in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007ff65463af59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007ff65bffe956 in QEventDispatcherGlib::processEvents (this=0x7ff5f8002280, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007ff65bfce682 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007ff65bfce8d7 in QEventLoop::exec (this=0x7ff5ffffecf0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007ff65becf537 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007ff65bfae48f in QInotifyFileSystemWatcherEngine::run (this=0xfbbec0) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007ff65bed255b in QThreadPrivate::start (arg=0xfbbec0) at thread/qthread_unix.cpp:298
#10 0x00007ff64bf30354 in ?? () from /usr/lib64/libGL.so.1
#11 0x00007ff658aebf05 in start_thread () from /lib64/libpthread.so.0
#12 0x00007ff65a9a163d in clone () from /lib64/libc.so.6

Thread 9 (Thread 0x7ff5fecae700 (LWP 12619)):
#0  0x00007ff65a998523 in poll () from /lib64/libc.so.6
#1  0x00007ff65463aa98 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007ff65463af59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007ff65bffe956 in QEventDispatcherGlib::processEvents (this=0x7ff5ec0008e0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007ff65bfce682 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ff65bfce8d7 in QEventLoop::exec (this=0x7ff5fecadd20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007ff65becf537 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007ff65bed255b in QThreadPrivate::start (arg=0x107b560) at thread/qthread_unix.cpp:298
#8  0x00007ff64bf30354 in ?? () from /usr/lib64/libGL.so.1
#9  0x00007ff658aebf05 in start_thread () from /lib64/libpthread.so.0
#10 0x00007ff65a9a163d in clone () from /lib64/libc.so.6

Thread 8 (Thread 0x7ff5fde32700 (LWP 12620)):
#0  0x00007fff96bff8de in ?? ()
#1  0x00007ff6548eee91 in clock_gettime () from /lib64/librt.so.1
#2  0x00007ff65bf28a24 in do_gettime (frac=0x7ff5fde31ac8, sec=0x7ff5fde31ac0) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007ff65bfff0bd in QTimerInfoList::updateCurrentTime (this=0x7ff5e40020d0) at kernel/qeventdispatcher_unix.cpp:343
#5  0x00007ff65bfff3f3 in QTimerInfoList::timerWait (this=0x7ff5e40020d0, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#6  0x00007ff65bffde2c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7ff5fde31b8c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007ff654639b22 in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#8  0x00007ff65463a92d in ?? () from /usr/lib64/libglib-2.0.so.0
#9  0x00007ff65463af59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#10 0x00007ff65bffe956 in QEventDispatcherGlib::processEvents (this=0x7ff5e40008e0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#11 0x00007ff65bfce682 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#12 0x00007ff65bfce8d7 in QEventLoop::exec (this=0x7ff5fde31d20, flags=...) at kernel/qeventloop.cpp:204
#13 0x00007ff65becf537 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#14 0x00007ff65bed255b in QThreadPrivate::start (arg=0x1166b90) at thread/qthread_unix.cpp:298
#15 0x00007ff64bf30354 in ?? () from /usr/lib64/libGL.so.1
#16 0x00007ff658aebf05 in start_thread () from /lib64/libpthread.so.0
#17 0x00007ff65a9a163d in clone () from /lib64/libc.so.6

Thread 7 (Thread 0x7ff5fcc2d700 (LWP 12622)):
#0  0x00007ff658aefe6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ff65bed2a6b in wait (time=18446744073709551615, this=0x1159fa0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x110b8e0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007ff657eca96b in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1159e50, th=0x112c2a0) at /usr/src/debug/kdelibs-4.8.1/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007ff657ecd25b in ThreadWeaver::WorkingHardState::applyForWork (this=0x110b9b0, th=0x112c2a0) at /usr/src/debug/kdelibs-4.8.1/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007ff657ecd274 in ThreadWeaver::WorkingHardState::applyForWork (this=0x110b9b0, th=0x112c2a0) at /usr/src/debug/kdelibs-4.8.1/threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007ff657ecd274 in ThreadWeaver::WorkingHardState::applyForWork (this=0x110b9b0, th=0x112c2a0) at /usr/src/debug/kdelibs-4.8.1/threadweaver/Weaver/WorkingHardState.cpp:74
#7  0x00007ff657ecd274 in ThreadWeaver::WorkingHardState::applyForWork (this=0x110b9b0, th=0x112c2a0) at /usr/src/debug/kdelibs-4.8.1/threadweaver/Weaver/WorkingHardState.cpp:74
#8  0x00007ff657ecd274 in ThreadWeaver::WorkingHardState::applyForWork (this=0x110b9b0, th=0x112c2a0) at /usr/src/debug/kdelibs-4.8.1/threadweaver/Weaver/WorkingHardState.cpp:74
#9  0x00007ff657ecc0cf in ThreadWeaver::ThreadRunHelper::run (this=0x7ff5fcc2cd40, parent=0x1159e50, th=0x112c2a0) at /usr/src/debug/kdelibs-4.8.1/threadweaver/Weaver/Thread.cpp:87
#10 0x00007ff657ecc15b in ThreadWeaver::Thread::run (this=0x112c2a0) at /usr/src/debug/kdelibs-4.8.1/threadweaver/Weaver/Thread.cpp:142
#11 0x00007ff65bed255b in QThreadPrivate::start (arg=0x112c2a0) at thread/qthread_unix.cpp:298
#12 0x00007ff64bf30354 in ?? () from /usr/lib64/libGL.so.1
#13 0x00007ff658aebf05 in start_thread () from /lib64/libpthread.so.0
#14 0x00007ff65a9a163d in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7ff5f34af700 (LWP 12623)):
#0  0x00007ff658aefe6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ff65bed2a6b in wait (time=18446744073709551615, this=0x1159fa0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x110b8e0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007ff657eca96b in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1159e50, th=0x14331c0) at /usr/src/debug/kdelibs-4.8.1/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007ff657ecd25b in ThreadWeaver::WorkingHardState::applyForWork (this=0x110b9b0, th=0x14331c0) at /usr/src/debug/kdelibs-4.8.1/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007ff657ecd274 in ThreadWeaver::WorkingHardState::applyForWork (this=0x110b9b0, th=0x14331c0) at /usr/src/debug/kdelibs-4.8.1/threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007ff657ecc0cf in ThreadWeaver::ThreadRunHelper::run (this=0x7ff5f34aed40, parent=0x1159e50, th=0x14331c0) at /usr/src/debug/kdelibs-4.8.1/threadweaver/Weaver/Thread.cpp:87
#7  0x00007ff657ecc15b in ThreadWeaver::Thread::run (this=0x14331c0) at /usr/src/debug/kdelibs-4.8.1/threadweaver/Weaver/Thread.cpp:142
#8  0x00007ff65bed255b in QThreadPrivate::start (arg=0x14331c0) at thread/qthread_unix.cpp:298
#9  0x00007ff64bf30354 in ?? () from /usr/lib64/libGL.so.1
#10 0x00007ff658aebf05 in start_thread () from /lib64/libpthread.so.0
#11 0x00007ff65a9a163d in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7ff5f2cae700 (LWP 12624)):
#0  0x00007ff658aefe6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ff65bed2a6b in wait (time=18446744073709551615, this=0x1159fa0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x110b8e0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007ff657eca96b in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1159e50, th=0x1433f00) at /usr/src/debug/kdelibs-4.8.1/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007ff657ecd25b in ThreadWeaver::WorkingHardState::applyForWork (this=0x110b9b0, th=0x1433f00) at /usr/src/debug/kdelibs-4.8.1/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007ff657ecc0cf in ThreadWeaver::ThreadRunHelper::run (this=0x7ff5f2cadd40, parent=0x1159e50, th=0x1433f00) at /usr/src/debug/kdelibs-4.8.1/threadweaver/Weaver/Thread.cpp:87
#6  0x00007ff657ecc15b in ThreadWeaver::Thread::run (this=0x1433f00) at /usr/src/debug/kdelibs-4.8.1/threadweaver/Weaver/Thread.cpp:142
#7  0x00007ff65bed255b in QThreadPrivate::start (arg=0x1433f00) at thread/qthread_unix.cpp:298
#8  0x00007ff64bf30354 in ?? () from /usr/lib64/libGL.so.1
#9  0x00007ff658aebf05 in start_thread () from /lib64/libpthread.so.0
#10 0x00007ff65a9a163d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7ff5f24ad700 (LWP 12625)):
#0  0x00007ff658aefe6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ff65bed2a6b in wait (time=18446744073709551615, this=0x1159fa0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x110b8e0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007ff657eca96b in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1159e50, th=0x1434c80) at /usr/src/debug/kdelibs-4.8.1/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007ff657ecd25b in ThreadWeaver::WorkingHardState::applyForWork (this=0x110b9b0, th=0x1434c80) at /usr/src/debug/kdelibs-4.8.1/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007ff657ecc0cf in ThreadWeaver::ThreadRunHelper::run (this=0x7ff5f24acd40, parent=0x1159e50, th=0x1434c80) at /usr/src/debug/kdelibs-4.8.1/threadweaver/Weaver/Thread.cpp:87
#6  0x00007ff657ecc15b in ThreadWeaver::Thread::run (this=0x1434c80) at /usr/src/debug/kdelibs-4.8.1/threadweaver/Weaver/Thread.cpp:142
#7  0x00007ff65bed255b in QThreadPrivate::start (arg=0x1434c80) at thread/qthread_unix.cpp:298
#8  0x00007ff64bf30354 in ?? () from /usr/lib64/libGL.so.1
#9  0x00007ff658aebf05 in start_thread () from /lib64/libpthread.so.0
#10 0x00007ff65a9a163d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7ff5f1669700 (LWP 12626)):
#0  0x00007ff658aefe6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ff651488c12 in WTF::TCMalloc_PageHeap::scavengerThread (this=0x7ff651e271a0) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#2  0x00007ff651488c49 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#3  0x00007ff64bf30354 in ?? () from /usr/lib64/libGL.so.1
#4  0x00007ff658aebf05 in start_thread () from /lib64/libpthread.so.0
#5  0x00007ff65a9a163d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7ff5d3fff700 (LWP 12629)):
#0  0x00007ff65a96fe0d in nanosleep () from /lib64/libc.so.6
#1  0x00007ff65a96fc98 in sleep () from /lib64/libc.so.6
#2  0x00007ff656ee68d5 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7ff6571dfe80) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2363
#3  0x00007ff656ee6979 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#4  0x00007ff64bf30354 in ?? () from /usr/lib64/libGL.so.1
#5  0x00007ff658aebf05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007ff65a9a163d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7ff65e0c97a0 (LWP 12572)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007ff65cf72a9e in qDeleteAll<QList<Collections::Collection*>::const_iterator> (end=<optimized out>, begin=<optimized out>) at /usr/include/QtCore/qalgorithms.h:322
#8  qDeleteAll<SmartPointerList<Collections::Collection> > (c=...) at /usr/include/QtCore/qalgorithms.h:330
#9  CollectionManager::~CollectionManager (this=0x81aad0, __in_chrg=<optimized out>) at /usr/src/debug/amarok-2.5.0/src/core-impl/collections/support/CollectionManager.cpp:137
#10 0x00007ff65cf72c89 in CollectionManager::~CollectionManager (this=0x81aad0, __in_chrg=<optimized out>) at /usr/src/debug/amarok-2.5.0/src/core-impl/collections/support/CollectionManager.cpp:145
#11 0x00007ff65cf70f26 in CollectionManager::destroy () at /usr/src/debug/amarok-2.5.0/src/core-impl/collections/support/CollectionManager.cpp:107
#12 0x00007ff65d0a5edf in App::~App (this=0x7fff96be49c0, __in_chrg=<optimized out>) at /usr/src/debug/amarok-2.5.0/src/App.cpp:248
#13 0x000000000040909a in main (argc=3, argv=0x7fff96be6e48) at /usr/src/debug/amarok-2.5.0/src/main.cpp:301

This bug may be a duplicate of or related to bug 285951.

Possible duplicates by query: bug 294709, bug 290283, bug 289869, bug 281312, bug 274095.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2012-03-10 21:41:20 UTC

*** This bug has been marked as a duplicate of bug 285951 ***