Bug 295607 - Amarok crashed after it started
Summary: Amarok crashed after it started
Status: RESOLVED DUPLICATE of bug 281312
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.5.0
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-09 12:54 UTC by Unknown
Modified: 2012-03-10 10:52 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Unknown 2012-03-09 12:54:50 UTC
Since there's no Dr. Konqui, I don't know whether there is a duplicate somewhere else.

I updated to the latest Amarok alogn with KDE and restarted the machine. After that Amarok crashed when it was starting.

Crashlog:
Application: Amarok (amarok), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f3ccd54f7a0 (LWP 5009))]

Thread 3 (Thread 0x7f3caf8fe700 (LWP 5018)):
#0  0x00007f3cc9e1dd33 in select () from /lib64/libc.so.6
#1  0x00007f3ccb42f931 in QProcessManager::run (this=0x7f3ccb7a94a0) at io/qprocess_unix.cpp:244
#2  0x00007f3ccb35555b in QThreadPrivate::start (arg=0x7f3ccb7a94a0) at thread/qthread_unix.cpp:298
#3  0x00007f3cbb3b22da in ?? () from /usr/X11R6/lib64/libGL.so.1
#4  0x00007f3cc7f6ef05 in start_thread () from /lib64/libpthread.so.0
#5  0x00007f3cc9e2463d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f3caedb5700 (LWP 5041)):
[KCrash Handler]
#6  0x00007f3cb0f6189b in DirWatchJob::run (this=0xc06e60) at /usr/src/debug/amarok-2.5.0/src/core-impl/collections/db/ScanManager.cpp:372
#7  0x00007f3cc734f8db in ThreadWeaver::JobRunHelper::runTheJob (this=0x7f3caedb4cc0, th=0xcba870, job=0xc06e60) at /usr/src/debug/kdelibs-4.8.1/threadweaver/Weaver/Job.cpp:106
#8  0x00007f3cc734fa4c in ThreadWeaver::Job::execute (this=0xc06e60, th=0xcba870) at /usr/src/debug/kdelibs-4.8.1/threadweaver/Weaver/Job.cpp:135
#9  0x00007f3cc734f09f in ThreadWeaver::ThreadRunHelper::run (this=0x7f3caedb4d40, parent=0xca9120, th=0xcba870) at /usr/src/debug/kdelibs-4.8.1/threadweaver/Weaver/Thread.cpp:95
#10 0x00007f3cc734f15b in ThreadWeaver::Thread::run (this=0xcba870) at /usr/src/debug/kdelibs-4.8.1/threadweaver/Weaver/Thread.cpp:142
#11 0x00007f3ccb35555b in QThreadPrivate::start (arg=0xcba870) at thread/qthread_unix.cpp:298
#12 0x00007f3cbb3b22da in ?? () from /usr/X11R6/lib64/libGL.so.1
#13 0x00007f3cc7f6ef05 in start_thread () from /lib64/libpthread.so.0
#14 0x00007f3cc9e2463d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f3ccd54f7a0 (LWP 5009)):
#0  0x00007f3cc7f72e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f3ccb355a6b in wait (time=18446744073709551615, this=0x807120) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7e3488, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f3ccb355178 in QThread::wait (this=<optimized out>, time=18446744073709551615) at thread/qthread_unix.cpp:651
#4  0x00007f3ccb42f430 in QProcessManager::~QProcessManager (this=0x7f3ccb7a94a0, __in_chrg=<optimized out>) at io/qprocess_unix.cpp:211
#5  0x00007f3cc9d829a1 in __run_exit_handlers () from /lib64/libc.so.6
#6  0x00007f3cc9d82a25 in exit () from /lib64/libc.so.6
#7  0x00007f3cca843ae8 in qt_xio_errhandler () at kernel/qapplication_x11.cpp:770
#8  0x00007f3cccf59918 in KApplication::xioErrhandler (this=0x7fff3e6a01f0, dpy=0x809d80) at /usr/src/debug/kdelibs-4.8.1/kdeui/kernel/kapplication.cpp:419
#9  0x00007f3ccbcd251e in _XIOError (dpy=0x809d80) at XlibInt.c:1602
#10 0x00007f3ccbccfe2d in _XEventsQueued (dpy=0x809d80, mode=<optimized out>) at xcb_io.c:307
#11 0x00007f3ccbcc081f in XEventsQueued (dpy=0x809d80, mode=2) at Pending.c:43
#12 0x00007f3cca87b11c in x11EventSourceCheck (s=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:85
#13 0x00007f3cc3abd264 in g_main_context_check (context=0x7e2110, max_priority=2147483647, fds=<optimized out>, n_fds=<optimized out>) at gmain.c:2943
#14 0x00007f3cc3abdab2 in g_main_context_iterate (context=0x7e2110, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3070
#15 0x00007f3cc3abdf59 in g_main_context_iteration (context=0x7e2110, may_block=1) at gmain.c:3136
#16 0x00007f3ccb4818ef in QEventDispatcherGlib::processEvents (this=0x61b000, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#17 0x00007f3cca87b2de in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#18 0x00007f3ccb451682 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#19 0x00007f3ccb4518d7 in QEventLoop::exec (this=0x7fff3e69ed70, flags=...) at kernel/qeventloop.cpp:204
#20 0x00007f3ccaca4086 in QDialog::exec (this=0xb50160) at dialogs/qdialog.cpp:552
#21 0x00007f3cccec257a in KMessageBox::createKMessageBox (dialog=<optimized out>, icon=..., text=..., strlist=..., ask=..., checkboxReturn=0x0, options=..., details=..., notifyType=QMessageBox::Critical) at /usr/src/debug/kdelibs-4.8.1/kdeui/dialogs/kmessagebox.cpp:344
#22 0x00007f3cccec2d54 in KMessageBox::createKMessageBox (dialog=0xb50160, icon=QMessageBox::Critical, text=..., strlist=..., ask=..., checkboxReturn=0x0, options=..., details=...) at /usr/src/debug/kdelibs-4.8.1/kdeui/dialogs/kmessagebox.cpp:159
#23 0x00007f3cccec3a4b in KMessageBox::errorListWId (parent_id=0, text=..., strlist=..., caption=..., options=...) at /usr/src/debug/kdelibs-4.8.1/kdeui/dialogs/kmessagebox.cpp:854
#24 0x00007f3cccec3c6b in KMessageBox::error (parent=<optimized out>, text=..., caption=..., options=...) at /usr/src/debug/kdelibs-4.8.1/kdeui/dialogs/kmessagebox.cpp:821
#25 0x00007f3cb0f679aa in Collections::SqlCollection::SqlCollection (this=<optimized out>, id=..., prettyName=..., storage=0xb6c070) at /usr/src/debug/amarok-2.5.0/src/core-impl/collections/db/sql/SqlCollection.cpp:176
#26 0x00007f3cb0f6968f in Collections::SqlCollectionFactory::createSqlCollection (this=<optimized out>, id=..., prettyName=..., storage=0xb6c070) at /usr/src/debug/amarok-2.5.0/src/core-impl/collections/db/sql/SqlCollectionFactory.cpp:31
#27 0x00007f3cb11c836a in Collections::MySqlEmbeddedCollectionFactory::init (this=0xb410c0) at /usr/src/debug/amarok-2.5.0/src/core-impl/collections/db/sql/mysqlecollection/MySqlEmbeddedCollection.cpp:35
#28 0x00007f3ccc3f5059 in CollectionManager::loadPlugins (this=0x7df280, factories=...) at /usr/src/debug/amarok-2.5.0/src/core-impl/collections/support/CollectionManager.cpp:207
#29 0x00007f3ccc3f8604 in CollectionManager::init (this=0x7df280, factories=...) at /usr/src/debug/amarok-2.5.0/src/core-impl/collections/support/CollectionManager.cpp:175
#30 0x00007f3ccc56e60a in Plugins::PluginManager::init (this=0xa29a30) at /usr/src/debug/amarok-2.5.0/src/PluginManager.cpp:82
#31 0x00007f3ccc56f829 in Plugins::PluginManager::PluginManager (this=0xa29a30, parent=<optimized out>) at /usr/src/debug/amarok-2.5.0/src/PluginManager.cpp:64
#32 0x00007f3ccc56f9f7 in Plugins::PluginManager::instance () at /usr/src/debug/amarok-2.5.0/src/PluginManager.cpp:43
#33 0x00007f3ccc55163d in pluginManager () at /usr/src/debug/amarok-2.5.0/src/PluginManager.h:76
#34 MainWindow::MainWindow (this=0x7f2450) at /usr/src/debug/amarok-2.5.0/src/MainWindow.cpp:139
#35 0x00007f3ccc529aef in App::continueInit (this=0x7fff3e6a01f0) at /usr/src/debug/amarok-2.5.0/src/App.cpp:545
#36 0x00007f3ccc52b1dc in App::App (this=0x7fff3e6a01f0) at /usr/src/debug/amarok-2.5.0/src/App.cpp:185
#37 0x0000000000409085 in main (argc=2, argv=0x7fff3e6a2678) at /usr/src/debug/amarok-2.5.0/src/main.cpp:301
Comment 1 Myriam Schweingruber 2012-03-10 10:52:17 UTC
Please remove the $HOME/.kde4/share/config/amarok* files and don't enable the option "Watch folders for change" in the Amarok settings for the collection. this is a workaround though, not a permanent solution.

*** This bug has been marked as a duplicate of bug 281312 ***