Bug 295549 - files opened/previewed from ark (e.g. zip package) are limited in functions (okular)
Summary: files opened/previewed from ark (e.g. zip package) are limited in functions (...
Status: RESOLVED DUPLICATE of bug 179066
Alias: None
Product: ark
Classification: Applications
Component: general (show other bugs)
Version: 2.17
Platform: Ubuntu Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Raphael Kubo da Costa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-08 18:41 UTC by Dan Duris
Modified: 2014-08-20 19:52 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Duris 2012-03-08 18:41:11 UTC
Files that are opened directly from ark are limited in options. Fore example okular does not allow to search thecontent of  PDF file and is limited in other ways, too.

Please, allow external programs opening files from ark to be allowed full control over.

Does this stem from files opened as read only?
Comment 1 Raphael Kubo da Costa 2012-03-08 20:21:15 UTC
Hi. There are two separate issues here:

(In reply to comment #0)
> Files that are opened directly from ark are limited in options. Fore example
> okular does not allow to search thecontent of  PDF file and is limited in
> other ways, too.

We just use whatever Okular provides as a KPart to read PDF files; if it provides no way to search a file by just embedding the KPart into a dialog, there is not much we can do.

> Please, allow external programs opening files from ark to be allowed full
> control over.

This is bug 179066, which has a patch in the works and should probably solve the issue above to, as you'll then be able to launch Okular itself to view a PDF file. I'm marking this report as a duplicate of it.

*** This bug has been marked as a duplicate of bug 179066 ***
Comment 2 Travis Evans 2014-08-20 19:52:47 UTC
FWIW, in regard to the first part, searching and printing appear to be available from an Okular KPart in Konqueror (if that is indeed a KPart).  It's claimed in Bug #307525 that this is Ark's fault.  Not being a KDE developer, of course, I have no idea who's really at fault.