Bug 295543 - Muon crashes on startup: Application: Muon Software Center (muon-installer), signal: Segmentation fault
Summary: Muon crashes on startup: Application: Muon Software Center (muon-installer), ...
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: muon
Classification: Unclassified
Component: muon (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR critical (vote)
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-08 17:46 UTC by Greg Fike
Modified: 2012-03-08 18:23 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Greg Fike 2012-03-08 17:46:45 UTC
User-Agent:       Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:10.0.2) Gecko/20100101 Firefox/10.0.2
Build Identifier: 

When trying to start up the Muon Software Center, it crashes.Below is the backtrace.

Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7793930 (LWP 1472))]

Thread 2 (Thread 0xb5ac7b70 (LWP 1473)):
#0  0x009ad416 in __kernel_vsyscall ()
#1  0x062d840e in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x01f5734b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x01f48896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x01f48c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x005aeb37 in QEventDispatcherGlib::processEvents (this=0x9102bf8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x0057f1dd in QEventLoop::processEvents (this=0xb5ac72b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x0057f421 in QEventLoop::exec (this=0xb5ac72b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x0048290b in QThread::exec (this=0x90fbc40) at thread/qthread.cpp:498
#9  0x0055fe2d in QInotifyFileSystemWatcherEngine::run (this=0x90fbc40) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x004857b3 in QThreadPrivate::start (arg=0x90fbc40) at thread/qthread_unix.cpp:331
#11 0x007b3d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x062e70ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7793930 (LWP 1472)):
[KCrash Handler]
#7  0x004d9e11 in QtPrivate::QStringList_contains (that=0xbf8be624, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf8be624) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x90e8b88) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x90e8b88, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8be844) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00586b7d in metacall (argv=0xbf8be844, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x90e8b88) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x90e8b88, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf8be844) at kernel/qmetaobject.cpp:232
#13 0x00595a6a in QMetaObject::activate (sender=0x917dd80, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x917dd80) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x917dd80, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8be988) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00586b7d in metacall (argv=0xbf8be988, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x917dd80) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x917dd80, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf8be988) at kernel/qmetaobject.cpp:232
#18 0x00595a6a in QMetaObject::activate (sender=0x90e8b88, m=0x80950c0, local_signal_index=0, argv=0xbf8be988) at kernel/qobject.cpp:3278
#19 0x001407c5 in MuonMainWindow::backendReady (this=0x90e8b88, _t1=0x910a330) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00140933 in MuonMainWindow::initObject (this=0x90e8b88) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x90e8b88) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x90e8b88, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8beab4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00586b7d in metacall (argv=0xbf8beab4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x90e8b88) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x90e8b88, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf8beab4) at kernel/qmetaobject.cpp:232
#25 0x00595a6a in QMetaObject::activate (sender=0x914aa50, m=0x6b6238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x0059d375 in QSingleShotTimer::timeout (this=0x914aa50) at .moc/release-shared/qtimer.moc:82
#27 0x0059d42c in QSingleShotTimer::timerEvent (this=0x914aa50) at kernel/qtimer.cpp:308
#28 0x00598994 in QObject::event (this=0x914aa50, e=0xbf8beeac) at kernel/qobject.cpp:1181
#29 0x047aad84 in notify_helper (e=0xbf8beeac, receiver=0x914aa50, this=0x9008248) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9008248, receiver=0x914aa50, e=0xbf8beeac) at kernel/qapplication.cpp:4458
#31 0x047b0133 in QApplication::notify (this=0xbf8beeac, receiver=0x914aa50, e=0xbf8beeac) at kernel/qapplication.cpp:3886
#32 0x00c3a971 in KApplication::notify (this=0xbf8bf1c0, receiver=0x914aa50, event=0xbf8beeac) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0058019e in QCoreApplication::notifyInternal (this=0xbf8bf1c0, receiver=0x914aa50, event=0xbf8beeac) at kernel/qcoreapplication.cpp:787
#34 0x005b0c10 in sendEvent (event=0xbf8beeac, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x900b7a4) at kernel/qeventdispatcher_unix.cpp:603
#36 0x005ae122 in timerSourceDispatch (source=0x900b770) at kernel/qeventdispatcher_glib.cpp:184
#37 0x01f4825f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x01f48990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x01f48c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x005aeada in QEventDispatcherGlib::processEvents (this=0x8feb238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x04862e7a in QGuiEventDispatcherGlib::processEvents (this=0x8feb238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x0057f1dd in QEventLoop::processEvents (this=0xbf8bf124, flags=...) at kernel/qeventloop.cpp:149
#43 0x0057f421 in QEventLoop::exec (this=0xbf8bf124, flags=...) at kernel/qeventloop.cpp:201
#44 0x0058419d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x047a8924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61


Reproducible: Always

Steps to Reproduce:
1.Go to the Muon Software Center
2. Double Click on it (I have my mouse settings to doube click)
3. The box for Muon pops up but it is empty and then it crashes.
Actual Results:  
Muon crashes and asks if I want to submit a bug report.

Expected Results:  
It should have given me a listing of what I can install.

The first time it crashed, some issues happened with KDE. The file manager threw up an io-slave error and the program menu was empty. A restart fixed it and it did not happen on the second crash.
Comment 1 Christoph Feck 2012-03-08 18:23:22 UTC

*** This bug has been marked as a duplicate of bug 291262 ***