Bug 295495 - amarok crashed when closed while still playing file
Summary: amarok crashed when closed while still playing file
Status: RESOLVED DUPLICATE of bug 285951
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.5.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-07 22:52 UTC by xejakig884
Modified: 2012-05-07 12:24 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
DRKonqi crash log (35.35 KB, text/plain)
2012-03-07 22:52 UTC, xejakig884
Details

Note You need to log in before you can comment on or make changes to this bug.
Description xejakig884 2012-03-07 22:52:42 UTC
Created attachment 69354 [details]
DRKonqi crash log

I was playing a file and closed amarok. It crashed immediately.
Comment 1 Myriam Schweingruber 2012-05-07 12:24:26 UTC
Backtrace from attachment: (please always paste backtraces inline, else those are not searchable)


Thread 1 (Thread 0xb115b980 (LWP 19439)):
[KCrash Handler]
#7  0x00000000 in ?? ()
#8  0xb6d9f04e in qDeleteAll<QList<Collections::Collection*>::const_iterator> (end=..., begin=...) at /usr/include/qt4/QtCore/qalgorithms.h:322
#9  qDeleteAll<SmartPointerList<Collections::Collection> > (c=...) at /usr/include/qt4/QtCore/qalgorithms.h:330
#10 CollectionManager::~CollectionManager (this=0x9df67a0, __in_chrg=<optimized out>) at ../../src/core-impl/collections/support/CollectionManager.cpp:137
#11 0xb6d9f292 in CollectionManager::~CollectionManager (this=0x9df67a0, __in_chrg=<optimized out>) at ../../src/core-impl/collections/support/CollectionManager.cpp:145
#12 0xb6d9d29a in CollectionManager::destroy () at ../../src/core-impl/collections/support/CollectionManager.cpp:107
#13 0xb6ee9c6a in App::~App (this=0xbf9c73f4, __in_chrg=<optimized out>) at ../../src/App.cpp:248
#14 0x0804fc3c in main (argc=0, argv=0x0) at ../../src/main.cpp:303

*** This bug has been marked as a duplicate of bug 285951 ***