Bug 295468 - Username need not be a required field
Summary: Username need not be a required field
Status: RESOLVED DUPLICATE of bug 286855
Alias: None
Product: Network Management
Classification: Unclassified
Component: VPNC (show other bugs)
Version: 0.9
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Lamarque V. Souza
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-07 13:53 UTC by Vincent Batts
Modified: 2012-07-25 19:47 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
'OK' is grayed out (68.23 KB, image/png)
2012-03-07 13:53 UTC, Vincent Batts
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vincent Batts 2012-03-07 13:53:38 UTC
Created attachment 69348 [details]
'OK' is grayed out

The attached picture shows a currently working profile for NetworkManager, but the KDE connection editor will not allow the Username field to be empty. It keeps the 'OK' button grayed out.
In the gnome applet, it allows me to submit an empty username, or editing the '/etc/NetworkManager/system-connections/...' file directly.

A sample of that connection file, in working order for my employers Cisco termination point is:
<< EOF

[vpn]
service-type=org.freedesktop.NetworkManager.vpnc
NAT Traversal Mode=natt
IPSec secret-flags=1
Vendor=cisco
Cisco UDP Encapsulation Port=0
Xauth username=
IPSec gateway=255.255.255.255
IPSec ID=foo-bar
Xauth password-flags=2
Perfect Forward Secrecy=server
IKE DH Group=dh2
Local Port=0
EOF

Please allow the validation of the information in the connection editor to allow the Username field to be empty, and still click 'OK'

Thanks,
vb
Comment 1 Lamarque V. Souza 2012-03-07 14:30:16 UTC

*** This bug has been marked as a duplicate of bug 286855 ***
Comment 2 mail 2012-07-25 18:34:01 UTC
I don't understand how this is a duplicate of 286855.
That was for the no authentication required option.

I have a similar problem to the OP.  I want to distribute an image with the VPN details pre-populated (group, gateway etc), but use the 'Always Ask' option to request user credentials in the connection pop-up.

This works for the user password, but not for the username.  
As with the attached image, the OK button is greyed out until a username is specified.

Surely the purpose of 'Always Ask' is to request credentials at connection time - with a prefilled username being optional.

It would be OK if a dummy username could be submitted, then changed on the connection pop-up - but by then it too is greyed out.

Unless I'm missing an update (Kubuntu 12.04), can this bug be re-opened?
Comment 3 Lamarque V. Souza 2012-07-25 19:00:40 UTC
Both this bug and 286855 talk about the same problem, it is obvious this one is a duplicate. The answer for not allowing empty username is in https://bugs.kde.org/show_bug.cgi?id=286855#c4
Comment 4 mail 2012-07-25 19:31:43 UTC
Thanks for the quick reply.

But I don't understand:

286855 describes when authentication is set to "Not Required", which is unsupported by vpnc, as you pointed out.
295468 describes when authentication is set to "Always Ask", ie. not pre-populated, but entered in the connection pop-up at a later time.

Currently you can enter the password at the connection stage, but the username has to be pre-filled at the VPN setup stage.

Can this not be delayed until connection?

What invokes vpnc?  The VPN setup dialog, or the connection pop-up?
Comment 5 Lamarque V. Souza 2012-07-25 19:47:16 UTC
It is NetworkManager that invokes vpnc. The username is not a secret, so there is no "Always Ask" flag for them in NetworkManager. Therefor I cannot implement an "Always Ask" option for it (not even nm-applet implements that).