Bug 295465 - high cpu spikes and stalling on selecting another payee
Summary: high cpu spikes and stalling on selecting another payee
Status: RESOLVED DUPLICATE of bug 268274
Alias: None
Product: kmymoney
Classification: Unclassified
Component: general (show other bugs)
Version: 4.5.3
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KMyMoney Devel Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-07 13:06 UTC by Martin Tlustos
Modified: 2012-03-07 13:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Tlustos 2012-03-07 13:06:53 UTC
User-Agent:       Mozilla/5.0 (X11; Linux i686) AppleWebKit/535.11 (KHTML, like Gecko) Ubuntu/11.10 Chromium/17.0.963.65 Chrome/17.0.963.65 Safari/535.11
Build Identifier: 

When selecting another payee, kmymoney stalls for a time (up to a minute sometimes), with cpu usage going up to over 90%, but no hd i/o.

Reproducible: Always

Steps to Reproduce:
1.Open payees list
2.select payee
3. maybe select another payee (to be sure or to compare
Actual Results:  
high cpu, it takes ages to display the information

Expected Results:  
Information should be displayed much more quickly.

I have a rather large file (508 payees, 11,000+ book entries). I tried using mysql but didn't see a big difference and went back to xml because mysql was said to be a beta feature.
Comment 1 Cristian Oneț 2012-03-07 13:17:06 UTC

*** This bug has been marked as a duplicate of bug 268274 ***