Bug 295454 - Kmail crashes when displaying e-mail from message list
Summary: Kmail crashes when displaying e-mail from message list
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kmail2
Classification: Applications
Component: message list (show other bugs)
Version: 4.8
Platform: Ubuntu Linux
: NOR critical with 4 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-07 08:07 UTC by karaluh
Modified: 2012-03-07 09:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description karaluh 2012-03-07 08:07:02 UTC
User-Agent:       Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:10.0.2) Gecko/20100101 Firefox/10.0.2
Build Identifier: 

As in summary, it's 100% reproducable
Thread 1 (Thread 0xb5f8a730 (LWP 25979)):
[KCrash Handler]
#7  0x01a70cf5 in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x9f43918, hm=) at access/qnetworkaccesshttpbackend.cpp:805
#8  0x01b07d0d in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x9f43918, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xaa8ad58) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#9  0x00cef411 in QMetaCallEvent::placeMetaCall (this=0xaa8aab0, object=0x9f43918) at kernel/qobject.cpp:525
#10 0x00cf848b in QObject::event (this=0x9f43918, e=0xaa8aab0) at kernel/qobject.cpp:1195
#11 0x01079844 in notify_helper (e=0xaa8aab0, receiver=0x9f43918, this=0x9825770) at kernel/qapplication.cpp:4555
#12 QApplicationPrivate::notify_helper (this=0x9825770, receiver=0x9f43918, e=0xaa8aab0) at kernel/qapplication.cpp:4527
#13 0x0107ec7d in QApplication::notify (this=0xaa8aab0, receiver=0x9f43918, e=0xaa8aab0) at kernel/qapplication.cpp:4284
#14 0x002f9051 in KApplication::notify (this=0xbffecffc, receiver=0x9f43918, event=0xaa8aab0) at ../../kdeui/kernel/kapplication.cpp:311
#15 0x00cdd18e in QCoreApplication::notifyInternal (this=0xbffecffc, receiver=0x9f43918, event=0xaa8aab0) at kernel/qcoreapplication.cpp:876
#16 0x00ce12e8 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#17 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x97cc150) at kernel/qcoreapplication.cpp:1500
#18 0x00ce161c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#19 0x00d0fd74 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#20 postEventSourceDispatch (s=0x98278d0) at kernel/qeventdispatcher_glib.cpp:279
#21 0x0784a25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#22 0x0784a990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#23 0x0784ac2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#24 0x00d10167 in QEventDispatcherGlib::processEvents (this=0x97ccef0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#25 0x0112efda in QGuiEventDispatcherGlib::processEvents (this=0x97ccef0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#26 0x00cdbd1d in QEventLoop::processEvents (this=0xbffecf24, flags=...) at kernel/qeventloop.cpp:149
#27 0x00cdbfb9 in QEventLoop::exec (this=0xbffecf24, flags=...) at kernel/qeventloop.cpp:204
#28 0x00ce16ca in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#29 0x010776a4 in QApplication::exec () at kernel/qapplication.cpp:3816
#30 0x0804a266 in main (argc=) at ../../kmail/main.cpp:145

Reproducible: Always
Comment 1 Laurent Montel 2012-03-07 09:17:44 UTC

*** This bug has been marked as a duplicate of bug 286307 ***