Bug 295295 - Save Link… context menu saves the target without asking where first (regression)
Summary: Save Link… context menu saves the target without asking where first (regression)
Status: RESOLVED NOT A BUG
Alias: None
Product: rekonq
Classification: Applications
Component: general (show other bugs)
Version: 0.9.0
Platform: Chakra Linux
: NOR normal
Target Milestone: ---
Assignee: Andrea Diamantini
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-04 09:42 UTC by Adrián Chaves (Gallaecio)
Modified: 2012-03-05 22:04 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adrián Chaves (Gallaecio) 2012-03-04 09:42:41 UTC
User-Agent:       Mozilla/5.0 (X11; Linux i686) AppleWebKit/534.34 (KHTML, like Gecko) rekonq Safari/534.34
Build Identifier: 0.9.0

When I right-click a link and then click on Save Link…, it saves the target diectly to my home folder instead of asking me where to save it.

Reproducible: Always

Steps to Reproduce:
1. Open http://chakra.sourceforge.net/ccr/packages.php?O=0&K=lives&do_Search=Go in Rekonq.
2. Right click “Tarball”, and select “Save Link…”.
Actual Results:  
The linked tarball is saved to the home folder.

Expected Results:  
Rekonq should (and used to) open a dialog for you to choose the destination path.

If I directly click on the link, it works as expected.
Comment 1 Johannes Obermayr 2012-03-04 10:29:29 UTC
Configure rekonq... -> General -> Always ask me where to save files
Comment 2 Adrián Chaves (Gallaecio) 2012-03-05 06:23:58 UTC
Ups, that setting must have been changed during the update from 0.8.

Anyway, I will take the opportunity to strongly suggest that “Save Link…” is changed to “Save Link”, since the ellipsis are meant to lead to another dialog, while it is possible that nothing else happens (visually on Rekonq) after you click that command.
Comment 3 Andrea Diamantini 2012-03-05 21:54:20 UTC
I agree we should anyway better notify started download. You can just see a note with downloaded file name of the bottom left.

The problem is I'd like to not create a "duplicate" of plasma notification system ;)
Different solutions will be investigated during next development cycles. I'll fix the "Save Link..." text as suggested.
Thanks.
Comment 4 Andrea Diamantini 2012-03-05 22:04:57 UTC
Git commit e30f9f58d5c2df9d02ae83f8ae2f5faee6f04814 by Andrea Diamantini.
Committed on 05/03/2012 at 23:09.
Pushed by adjam into branch 'master'.

Don't show dots after "Save Link" text if we are not going to ask for
download path

M  +9    -1    src/webview.cpp

http://commits.kde.org/rekonq/e30f9f58d5c2df9d02ae83f8ae2f5faee6f04814