Bug 295142 - Dragging a file with executable permission over the task bar doesn't raise window.
Summary: Dragging a file with executable permission over the task bar doesn't raise wi...
Status: RESOLVED INTENTIONAL
Alias: None
Product: plasma4
Classification: Plasma
Component: widget-taskbar (show other bugs)
Version: 4.9.1
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-01 14:55 UTC by dE
Modified: 2013-06-15 15:08 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dE 2012-03-01 14:55:11 UTC
Version:           unspecified
OS:                Linux

This's the same as bug Bug 261443, but it's not yet fixed.

For e.g. if you try and drag a file over K3b which is at the taskbar, K3b's window won't get raised if the file has x bit set.

Reproducible: Didn't try


Actual Results:  
 

Expected Results:
Comment 1 dE 2012-03-06 08:24:39 UTC
Any particular reason why?
Comment 2 Myriam Schweingruber 2012-05-22 10:20:34 UTC
And which version is this report about?
Comment 3 dE 2012-05-22 14:04:59 UTC
Done
Comment 4 dE 2012-09-23 12:37:40 UTC
Ironic, this bug is not yet fixed.
Comment 5 Mathias Tillman 2012-09-24 10:57:13 UTC
I can confirm this bug in 4.9.1. The problem here is that shouldIgnoreDragEvent method of kde-workspace/plasma/desktop/applets/tasks/abstracttaskitem.cpp is set to ignore executable files, as executable files are "supposed" to be used as launchers.

One easy way to reproduce is by trying to drag and drop a file from an NTFS drive (without the noexec flag), since NTFS partition files are set to be executable by default.
Comment 6 Myriam Schweingruber 2012-10-11 10:27:12 UTC
Setting status to confirmed.
Comment 7 Aaron J. Seigo 2013-06-15 15:08:25 UTC
This is because dropping executables creates launchers. Dropping files, executables or otherwise, is a lower priority feature than launcher support, so when choosing what behaviour to adopt launcher support was selected.