Bug 294707 - konqueror w/ webkit crashed when idle
Summary: konqueror w/ webkit crashed when idle
Status: RESOLVED UPSTREAM
Alias: None
Product: kdelibs
Classification: Unclassified
Component: kdewebkit (show other bugs)
Version: 4.8
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: webkit-devel
URL:
Keywords:
: 287914 295009 299490 310918 316867 317578 318695 319827 320042 324042 325827 330328 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-02-23 19:17 UTC by argonel
Modified: 2015-05-24 08:13 UTC (History)
18 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (9.75 KB, text/plain)
2012-12-10 07:06 UTC, kavol
Details
New crash information added by DrKonqi (8.59 KB, text/plain)
2013-02-10 21:35 UTC, kavol
Details
New crash information added by DrKonqi (12.64 KB, text/plain)
2013-03-11 09:09 UTC, m.wege
Details
New crash information added by DrKonqi (44.06 KB, text/plain)
2013-03-24 12:20 UTC, kavol
Details
New crash information added by DrKonqi (3.59 KB, text/plain)
2013-11-18 16:11 UTC, Francesco Riosa
Details
New crash information added by DrKonqi (29.13 KB, text/plain)
2015-05-24 08:13 UTC, kavol
Details
New crash information added by DrKonqi (29.13 KB, text/plain)
2015-05-24 08:13 UTC, kavol
Details

Note You need to log in before you can comment on or make changes to this bug.
Description argonel 2012-02-23 19:17:33 UTC
Application: konqueror (4.8.00 (4.8.0)
KDE Platform Version: 4.8.00 (4.8.0
Qt Version: 4.8.0
Operating System: Linux 3.2.6-3.fc16.x86_64 x86_64
Distribution: "Fedora release 16 (Verne)"

-- Information about the crash:
This instance of Konqueror hadn't been used in quite a while, it had 4 wikipedia tabs open. There were 6 other instances of Konqueror open that did not crash during the same idle period.

-- Backtrace:
Application: Konqueror (konqueror), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7fe90e36a840 (LWP 14276))]

Thread 4 (Thread 0x7fe90146b700 (LWP 14277)):
#0  0x0000003d9c8443e5 in g_main_context_query (context=0x7fe8fc0009a0, max_priority=2147483647, timeout=0x7fe90146abec, fds=0x7fe8fc0013e0, n_fds=1) at gmain.c:2835
#1  0x0000003d9c844eda in g_main_context_iterate (context=0x7fe8fc0009a0, block=1, dispatch=1, self=<optimized out>) at gmain.c:3071
#2  0x0000003d9c84549c in g_main_context_iteration (context=0x7fe8fc0009a0, may_block=1) at gmain.c:3152
#3  0x0000003da51a7dc6 in QEventDispatcherGlib::processEvents (this=0x7fe8fc0008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x0000003da5178182 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x0000003da51783d7 in QEventLoop::exec (this=0x7fe90146ad10, flags=...) at kernel/qeventloop.cpp:204
#6  0x0000003da5078b27 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x0000003d8cbb3dbe in KIO::NameLookUpThread::run (this=0x1191950) at /usr/src/debug/kdelibs-4.8.0/kio/kio/hostinfo.cpp:226
#8  0x0000003da507bb6b in QThreadPrivate::start (arg=0x1191950) at thread/qthread_unix.cpp:298
#9  0x0000003d9d007d90 in start_thread (arg=0x7fe90146b700) at pthread_create.c:309
#10 0x0000003d9ccef48d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 3 (Thread 0x7fe8fb848700 (LWP 14279)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:165
#1  0x0000003d93db86ec in WTF::TCMalloc_PageHeap::scavengerThread (this=0x3d9477cc20) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#2  0x0000003d93db8819 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#3  0x0000003d9d007d90 in start_thread (arg=0x7fe8fb848700) at pthread_create.c:309
#4  0x0000003d9ccef48d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7fe8fb047700 (LWP 14280)):
#0  0x0000003d9cce6af3 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x0000003d9c844fd8 in g_main_context_poll (n_fds=1, fds=0x7fe8f00013e0, priority=<optimized out>, timeout=7477, context=0x7fe8f00009a0) at gmain.c:3402
#2  g_main_context_iterate (context=0x7fe8f00009a0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3084
#3  0x0000003d9c84549c in g_main_context_iteration (context=0x7fe8f00009a0, may_block=1) at gmain.c:3152
#4  0x0000003da51a7dc6 in QEventDispatcherGlib::processEvents (this=0x7fe8f00008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x0000003da5178182 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x0000003da51783d7 in QEventLoop::exec (this=0x7fe8fb046d40, flags=...) at kernel/qeventloop.cpp:204
#7  0x0000003da5078b27 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x0000003da507bb6b in QThreadPrivate::start (arg=0x169c840) at thread/qthread_unix.cpp:298
#9  0x0000003d9d007d90 in start_thread (arg=0x7fe8fb047700) at pthread_create.c:309
#10 0x0000003d9ccef48d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7fe90e36a840 (LWP 14276)):
[KCrash Handler]
#6  0x0000003da518c562 in QObject::disconnect (sender=0x2691c60, signal=0x0, receiver=0x24d52c0, method=0x30ad4c9 "receiveMetaData()") at kernel/qobject.cpp:2891
#7  0x0000003d93a921ee in disconnect (member=0x3d94090f0f "1receiveMetaData()", receiver=0x24d52c0, this=<optimized out>) at /usr/include/QtCore/qobject.h:252
#8  WebCore::QNetworkReplyWrapper::resetConnections (this=0x24d52c0) at ../../../Source/WebCore/platform/network/qt/QNetworkReplyHandler.cpp:254
#9  0x0000003d93a9224f in WebCore::QNetworkReplyWrapper::release (this=0x24d52c0) at ../../../Source/WebCore/platform/network/qt/QNetworkReplyHandler.cpp:235
#10 0x0000003d93a923b8 in WebCore::QNetworkReplyHandler::release (this=0x3529e90) at ../../../Source/WebCore/platform/network/qt/QNetworkReplyHandler.cpp:425
#11 0x0000003d93a923fe in WebCore::QNetworkReplyHandler::abort (this=0x3529e90) at ../../../Source/WebCore/platform/network/qt/QNetworkReplyHandler.cpp:413
#12 0x0000003d93a8f509 in WebCore::ResourceHandle::cancel (this=0x7fe8a9fb3be8) at ../../../Source/WebCore/platform/network/qt/ResourceHandleQt.cpp:107
#13 0x0000003d93883d3c in (anonymous namespace)::PingLoader::~PingLoader (this=0x7fe8a9baa910, __in_chrg=<optimized out>) at ../../../Source/WebCore/loader/PingLoader.cpp:130
#14 0x0000003d93883de9 in (anonymous namespace)::PingLoader::~PingLoader (this=0x7fe8a9baa910, __in_chrg=<optimized out>) at ../../../Source/WebCore/loader/PingLoader.cpp:131
#15 0x0000003d939669d2 in WebCore::ThreadTimers::sharedTimerFiredInternal (this=0x7fe9000eb7a8) at ../../../Source/WebCore/platform/ThreadTimers.cpp:112
#16 0x0000003da5191c49 in QObject::event (this=0x16bb9b0, e=<optimized out>) at kernel/qobject.cpp:1157
#17 0x0000003d885c9994 in notify_helper (e=0x7ffff0e8a590, receiver=0x16bb9b0, this=0x11a9290) at kernel/qapplication.cpp:4550
#18 QApplicationPrivate::notify_helper (this=0x11a9290, receiver=0x16bb9b0, e=0x7ffff0e8a590) at kernel/qapplication.cpp:4522
#19 0x0000003d885ce813 in QApplication::notify (this=0x7ffff0e8aa00, receiver=0x16bb9b0, e=0x7ffff0e8a590) at kernel/qapplication.cpp:4411
#20 0x0000003d8a050eb6 in KApplication::notify (this=0x7ffff0e8aa00, receiver=0x16bb9b0, event=0x7ffff0e8a590) at /usr/src/debug/kdelibs-4.8.0/kdeui/kernel/kapplication.cpp:311
#21 0x0000003da517904c in QCoreApplication::notifyInternal (this=0x7ffff0e8aa00, receiver=0x16bb9b0, event=0x7ffff0e8a590) at kernel/qcoreapplication.cpp:876
#22 0x0000003da51a9b52 in sendEvent (event=0x7ffff0e8a590, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#23 QTimerInfoList::activateTimers (this=0x11ab950) at kernel/qeventdispatcher_unix.cpp:611
#24 0x0000003da51a752d in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:186
#25 timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:180
#26 0x0000003da51a7551 in idleTimerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:233
#27 0x0000003d9c844acd in g_main_dispatch (context=0x11abdf0) at gmain.c:2441
#28 g_main_context_dispatch (context=0x11abdf0) at gmain.c:3011
#29 0x0000003d9c8452c8 in g_main_context_iterate (context=0x11abdf0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3089
#30 0x0000003d9c84549c in g_main_context_iteration (context=0x11abdf0, may_block=1) at gmain.c:3152
#31 0x0000003da51a7d5f in QEventDispatcherGlib::processEvents (this=0x117e510, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#32 0x0000003d8866c66e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#33 0x0000003da5178182 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x0000003da51783d7 in QEventLoop::exec (this=0x7ffff0e8a830, flags=...) at kernel/qeventloop.cpp:204
#35 0x0000003da517cdd5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#36 0x0000003d8d0b5ca2 in kdemain () from /usr/lib64/libkdeinit4_konqueror.so
#37 0x0000003d9cc2169d in __libc_start_main (main=0x4007c0, argc=2, ubp_av=0x7ffff0e8b2c8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffff0e8b2b8) at libc-start.c:226
#38 0x00000000004007f1 in _start ()

Reported using DrKonqi
Comment 1 Dawit Alemayehu 2012-03-05 20:38:18 UTC
This is a QtWebKit issue and needs to be reported upstream. See http://trac.webkit.org/wiki/QtWebKitBugs.
Comment 2 Christophe Giboudeaux 2012-03-31 12:43:41 UTC
*** Bug 287914 has been marked as a duplicate of this bug. ***
Comment 3 Christophe Giboudeaux 2012-03-31 12:43:57 UTC
*** Bug 295009 has been marked as a duplicate of this bug. ***
Comment 4 Raúl 2012-05-06 11:03:42 UTC
I reported upstream[0], but looks not much attention paid. I'm not sure if there's anything else to be done.
[0] https://bugs.webkit.org/show_bug.cgi?id=81041
Comment 5 Jekyll Wu 2012-05-06 11:42:06 UTC
*** Bug 299490 has been marked as a duplicate of this bug. ***
Comment 6 Jekyll Wu 2012-11-30 13:25:48 UTC
*** Bug 310918 has been marked as a duplicate of this bug. ***
Comment 7 kavol 2012-12-10 07:06:46 UTC
Created attachment 75763 [details]
New crash information added by DrKonqi

konqueror (4.9.3) on KDE Platform 4.9.3 using Qt 4.8.2

- What I was doing when the application crashed:

the same, just left it overnight (without suspending) ... is there really nothing to do at KDE side?

-- Backtrace (Reduced):
#6  0x00007f1ea0fcc88d in QObject::disconnect (sender=0xd7ac630, signal=0x0, receiver=0x38dacf0, method=0xe74ef39 "receiveMetaData()") at kernel/qobject.cpp:2891
#7  0x00007f1e90fe346e in disconnect (member=0x7f1e915fc66f "1receiveMetaData()", receiver=0x38dacf0, this=<optimized out>) at ../../../../../include/QtCore/../../src/corelib/kernel/qobject.h:252
#8  WebCore::QNetworkReplyWrapper::resetConnections (this=0x38dacf0) at platform/network/qt/QNetworkReplyHandler.cpp:254
#9  0x00007f1e90fe34cf in WebCore::QNetworkReplyWrapper::release (this=0x38dacf0) at platform/network/qt/QNetworkReplyHandler.cpp:235
#10 0x00007f1e90fe3651 in WebCore::QNetworkReplyHandler::release (this=0x2b231a0) at platform/network/qt/QNetworkReplyHandler.cpp:419
Comment 8 kavol 2013-02-10 21:35:20 UTC
Created attachment 77114 [details]
New crash information added by DrKonqi

konqueror (4.9.5) on KDE Platform 4.9.5 using Qt 4.8.4

- What I was doing when the application crashed:

still the same with newer version ... does the crash of the engine (if I get it right) really need to kill the whole browser? what about some sandboxing?

-- Backtrace (Reduced):
#6  0x00007f40a7e496ef in QObject::disconnect (sender=0x478aae0, signal=0x0, receiver=0x4c62bd0, method=0x4d3be69 "receiveMetaData()") at kernel/qobject.cpp:2887
#7  0x00007f409372dfde in disconnect (member=0x7f4093d0c66f "1receiveMetaData()", receiver=0x4c62bd0, this=<optimized out>) at /usr/include/QtCore/qobject.h:252
#8  WebCore::QNetworkReplyWrapper::resetConnections (this=0x4c62bd0) at platform/network/qt/QNetworkReplyHandler.cpp:254
#9  0x00007f409372e03d in WebCore::QNetworkReplyWrapper::release (this=0x4c62bd0) at platform/network/qt/QNetworkReplyHandler.cpp:235
#10 0x00007f409372e1b6 in WebCore::QNetworkReplyHandler::release (this=this@entry=0x4b1dbd0) at platform/network/qt/QNetworkReplyHandler.cpp:419
Comment 9 Dawit Alemayehu 2013-02-10 23:57:58 UTC
(In reply to comment #8)
> Created attachment 77114 [details]
> New crash information added by DrKonqi
> 
> konqueror (4.9.5) on KDE Platform 4.9.5 using Qt 4.8.4
> 
> - What I was doing when the application crashed:
> 
> still the same with newer version ... does the crash of the engine (if I get
> it right) really need to kill the whole browser? what about some sandboxing?

It is not the newer version of KDE you need. It is a newer version the browser engine (QtWebKit). The version that is included with Qt 4.8.4 is old (QtWebKit 2.2). There is a beta version for Qtwebkit 2.3 with a more recent version of webkit that includes tons of fixes. Even then, as already stated, the crash is upstream and you need to report it there. Nothing we can do about that here.
Comment 10 m.wege 2013-03-11 09:09:51 UTC
Created attachment 77939 [details]
New crash information added by DrKonqi

akregator (4.10.1) on KDE Platform 4.10.1 using Qt 4.8.3

- What I was doing when the application crashed: Crash happenend after waking up from suspension.

-- Backtrace (Reduced):
#6  0x00007f6873f4e70f in QObject::disconnect (sender=0x20278cd0, signal=0x0, receiver=0x135e0ec0, method=0x22bc6189 "receiveMetaData()") at kernel/qobject.cpp:2891
#7  0x00007f6858cfd0ae in disconnect (member=0x7f68592d75cf "1receiveMetaData()", receiver=0x135e0ec0, this=<optimized out>) at /usr/include/qt4/QtCore/qobject.h:252
#8  WebCore::QNetworkReplyWrapper::resetConnections (this=0x135e0ec0) at platform/network/qt/QNetworkReplyHandler.cpp:254
#9  0x00007f6858cfd10d in WebCore::QNetworkReplyWrapper::release (this=0x135e0ec0) at platform/network/qt/QNetworkReplyHandler.cpp:235
#10 0x00007f6858cfd286 in WebCore::QNetworkReplyHandler::release (this=this@entry=0x18315d00) at platform/network/qt/QNetworkReplyHandler.cpp:419
Comment 11 Jekyll Wu 2013-03-17 01:03:26 UTC
*** Bug 316867 has been marked as a duplicate of this bug. ***
Comment 12 kavol 2013-03-24 12:20:00 UTC
Created attachment 78347 [details]
New crash information added by DrKonqi

konqueror (4.10.1) on KDE Platform 4.10.1 using Qt 4.8.4

- What I was doing when the application crashed:

just FTR, still happens with all Fedora 18 updates

-- Backtrace (Reduced):
#7  0x00007f046712c721 in QObject::disconnect (sender=0x5907d80, signal=0x0, receiver=0x4907730, method=0x8a820c9 "receiveMetaData()") at kernel/qobject.cpp:2887
#8  0x00007f0452a00fde in disconnect (member=0x7f0452fdf66f "1receiveMetaData()", receiver=0x4907730, this=<optimized out>) at /usr/include/QtCore/qobject.h:252
#9  WebCore::QNetworkReplyWrapper::resetConnections (this=0x4907730) at platform/network/qt/QNetworkReplyHandler.cpp:254
#10 0x00007f0452a0103d in WebCore::QNetworkReplyWrapper::release (this=0x4907730) at platform/network/qt/QNetworkReplyHandler.cpp:235
#11 0x00007f0452a011b6 in WebCore::QNetworkReplyHandler::release (this=this@entry=0x5e18ac0) at platform/network/qt/QNetworkReplyHandler.cpp:419
Comment 13 Tommi Tervo 2013-03-30 15:11:56 UTC
*** Bug 317578 has been marked as a duplicate of this bug. ***
Comment 14 Jekyll Wu 2013-04-22 05:25:49 UTC
*** Bug 318695 has been marked as a duplicate of this bug. ***
Comment 15 Jonathan Marten 2013-07-11 20:28:38 UTC
*** Bug 320042 has been marked as a duplicate of this bug. ***
Comment 16 Jonathan Marten 2013-07-11 20:29:27 UTC
*** Bug 319827 has been marked as a duplicate of this bug. ***
Comment 17 Thomas Tanghus 2013-07-12 13:26:12 UTC
(In reply to comment #9)
> There is a beta version for Qtwebkit 2.3 with a more recent
> version of webkit that includes tons of fixes.

Is it feasible to compile Qtwebkit 2.3 under Qt 4.8.4 to get a working kdewebkit? What do the devs use?

This issue renders Akregator almost unusable using kwebkitpart, so I switched to KHTML, and the 2½ years old https://bugs.kde.org/show_bug.cgi?id=264526 showed it's grim face.
Comment 18 Thomas Tanghus 2013-07-12 13:55:09 UTC
(In reply to comment #17)
> (In reply to comment #9)
> > There is a beta version for Qtwebkit 2.3 with a more recent
> > version of webkit that includes tons of fixes.
> Is it feasible to compile Qtwebkit 2.3 under Qt 4.8.4 to get a working
> kdewebkit? What do the devs use?

Ignore that. Seems I'm already using 2.3

aptitude show libqtwebkit4
Package: libqtwebkit4                    
New: yes
State: installed
Automatically installed: no
Multi-Arch: same
Version: 2.3.0-0ubuntu2.1
Priority: optional
Section: libs
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Architecture: amd64
Uncompressed Size: 35.1 M
Depends: libc6 (>= 2.14), libfontconfig1 (>= 2.9.0), libgcc1 (>= 1:4.1.1), libgl1-mesa-glx | libgl1, libglib2.0-0 (>= 2.31.8), libgstreamer-plugins-base0.10-0 (>= 0.10.31),
         libgstreamer0.10-0 (>= 0.10.31), libjpeg8 (>= 8c), libpng12-0 (>= 1.2.13-4), libqt4-network (>= 4:4.7.0~beta1), libqt4-opengl (>= 4:4.5.3), libqtcore4 (>= 4:4.8.0),
         libqtgui4 (>= 4:4.8.0), libsqlite3-0 (>= 3.5.9), libstdc++6 (>= 4.2.1), libx11-6, libxml2 (>= 2.7.4), libxrender1, libxslt1.1 (>= 1.1.25), zlib1g (>= 1:1.2.0)
PreDepends: multiarch-support
Breaks: libqtwebkit4 (!= 2.3.0-0ubuntu2.1)
Replaces: libqt4-webkit (<= 4:4.7.0~beta1), libqt4-webkit (<= 4:4.7.0~beta1), libqtwebkit4 (< 2.3.0-0ubuntu2.1)
Description: Web content engine library for Qt
 QtWebKit provides a Web browser engine that makes it easy to embed content from the World Wide Web into your Qt application.
Homepage: http://trac.webkit.org/wiki/QtWebKit

Wonder what it takes to make the Qt devs react on https://bugs.webkit.org/show_bug.cgi?id=81041
Comment 19 Jonathan Marten 2013-07-22 16:55:30 UTC
Not really enough testing to say that it is definitely fixed, but I have not observed this crash in either konqueror or akregator since building Qt WebKit 2.3.2 separately.  Pulled from gitorious repo as described at
http://blogs.kde.org/2013/07/17/qtwebkit-232-and-qtwebkit-qt-51
Comment 20 Dominik Haumann 2013-08-30 21:18:32 UTC
*** Bug 324042 has been marked as a duplicate of this bug. ***
Comment 21 Dawit Alemayehu 2013-10-10 10:54:30 UTC
*** Bug 325827 has been marked as a duplicate of this bug. ***
Comment 22 Francesco Riosa 2013-11-18 16:11:53 UTC
Created attachment 83622 [details]
New crash information added by DrKonqi

konqueror (4.11.3) on KDE Platform 4.11.3 using Qt 4.8.5

- What I was doing when the application crashed:

long time without using konqueror, on returning to the PC on day later konqui was there

so probably this is not fixed

-- Backtrace (Reduced):
#6  0x00007f0b0369e3f1 in QObject::disconnect(QObject const*, char const*, QObject const*, char const*) () from /usr/lib64/qt4/libQtCore.so.4
#7  0x00007f0af577783e in WebCore::QNetworkReplyWrapper::resetConnections() () from /usr/lib64/qt4/libQtWebKit.so.4
#8  0x00007f0af5777897 in WebCore::QNetworkReplyWrapper::release() () from /usr/lib64/qt4/libQtWebKit.so.4
#9  0x00007f0af5777a02 in WebCore::QNetworkReplyHandler::release() () from /usr/lib64/qt4/libQtWebKit.so.4
#10 0x00007f0af5777a46 in WebCore::QNetworkReplyHandler::abort() () from /usr/lib64/qt4/libQtWebKit.so.4
Comment 23 Jekyll Wu 2014-01-24 01:07:54 UTC
*** Bug 330328 has been marked as a duplicate of this bug. ***
Comment 24 Thomas Tanghus 2014-01-24 01:46:17 UTC
(In reply to comment #19)
> Not really enough testing to say that it is definitely fixed, but I have not
> observed this crash in either konqueror or akregator since building Qt
> WebKit 2.3.2 separately.  Pulled from gitorious repo as described at
> http://blogs.kde.org/2013/07/17/qtwebkit-232-and-qtwebkit-qt-51

I'm now on kdelibs 4.12 using Kubuntu 13.10 with libqtwebkit4 2.3.2 and haven't had that crash for a while, so it seems the bug is actually fixed after almost 2 years \o/

The fix revealed a massive memory leak in Akregator, which is the only place I use kwebkitpart...
Comment 25 kavol 2015-05-24 08:13:10 UTC
Created attachment 92806 [details]
New crash information added by DrKonqi

konqueror (4.14.3) on KDE Platform 4.14.3 using Qt 4.8.6

- What I was doing when the application crashed:

As usual, Konqueror left overnight, and it crashed.
I'm really not sure which version this should be fixed in as the latest comment about not seeing the crash any more talks about qtwebkit 2.something and I have 4.8.6 installed ...

-- Backtrace (Reduced):
#6  0x00007ff0aa54d847 in QObject::disconnect (sender=0x2d335f60, signal=signal@entry=0x0, receiver=receiver@entry=0x2d335e70, method=0x3ea3a809 "receiveMetaData()", method@entry=0x7ff09b843ad5 "1receiveMetaData()") at /var/tmp/portage/dev-qt/qtcore-4.8.6-r2/work/qt-everywhere-opensource-src-4.8.6/src/corelib/kernel/qobject.cpp:2911
#7  0x00007ff09b26364e in disconnect (member=0x7ff09b843ad5 "1receiveMetaData()", receiver=0x2d335e70, this=<optimized out>) at ../../../../../include/QtCore/../../../qt-everywhere-opensource-src-4.8.6/src/corelib/kernel/qobject.h:252
#8  WebCore::QNetworkReplyWrapper::resetConnections (this=this@entry=0x2d335e70) at /var/tmp/portage/dev-qt/qtwebkit-4.8.6-r1/work/qt-everywhere-opensource-src-4.8.6/src/3rdparty/webkit/Source/WebCore/platform/network/qt/QNetworkReplyHandler.cpp:254
#9  0x00007ff09b2636a7 in WebCore::QNetworkReplyWrapper::release (this=0x2d335e70) at /var/tmp/portage/dev-qt/qtwebkit-4.8.6-r1/work/qt-everywhere-opensource-src-4.8.6/src/3rdparty/webkit/Source/WebCore/platform/network/qt/QNetworkReplyHandler.cpp:235
#10 0x00007ff09b263802 in WebCore::QNetworkReplyHandler::release (this=this@entry=0x2d336030) at /var/tmp/portage/dev-qt/qtwebkit-4.8.6-r1/work/qt-everywhere-opensource-src-4.8.6/src/3rdparty/webkit/Source/WebCore/platform/network/qt/QNetworkReplyHandler.cpp:419
Comment 26 kavol 2015-05-24 08:13:10 UTC
Created attachment 92807 [details]
New crash information added by DrKonqi

konqueror (4.14.3) on KDE Platform 4.14.3 using Qt 4.8.6

- What I was doing when the application crashed:

As usual, Konqueror left overnight, and it crashed.
I'm really not sure which version this should be fixed in as the latest comment about not seeing the crash any more talks about qtwebkit 2.something and I have 4.8.6 installed ...

-- Backtrace (Reduced):
#6  0x00007ff0aa54d847 in QObject::disconnect (sender=0x2d335f60, signal=signal@entry=0x0, receiver=receiver@entry=0x2d335e70, method=0x3ea3a809 "receiveMetaData()", method@entry=0x7ff09b843ad5 "1receiveMetaData()") at /var/tmp/portage/dev-qt/qtcore-4.8.6-r2/work/qt-everywhere-opensource-src-4.8.6/src/corelib/kernel/qobject.cpp:2911
#7  0x00007ff09b26364e in disconnect (member=0x7ff09b843ad5 "1receiveMetaData()", receiver=0x2d335e70, this=<optimized out>) at ../../../../../include/QtCore/../../../qt-everywhere-opensource-src-4.8.6/src/corelib/kernel/qobject.h:252
#8  WebCore::QNetworkReplyWrapper::resetConnections (this=this@entry=0x2d335e70) at /var/tmp/portage/dev-qt/qtwebkit-4.8.6-r1/work/qt-everywhere-opensource-src-4.8.6/src/3rdparty/webkit/Source/WebCore/platform/network/qt/QNetworkReplyHandler.cpp:254
#9  0x00007ff09b2636a7 in WebCore::QNetworkReplyWrapper::release (this=0x2d335e70) at /var/tmp/portage/dev-qt/qtwebkit-4.8.6-r1/work/qt-everywhere-opensource-src-4.8.6/src/3rdparty/webkit/Source/WebCore/platform/network/qt/QNetworkReplyHandler.cpp:235
#10 0x00007ff09b263802 in WebCore::QNetworkReplyHandler::release (this=this@entry=0x2d336030) at /var/tmp/portage/dev-qt/qtwebkit-4.8.6-r1/work/qt-everywhere-opensource-src-4.8.6/src/3rdparty/webkit/Source/WebCore/platform/network/qt/QNetworkReplyHandler.cpp:419