Bug 294438 - nepomukfileindexer suspends when PowerDevil is disabled
Summary: nepomukfileindexer suspends when PowerDevil is disabled
Status: RESOLVED DUPLICATE of bug 300786
Alias: None
Product: nepomuk
Classification: Unclassified
Component: fileindexer (show other bugs)
Version: 4.8
Platform: Archlinux Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-19 16:25 UTC by Christoph Berg
Modified: 2012-06-21 14:28 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Berg 2012-02-19 16:25:29 UTC
Version:           4.8 (using KDE 4.8.0) 
OS:                Linux

After removing the complete Nepomuk configuration and Virtuoso database (because KMail told me, the semantic desktop is deactivated), I noticed that the Nepomuk KCM said that a communication error happend while contacting the org.kde.nepomuk.services.nepomukfileindexer service.

After removing all data/configuration again, I started nepomuk from the command line and got:

[/usr/bin/nepomukservicestub] nepomukfileindexer(27543)/nepomuk (strigi service) Nepomuk::EventMonitor::slotPowerManagementStatusChanged: Pausing indexer due to power management

after which Nepomuk posted repeating messages

NepomukServer(27523)/nepomuk (server) Nepomuk::ServiceController::slotIsInitializedDBusCallFinished: Failed to check service init state for "nepomukfileindexer" Retrying

Using GDB and a debug build, I traced it to the Solid::PowerManagement::appShouldConserveResources() method returning true even if the the power management service is deactivated.

When activating the PowerDevil service again, everything worked as it should. I'm on a desktop PC, so I deactivated the whole power saving stuff.

Reproducible: Always

Steps to Reproduce:
1. Remove the configuration files and virtuose database
2. Deactivate the PowerDevil service
3. Start nepomukserver from command line and look for the particular messages

Actual Results:  
Nepomuk bails about not being able to check init state of nepomukfileindexer

Expected Results:  
Nepomuk should do its first pass indexing
Comment 1 Daniel Nicoletti 2012-06-21 14:28:34 UTC

*** This bug has been marked as a duplicate of bug 300786 ***