Bug 294411 - kmail2 crash after google calendar, now not synchronizing imap account
Summary: kmail2 crash after google calendar, now not synchronizing imap account
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kmail2
Classification: Unclassified
Component: general (show other bugs)
Version: 4.7
Platform: openSUSE RPMs Linux
: NOR major (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-19 10:11 UTC by grglsn765
Modified: 2017-01-07 22:21 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description grglsn765 2012-02-19 10:11:07 UTC
Version:           4.7 (using KDE 4.7.4) 
OS:                Linux

Howdy,

Using openSUSE 12.1 and KDE 4.7.4 and Kmail 4.7.4.

The other day I tried to load the google calendar connection on akonadi. I 
tried to add a new calendar resource of the type "ical" and provided the 
location as the URL provided by google calendar. As soon as I did this, I lost 
my desktop, system tray, taskbar, and anything else associated with X except 
for a few things. The way this happened is my regular windows that I already 
had open I could alt-tab between, but my desktop background was black, the 
kicker and the entire lower bar where the system tray and taskbar reside were 
not there. Right clicking on the desktop would not give any menus. I was able 
to do alt-f2 and run an application that way.

I tried to reboot and it was the same thing, except that for about 2 seconds I 
was able to access one of my panels long enough to start up kontact again. I 
re-booted a couple of times with the same effect. Finally I started up kontact 
again and removed the google calendar resource. Once it was removed, 
everything went back to normal.

Except not everything, as I assumed. From that point on, Kmail2 stopped 
synchronizing one of my imap accounts. I have 3 imap accounts - 2 with gmail 
and 1 with yahoo. The imap account with gmail that I have set as my default 
account has not synchronized any email since last thursday. It also will not 
send. It says it sends the email by the indicator in the lower right corner, 
but it actually does not, because when I test send an email from that account 
to one of my other accounts, I never receive the email. I have verified that 
the problem is not with the server itself, for I can send and receive imap 
email on this account using thunderbird without any problem.

My other imap accounts do not seem to have any problem synchronizing.

George


Reproducible: Always

Steps to Reproduce:
the part that is reproducible is that my default imap account does not synchronize. I reproduce this by opening kmail and waiting, but it never synchronizes. I am not willing to try to connect google calendar again until I hear that problem is fixed.

Actual Results:  
nothing happens

Expected Results:  
the inbox and other folders should synchronize

I tried selecting server side subscriptions to make an adjustment to what it is looking for but it had no effect. The account will still not synchronize.
Comment 1 Denis Kurz 2016-09-24 18:09:25 UTC
This bug has only been reported for versions before 4.14, which have been unsupported for at least two years now. Can anyone tell if this bug still present?

If noone confirms this bug for a Framework-based version of kmail2 (version 5.0 or later, as part of KDE Applications 15.12 or later), it gets closed in about three months.
Comment 2 Denis Kurz 2017-01-07 22:21:01 UTC
Just as announced in my last comment, I close this bug. If you encounter it again in a recent version (at least 5.0 aka 15.08), please open a new one unless it already exists. Thank you for all your input.