Bug 294189 - ugly window decorations in opengl mode ati opensource driver
Summary: ugly window decorations in opengl mode ati opensource driver
Status: RESOLVED DUPLICATE of bug 282882
Alias: None
Product: kwin
Classification: Plasma
Component: scene-opengl (show other bugs)
Version: 4.8.0
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-15 22:00 UTC by flstcboy
Modified: 2012-02-15 22:08 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
opengl-mode (77.81 KB, image/png)
2012-02-15 22:00 UTC, flstcboy
Details
xrender-mode (78.00 KB, image/png)
2012-02-15 22:02 UTC, flstcboy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description flstcboy 2012-02-15 22:00:24 UTC
Created attachment 68835 [details]
opengl-mode

Version:           4.8.0 (using KDE 4.8.0) 
OS:                Linux

All window decorations looking ugly in opengl mode. using "render" the decorations are looking normal. screenshot attached!

graphics card is ATI 9200, hp compaq laptop.


---------------------
OpenGL vendor string:                   Tungsten Graphics, Inc.
OpenGL renderer string:                 Mesa DRI R200 (RV250 4C66) x86/MMX/SSE2 TCL DRI2
OpenGL version string:                  1.3 Mesa 7.11.1
Driver:                                 R200
GPU class:                              R200
OpenGL version:                         1.3
Mesa version:                           7.11.1
X server version:                       1.10.4
Linux kernel version:                   3.1.9
Direct rendering:                       yes
Requires strict binding:                yes
GLSL shaders:                           no
Texture NPOT support:                   no
---------------------

Facts:
Opensuse 12.1
KDE 4.8 Release repository
Extra repository for KDE 4.8 release !
X11/Xorg repository for openSUSE 12.1 (anyway, same issue without this repo!)


Reproducible: Didn't try

Steps to Reproduce:
update from kde4.7.4 to kde4.8 (release repository). using opensource driver for ATI 9200 (on a notebook). with or without latest X11/Xorg packages from repository.

Actual Results:  
all window decorations are malformed. it seems, that symbols are oversized and font rendering is ugly (screenshot attached)

Expected Results:  
window decorations just should look like same as using Xrender (not opengl)

the window decorations have been rendering correctly using opengl before update to kde 4.8 !
though, i noticed this kind of issue occurs occasionally after update to a new version of KDE. After some weeks it seems to fixed, is it still the "old nabble" you can find on google ??? ([Bug 172627] New: Kwin composite not rendering properly with Ati free drivers)

the bug affects every kwin window decoration, independent from plasmas' graphicssystem (raster or default) !
Comment 1 flstcboy 2012-02-15 22:02:41 UTC
Created attachment 68836 [details]
xrender-mode

here you can see the correct rendering of window decoration oxygen! don't care about the black color. the issue is the same when using default colors.
Comment 2 Thomas Lübking 2012-02-15 22:08:58 UTC
The black background is either configuration or inside the oxygen decoration.
The scale is the dupe.

*** This bug has been marked as a duplicate of bug 282882 ***