Bug 294169 - Calendar templates change date and time
Summary: Calendar templates change date and time
Status: RESOLVED FIXED
Alias: None
Product: korganizer
Classification: Unclassified
Component: general (show other bugs)
Version: 0.9
Platform: Ubuntu Packages Linux
: NOR major (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 283486 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-02-15 18:02 UTC by lnxusr
Modified: 2013-07-21 14:27 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lnxusr 2012-02-15 18:02:27 UTC
Version:           0.9 (using KDE 4.8.0) 
OS:                Linux

When utilizing a template in the calendar for a future date, the date and time selected are replaced with the date and time the template was created.  If the date and time were left blank when the template was created, the date is filled in with the current date and the event is set to take all day.  If the datetime stamp is deleted manually in the template/Events file, again the current date is used and the event is set to take all day.

Also, there seems to be quite a bit of garbage in the template file.  During testing, the file size ranged from 5K, 4K and 390 bytes for the same info.  There appears to be a lot of unneeded garbage in the larger files. 

Reproducible: Always

Steps to Reproduce:
Create an event template and try to use it on a future date.

Actual Results:  
Date and time are not left to the desired settings.

Expected Results:  
Date and time are left alone to the actual date and time I'm trying to set the event.

OS: Linux (i686) release 3.0.0-16-generic-pae
Compiler: gcc
Comment 1 Thomas Reitelbach 2012-03-03 12:53:58 UTC
I can confirm this issue on Windows "Kolab E5 RC" Version 4.8 rc2, downloaded as file "Kolab-E5-Client-2012-01-11-12-48.exe" from the kolab development team.

This is very annoying and makes the template feature unusable for me.
Comment 2 Martin Bříza 2012-06-19 14:39:11 UTC
This bug is also reported on the Red Hat Bugzilla for Fedora 16 (KDE SC 4.7.4) on https://bugzilla.redhat.com/show_bug.cgi?id=797404
Comment 3 Pino Toscano 2013-07-21 09:59:28 UTC
This seems a duplicate of #283486 (or the other way round).
Comment 4 Sergio Martins 2013-07-21 12:24:37 UTC
*** Bug 283486 has been marked as a duplicate of this bug. ***
Comment 5 Sergio Martins 2013-07-21 14:27:52 UTC
Git commit 2b160d53fe9c83fc2a0e65e510d0f02cb8670552 by Sergio Martins.
Committed on 21/07/2013 at 14:24.
Pushed by smartins into branch 'KDE/4.11'.

Don't let templates override the dates that the user chose.

Dates should never be overriden by templates.
Related: bug 190545

M  +62   -18   incidenceeditor-ng/incidencedatetime.cpp
M  +4    -0    incidenceeditor-ng/incidencedialog.cpp

http://commits.kde.org/kdepim/2b160d53fe9c83fc2a0e65e510d0f02cb8670552